3 Replies Latest reply on Aug 12, 2010 7:59 AM by davibu

    BUG: Crash inside clBuildProgram

    davibu

      Compiling the kernel available a this link http://src.luxrender.net/luxrays/raw-file/3e54a5b61b56/src/kernels/mqbvh_kernel.cl for a GPU Device cause a crash inside clBuildProgram().

       

      The same kernel is compiled and works fine with AMD OpenCL CPU device and NVIDIA OpenCL.

       

      As a proof of this bug you can just cut&paste the kernel inside Stream KernelAnalyzer and see how it crashes as soon as you hit the compile button.

       

        • BUG: Crash inside clBuildProgram
          MicahVillmow
          davibu,
          This does not seem to crash with our upcoming release.
            • BUG: Crash inside clBuildProgram
              davibu

              This bug is still present in SDK 2.2. The only progress was to obtain a "Internal error: Compilation failed." instead of a crash.

              It wasn't exactly the kind of fix I was looking for.

               

               

               

                • BUG: Crash inside clBuildProgram
                  davibu

                   

                  Originally posted by: davibu This bug is still present in SDK 2.2. The only progress was to obtain a "Internal error: Compilation failed." instead of a crash.

                   

                  It wasn't exactly the kind of fix I was looking for.

                  It looks like this is another kind of problem: I get a "Internal error: Compilation failed." message every time I try to run a executable compiled with SDK 2.1. If I recompile the sources, everything works fine. Both SDK 2.1 and 2.2 binaries work fine with NVIDIA OpenCL.

                  This happen with Ubuntu 10.04 64bit but it may be something related to my installation (i.e. I have all SDK since the first beta).

                  Instead, the original bug reported in this thread has been fixed.