Paccone

Samples don't work [SOLVED]

Discussion created by Paccone on Jul 20, 2010
Latest reply on Jul 20, 2010 by omkaranathan

Hi I can't get any sample binary work, all them report errors.

I set the environment variables as:

 

export ATISTREAMSDKROOT=/home/davide/Download/ati-stream-sdk-v2.1-lnx32/

export ATISTREAMSDKSAMPLESROOT=/home/davide/Download/ati-stream-sdk-v2.1-lnx32/

export LD_LIBRARY_PATH=$ATISTREAMSDKROOT/lib/x86:$LD_LIBRARY_PATH



then extract the "icd-registration.tgz" in the sdk root and link it to /usr/lib/OpenCL/vendors/libatiocl32.so so that I have:

 

ls -l /usr/lib/OpenCL/vendors/

lrwxrwxrwx 1 root root 71 Jul 20 17:42 libatiocl32.so -> /home/davide/Downloads/ati-stream-sdk-v2.1-lnx32/lib/x86/libatiocl32.so



Building the samples goes fine without errors (some warnings anyway):

 

/samples/opencl$ make


so samples shuld now be ready, but I get errors such as:

(Binary and associated error; other regular output suppressed)

 

Template -> Error: Getting Platforms. (clGetPlatformsIDs)

HelloCL -> Platform::get() failed (-1001)

SimpleImage -> Error: clGetPlatformIDs failed. Error code : unknown error code

FFT -> Error: clGetPlatformIDs failed. Error code : unknown error code

no one works.

I run Debian testing on intel cpu / gpu without discrete card.

Since Debian's not supportet, I tried it on Ubuntu 9.04, with the same exact results.

Thanks replying!

 

 

Outcomes