9 Replies Latest reply on Jun 30, 2010 6:21 PM by Rasale

    open64 on Fedora 13 and Fedora 11

    hepplewhite
      Installation of open64 on fedora 13 fails

      Hello,

      wonder if you could advise - I installed x86_open64 on my Fedora linux fc11 (AMD athlon) with no problems, but can not on my Fedora fc13 (AMD Opteron). The problems appear related to missing libraries for glibc. They are present on the fc11 machine in /lib & /lib64, but on the fc13 ONLY in the /lib64. Infact Fedora 13 installation of the glibc for non x64_64 packages fail. (e.g. glibc-2.10.1-1(i686) can not be installed on fc13. I suppose this is a problem with fc13. Can you advise best course of action.

      Thank you.

        • open64 on Fedora 13 and Fedora 11
          Rasale

          Hi,               

           Thanks for bringing it our notice the issue with Fedora 13. We are looking into the same and will get back to you at the earliest.

           

          Thanks

          Anupama

            • open64 on Fedora 13 and Fedora 11
              Rasale

              Hi,

                              Sorry for getting back late. We were able to download and install 32-bit glibc and glibc-devel packages  on Fedora 13. Here are the steps we carried out to install the 32-bit version libs:

              1.       Login as root

              2.       Add /etc/yum.conf, “multilib_policy=all” option.

              3.       yum install glibc.i686

              4.       yum install glibc-devel

              5.       yum install libstdc++.i686

              6.       Exit as root

               

              Try executing a helloworld application with Open64. Let us know if this works for you.

               

              Thanks,

              Anupama

                • open64 on Fedora 13 and Fedora 11
                  hepplewhite

                  Thank you Anupama,

                  I added the multilib_policy=all to yum.conf

                  when installing glibc.i686 I get a transaction error with the report that

                  file:/usr/share/doc/glibc-2.12/INSTALL conflicts with file from package glibc-2.12.x86_64.

                  Do you have any further suggestions, are there any simple tests to see if my system is set up correctly.

                  thanks 

                    • open64 on Fedora 13 and Fedora 11
                      hepplewhite

                      Dear Anupama

                      are there any clues here:

                      https://bugzilla.redhat.com/show_bug.cgi?id=597583

                      which appears to be very closely related to my problem?

                      thnx

                        • open64 on Fedora 13 and Fedora 11
                          Rasale

                          Hi Hepplewhite,

                                          The transaction error you must be seeing (we assume the error that you are seeing is the same as described in https://bugzilla.redhat.com/show_bug.cgi?id=597583) arises due to mismatch in versioning of nss-softokn-freebl for x86_64 and i686. Couple of queries we have for you is:

                          1.       Are you working with Fedora 13 for x86_64 from LIVE CD?

                          2.       Did you try installing using the 64-bit Fedora 13 iso image instead of LIVE CD ?

                           

                           We downloaded 64-bit Fedora 13 iso image (about 4GB) and we didn’t find such issues with nss-softokn-freebl package. Please check and let us know. In any case at the bottom there are couple of suggestions we found on the internet as well, if that helps.

                           

                          Below are the steps we have tried with success and let us know if this works for you:

                           

                          1.       Download 64-bit DVD (about 4GB) from:

                          http://fedoraproject.org/en/get-fedora-options#architecture

                          2.       Install the OS and copy the RPMs to a local directory from the DVD.

                          $cp –r /media/RPMs/* ./

                          3.       Created a repo

                          $createrepo <RPM_DIR>

                          Check for “repodata” directory which gets created by createrepo

                          4.       Login as root

                          5.        Edit /etc/yum.repos.d/fedora.repo and /etc/yum.repos.d/fedora-updates.repo as follows(to disable internet connectivity):
                              enabled=0

                          6.       Add multilib_policy=all  to /etc/yum.conf

                          7.       Create a myrepo.repo under /etc/yum.repos.d/myrepo.repo as
                          [myrepo]
                          name=My Personal Yum Repo
                          baseurl=file:///root/local_repo
                          enabled=1

                          8.       Import the below key to solve
                          "Public key for glibc-2.10.1-2.i686.rpm is not installed" error

                          $rpm --import  /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-x86_64

                           

                          9.       Install the 32-bit packages

                          $yum install glibc.i686

                          $yum install glibc-devel

                          $yum install libstdc++.i686

                           

                          Note: If you do not install libstdc++.i686, you will get “wgen42: error while loading shared libraries: libstdc++.so.6: wrong ELF class: ELFCLASS64”

                           

                          Couple of suggestions suggested in the bugzilla forum for the issue you could be seeing are(We haven’t tried these from our side. We will try once we get an update on our queries from you):

                           

                          If while installing glibc.i686, the error is

                          ----------------------------------------------------------------------------------------------------------------
                          Transaction Check Error:
                             package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed
                          ------------------------------------------------------------------------------------------------

                          Suggestion 1:

                          # yum localinstall http://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/updates/13/i386/nss-softokn-freebl-3.12.4-19.fc13.i686.rpm

                          #yum localinstall http://ftp.free.fr/mirrors/fedora.redhat.com/fedora/linux/updates/13/i386/nss-softokn-freebl-devel-3.12.4-19.fc13.i686.rpm

                          Then install glibc.i686. Check and see if this works.

                          Suggestion 2:

                          curl http://ftp-stud.hs-esslingen.de/pub/fedora/linux/updates/13/i386/nss-softokn-freebl-3.12.4-19.fc13.i686.rpm -o nss-softokn-freebl-3.12.4-19.fc13.i686.rpm

                          su

                          yum install nss-softokn-freebl-3.12.4-19.fc13.i686.rpm

                           

                          Around 4-5 people have responded saying this works.

                           

                           

                          Let us know if these steps work for you.

                           

                          Thanks

                          Anupama

                            • open64 on Fedora 13 and Fedora 11
                              hepplewhite

                              Many thanks for the suggestions,

                              I had to install fc13 using live CD (my workstation was only spec'd with a CD ROM drive) so I only tried the two suggestions at the bottom of your last post.

                              Both fail with very similar transaction errors as already noted.

                              With the rpms files for both nss-softokn-freebl {i686} and glibc {i686} on my machine and trying to install with rpm -ivh I get dependency errors in both cases as each depends upon the other (it's a catch-22).

                              Unless I can boot off an ISO DVD image locally on my machine - is it worth installing fedora 12 (live CD) and wait for this bug to be fixed in fedora 13?

                              Again - are there other settings I don't have correctly set up on my machine you could think of?

                              thanks for your persistence.

                                • open64 on Fedora 13 and Fedora 11
                                  Rasale

                                  Hi,

                                                  We downloaded the Fedora 13 x86_64 LIVE Version and were able to install below mentioned packages successfully:

                                   

                                  1.       yum install glibc

                                  2.       yum install glibc.i686

                                  3.       yum groupinstall “Development Tools”

                                  4.       yum install glibc-devel.i686

                                  5.       yum install libstdc++.i686

                                   

                                  We installed open64 and ran a sample hello.c and openmp-hello.c programs on the same. From this it looks like the Fedora 13 issue that was reported is solved.

                                  Our suggestion to you would be to download latest Fedora 13 LIVE x86_64 bit onto a CD, install the OS onto the hard-disk and try the above mentioned steps.

                                   

                                  Below is the snippet from Fedora 13 working at our end:

                                  >>>>>> 

                                  [ranupama@anupama open64]$ cat /etc/*release*
                                  Fedora release 13 (Goddard)
                                  Fedora release 13 (Goddard)
                                  Fedora release 13 (Goddard)
                                  cpe:/o:fedoraproject:fedora:13
                                  [ranupama@anupama open64]$ uname -a
                                  Linux anupama.amd 2.6.33.3-85.fc13.x86_64 #1 SMP Thu May 6 18:09:49 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
                                  [ranupama@anupama open64]$ opencc hello.c
                                  [ranupama@anupama open64]$ ./a.out
                                  Hello World
                                  [ranupama@anupama open64]$ opencc -openmp openmp-hello.c
                                  [ranupama@anupama open64]$ ./a.out
                                  Hello World from thread = 3
                                  Hello World from thread = 1
                                  Hello World from thread = 2
                                  Hello World from thread = 0
                                  Number of threads = 4
                                  [ranupama@anupama open64]$

                                  >>>>>> 

                                   

                                  Thanks

                                  Anupama

                                    • open64 on Fedora 13 and Fedora 11
                                      hepplewhite

                                      Hello Anupama

                                      Having more success thank you!

                                      I installed new Fedora (see below) got the glibc and glibc.i686 and did a test to see if I could compile and run hello_world.f95 - and succeeded!

                                      Then I installed all the Development tools - without any apparent errors, then tried again with the following error -  could you advise please? I am a little reluctant to spend another half day re-installing the O/S (unless absolutely necessary)

                                      Thank you

                                       

                                      [clh@macduff Documents]$ cat /etc/*release*
                                      Fedora release 13 (Goddard)
                                      cat: /etc/lsb-release.d: Is a directory
                                      Fedora release 13 (Goddard)
                                      Fedora release 13 (Goddard)
                                      cpe:/o:fedoraproject:fedora:13


                                      [clh@macduff Documents]$ uname -a
                                      Linux macduff 2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11 09:38:12 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

                                       

                                      [clh@macduff Documents]$ openf95 hello.f95
                                      /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/mfef95: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory
                                      openf95 INTERNAL ERROR: /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/mfef95 returned non-zero status 127


                                      [clh@macduff Documents]$ locate libgcc_s
                                      /lib64/libgcc_s-4.4.4-20100503.so.1
                                      /lib64/libgcc_s.so.1
                                      /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/libgcc_s.so
                                      /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/libgcc_s.so.1
                                      /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/32/libgcc_s.so
                                      /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/32/libgcc_s.so.1
                                      /opt/x86_open64-4.2.3.2/open64-gcc-4.2.0/lib/libgcc_s.so
                                      /opt/x86_open64-4.2.3.2/open64-gcc-4.2.0/lib/libgcc_s.so.1
                                      /opt/x86_open64-4.2.3.2/open64-gcc-4.2.0/lib64/libgcc_s.so
                                      /opt/x86_open64-4.2.3.2/open64-gcc-4.2.0/lib64/libgcc_s.so.1
                                      /usr/lib/gcc/x86_64-redhat-linux/3.4.6/libgcc_s.so
                                      /usr/lib/gcc/x86_64-redhat-linux/3.4.6/libgcc_s_32.so
                                      /usr/lib/gcc/x86_64-redhat-linux/4.4.4/libgcc_s.so
                                      /usr/lib/gcc/x86_64-redhat-linux/4.4.4/32/libgcc_s.so

                                       

                                        • open64 on Fedora 13 and Fedora 11
                                          Rasale

                                          Hi,

                                           

                                          Please install

                                          $yum install libgcc.i686 to resolve the issue you are seeing.

                                           

                                          Besides, we have a new compiler version Open64 4.2.4 available for download at developer.amd.com/open64. You may want to try the new version

                                           

                                          One issue you may face, while running your “hello world” application, with older Open64 compiler, on security enabled Linux, would be

                                          ./a.out: error while loading shared libraries: /opt/x86_open64-4.2.3.2/lib/gcc-lib/x86_64-open64-linux/4.2.3.2/32/libfortran.so: cannot restore segment prot after reloc: Permission denied

                                           

                                          This issue is fixed in 4.2.4. So I would recommend that you start using the latest and the greatest.

                                           

                                          Please let us know if this helps

                                           

                                          Thanks

                                          Anupama