2 Replies Latest reply on May 18, 2010 9:54 AM by Tasp

    Ubuntu 9.10: Running ATI Stream Applications Remotely

    Tasp

      I tried it accordingly to:
      http://developer.amd.com/support/KnowledgeBase/Lists/KnowledgeBase/DispForm.aspx?ID=19

      No luck. Can someone who got this working post his configuration?

        • Ubuntu 9.10: Running ATI Stream Applications Remotely
          nou

          you can alternatively try this.

          set up autologin with some user into Xserver.

          then log in via ssh with the same user as is logged in Xserver. do not use -X

          export DISPLAY=:0

          run any OpenCL/OpenGL application. any GUI windows should appear on screen.

          IMHO this is the easyest way.

            • Ubuntu 9.10: Running ATI Stream Applications Remotely
              Tasp

              I logged in remotley and did:

               

              sudo service gdm stop
              sudo /usr/bin/Xorg -br -ac -audit 0


              And it works. So it is a problem with the gdm custom.conf file.

              *edit*

              Here is my solution:

              1. Disable gdm via grub (I don't need gdm on a remote machine)
              In /etc/default/grub set

              GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"
              ,
              than run update-grub

              2. In /etc/X11/Xwrapper.config set

              allowed_users=anybody


              3. In /usr/bin/startx set

              serverargs="-ac"


              Done.
              Login with ssh and run:

              startx &
              FindNumDevices
              and everything should be fine.