7 Replies Latest reply on May 12, 2010 7:55 AM by genaganna

    problem registering ICD on Ubuntu 10.04

    blacksamlou

      Driver Package version :

      8.723.100406a-099494C-ATI

      2 D Driver version 

      8.72.5

      GPU is HD4870

      OS is Ubuntu 10.04,

      Intel E6300 1.8@3.04 4Gb DDR2 on an SSD

       

      I did the following :

       

      l downloaded the SDK for 64 bit platform


      I created a new folder    /usr/local/opencl   

      - Copied the SDK extraction into the above mentioned folder

      then I 
      sudo gedit ~/.bashrc

      and add :

      export ATISTREAMSDKROOT=/usr/local/opencl
      export ATISTREAMSDKSAMPLESROOT=/usr/local/opencl
      export LD_LIBRARY_PATH=$ATISTREAMSDKROOT/lib/x86:$LD_LIBRARY_PATH

      export LD_LIBRARY_PATH=$ATISTREAMSDKROOT/lib/x86_64:$LD_LIBRARY_PATH



      Then again in a Terminal

      export ATISTREAMSDKROOT=/usr/local/opencl

      export ATISTREAMSDKSAMPLESROOT=/usr/local/opencl export LD_LIBRARY_PATH=$ATISTREAMSDKROOT/lib/x86:$LD_LIBRARY_PATH
      export LD_LIBRARY_PATH=$ATISTREAMSDKROOT/lib/x86_64:$LD_LIBRARY_PATH mkdir /usr/lib/OpenCL mkdir /usr/lib/OpenCL/vendors sudo ln -sf /usr/local/opencl/lib/x86/libatiocl32.so /usr/lib/OpenCL/vendors/libatiocl32.so
      sudo ln -sf /usr/local/opencl/lib/x86_64/libatiocl64.so /usr/lib/OpenCL/vendors/libatiocl64.so
      cd /usr/local/opencl make sudo ln -sf /usr/local/opencl/lib/x86/libOpenCL.so /usr/lib/libOpenCL.so
      sudo ln -sf /usr/local/opencl/lib/x86_64/libOpenCL.so /usr/lib64/libOpenCL.so

      I go into :

      cd /usr/local/opencl/samples/opencl make cd /usr/local/opencl/samples/opencl/bin/x86_64 ./HelloCL
      and boom nada !
      HelloCL! Getting Platform Information Platform::get() failed (-1001)
      I already removed everything and done it again 3 times and still no0thing, any help will be nice !@