1 Reply Latest reply on Mar 18, 2010 6:50 PM by samsdram

    ACML under Microsoft Visual Studio

    janaj

      Hey,

      I downloaded the acml version for windows and i tried to link it to an existing c program. Therefor I linked the acml library under project settings. First of all I got the error LNK cannot open library, but I think that was just a mispelling problem. Now that I solved that problem I get about 120 errors. They all say that a variable under acml is not set correctly or cannot be find. Has anyone an idea to solve that issue?

       

        • ACML under Microsoft Visual Studio
          samsdram

          My advice is to include a library that ends in _dll.lib. If you don't include one of those libraries you have to worry about defining symbols yourself. If you include a library file that ends in _dll.lib, be sure that windows can find the dlls it needs (these will be in the same lib folder where you link the library file). You can do this with visual studio by placing the dll files in the same folder as your source code or in the windows/systemWow64 folder. If you do that then you should have access to the functions in the ACML, worked for me anyway.