escapeclause

Driver support for OpenCL?

Discussion created by escapeclause on Feb 23, 2010
Latest reply on Mar 12, 2010 by RBD
Stream SDK 2.01 & ATI driver 10.2, samples fail

Hello,

What exact driver must I use to have Stream 2.01 work? I am running Stream SDK 2.01 (downloaded Feb 23) and OpenSuSE 11.2, with a pair of 4890 in crossfire.

Currently I am using driver 10.2 (downloaded Feb 21),which the Stream system requirements says should work.

Every sample app for both CAL and OpenCL fails with what I understand to be a driver not supporting Stream error. Examples:

emerth@quad:/usr/local/ati-stream-sdk-v2.01-lnx64/samples/cal/bin/x86_64> ./basic
Supported CAL Runtime Version: 1.3.185
Found CAL Runtime Version: 1.4.553
Use -? for help
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  144 ()
  Minor opcode of failed request:  19
  Serial number of failed request:  8
  Current serial number in output stream:  8
emerth@quad:/usr/local/ati-stream-sdk-v2.01-lnx64/samples/cal/bin/x86_64> ./hellocal
Supported CAL Runtime Version: 1.3.185
Found CAL Runtime Version: 1.4.553
Use -? for help
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  144 ()
  Minor opcode of failed request:  19
  Serial number of failed request:  8
  Current serial number in output stream:  8
emerth@quad:/usr/local/ati-stream-sdk-v2.01-lnx64/samples/cal/bin/x86_64> cd ../../../../
bin/         docs/        include/     lib/         make/        samples/     TempSDKUtil/
emerth@quad:/usr/local/ati-stream-sdk-v2.01-lnx64/samples/cal/bin/x86_64> cd ../../../opencl/bin/x86_64/
emerth@quad:/usr/local/ati-stream-sdk-v2.01-lnx64/samples/opencl/bin/x86_64> ./HelloCL
HelloCL!
Getting Platform Information
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  144 ()
  Minor opcode of failed request:  19
  Serial number of failed request:  8
  Current serial number in output stream:  8

The only driver I can get to work is Catalyst_9.12_Hotfix_Linux_8.682.2RC1_Dec15.zip, which places an overlaid square message in the lower right hand corner of the screen. The message is something like "AMD Experimental Use". Sorry I'm using the 10.2 driver right now so my recall of the message may not be correct.

Outcomes