basile.starynkevitch

Linux/AMD64 - Ati stream 2.01 & Catalyst 10.2 & ATI 5770 = no cursor

Discussion created by basile.starynkevitch on Feb 19, 2010
Latest reply on Feb 23, 2010 by omkaranathan

 

Helllo All

I have an ATI 5770 with dual-head on Linux/Ubuntu/Karmic AMD64, mostly for experimenting OpenCL. I am beginning to work on a GCC plugin in MELT to generate OpenCL code. I am using Ati stream 2.01 and some OpenCL sample applications did run ok.

Since Catalyst 10.2 was just released (and because the previous Catalyst 10.1 seems sometimes unstable with OpenCL - some opencl demos crashed the Xorg server) I installed it (the 10.2).

 

The Linux kernel is Linux glinka 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:02:26 UTC 2010 x86_64 GNU/Linux

The Xorg server (from Ubuntu Karmic) is xorg-server 2:1.6.4-2ubuntu4.1

I donwloaded & installed the ati-driver-installer-10-2-x86.x86_64.run

Indeed it is installed & loaded, because /var/log/Xorg.0.log contains stuff like

Module fglrxdrm: venfdore= "FireGL - ATI Technologies Inc."

  compiled for 1.4.99.906, module version 8.70.3

 

But there is no more any visible mouse cursor and this makes the Xorg server unusable. This is not related to the X11 applications or desktops. There is no cursor in gdm, icewm session (startx /usr/bin/icewm-session), plain xterm session (startx /usr/bin/xterm) or Gnome.

I tried to boot with or without the nopat kernel argument, and this does not change anything, still no cursor:

 

BTW is the nopat kernel option still needed? And do OpenCL AMD people recommend installing new Catalyst FGLRX versions or not?

 

Regards.

 

--

Basile Starynkevitch  http://starynkevitch.net/Basile/

 

 

 

Outcomes