0 Replies Latest reply on Feb 15, 2010 5:51 PM by vignyan

    INFO: INSTALLING ATI STREAM ON UBUNTU 9.10

    vignyan
      Getting openCL to work with ATI stream v2.01

      THE STUFF IN " "(QUOTES)  IS A LINK OR A COMMAND. DO NOT INCLUDE THEM WHEN USING THEM.

      First up, install Ubuntu 9.10 if you have not yet done so. Its really cool OS. Might not be a windows replacer if you are into games and stuff, but if you are here, Ubuntu is for you my friend.Obviously you will need superuser permissions for all most all these tasks.

      To install, follow the simple steps given in many places on the net. Just for your convenience, i paste the link below.

      "http://news.softpedia.com/news/Installing-Ubuntu-9-10-126370.shtml"

      After installing, make sure that you dont activate the restricted drivers of ATI cards. Instead, download the .deb packages from

      "http://rapidshare.com/files/350256479/ATI10_1_Ubuntu_9.10__drivers.7z"

      or download the ATI Catalyst 10.1 (actually 8.69 is the driver version) and use the technique described in

      "http://www.phoronix.com/forums/showpost.php?p=110091&postcount=56"

      Once you have done this, open a terminal and perform the operation

      "sudo aticonfig --initial"

      This will register your ATI card with your system.

      You need to install the openGL developement tools like freeGLUT or GLUT. Use synaptic package managet to do this.

      Download the ATI stream SDK v2.01 from the net. Follow the intsallation guide and setup all the environment variables as mentioned in the installation guide. The guide is present here.

      "http://developer.amd.com/gpu/ATIStreamSDK/pages/Documentation.aspx"

      Also, keep in mind the KB article on how to use some of the init functions as mentioned. 

      "http://developer.amd.com/support/KnowledgeBase/Lists/KnowledgeBase/DispForm.aspx?ID=71"

      Now, update the boot loader to make sure that you start the kernel with 'nopat' option.

      open up a terminal, and use your fav editor (mine is vim) to edit the file /etc/default/grub

      "sudo vim /etc/default/grub"

      If you are not comfortable with vim, use

      "gksudo gedit /etc/default/grub"

      in line 9 make changes so that your line looks like this

      "GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nopat""

      save and close the file.Now do a grub update using the command

      "sudo update-grub"

      Reboot. Now, compile and your programs and they should work fine.

       

      My system config:

      Sony Vaio VGN-FW490J; Intel Core 2 duo P735; 32-bit Ubuntu 9.10 with 9.31.19 kernel; ATI Mobility Radeon HD4650. 4GB RAM (seen as 3GB by each application)