2 Replies Latest reply on Feb 15, 2010 7:14 PM by chipf

    using acml4.3.0 with silverfrost ftn95

    weikoon

      I compile my file first using

      ftn95 myfile

      then link to the library

      slink myfile.obj <dir>\libacml_dll.dll

      an executable is generated. but when i run the executable I get the message "Error 94, Unit has neither been OPENed nor preconnected"

      What could be the problem?

        • using acml4.3.0 with silverfrost ftn95
          weikoon

          if i click on the icon to run (instead of executing from the command prompt), i get the error messsage box stating:

          the application has failed to start because libacml_dll.dll was not found. Reinstalling the application may fix the probleem.

          which I tried and didn't work, of course.

           

           

            • using acml4.3.0 with silverfrost ftn95
              chipf

              Which Salford compiler version are you using?

              I'm guessing you are using Windows 32 and you're trying this with the ifort32 ACML.  The second problem sounds like the acml lib directory is not found in the path.  One way to solve this is add that directory to the PATH using the system environment variables, but there are numerous other ways.

              The first problem sounds a little like a ifort compatibility problem.  See this thread (http://forums.amd.com/devforum/messageview.cfm?catid=217&threadid=99461).

              That thread was referring to linux builds, so this may not be the same problem.  And I don't think any of the suggested work arounds will be practical for you.

              If you could supply a simple fortran program that demonstrates the issue someone might be able to look at it.