pvl

compilation in Debian with skipping incompatible libstdc++

Discussion created by pvl on Jan 29, 2010
Latest reply on Feb 15, 2010 by RaghavendraSwamy
cannot complie x86_open64-4.2.3 due to incompatible libstdc++

Hello, 

I cannot compile x86_open64-4.2.3 due to incompatible libstdc++.

working on 64b Debian 5:

2.6.30-2-amd64 #1 SMP Mon Dec 7 05:21:45 UTC 2009 x86_64 GNU/Linux

Compile by:

make all MACHINE_TYPE=i386

get

 

...

make[3]: Entering directory `/opt/x86_open64-4.2.3/osprey/targia32_x8664/targ_info'

C++    /opt/x86_open64-4.2.3/osprey/targia32_x8664/targ_info/isa_gen.o

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.3.4/libstdc++.so when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.3.4/libstdc++.a when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.3.4/libstdc++.so when searching for -lstdc++

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.3.4/libstdc++.a when searching for -lstdc++

/usr/bin/ld: cannot find -lstdc++

collect2: ld returned 1 exit status



 

I am following Instalation instructions according ubuntu 9.10 but with no effect.

 

Could you help me?

Regars, Pavel

 

Outcomes