5 Replies Latest reply on Jan 18, 2010 3:30 PM by simnow.moderator

    simNow Installation

    khanb
      Installation Problems

      Hi

      I have just started using simnow simulator and am reading its manual. I am finding problems installing simnow (on suse 11.1 64 bit linux, on intel xeon 64 bit proc.)

      First of all, when I follow the installation command in the manual and do "tar -xzf",  the simnow directory I get is different from the one mentioned in the manual..there is no "devices" or "reg" directories.

      Similarly I dont get configuration file "simnowrc" in my $HOME/.qt directory.

      Can you please help me on that.

       

      Secondly I was followiing the manual on how to make device groups (page 26 of the manual). When I press the "finish" button I get the following error.

      reset issued
      created device AweSim Processor
      reset issued
      created device AweSim Processor
      reset issued
      created device AMD 8th Generation Integrated Northbridge
      device Unnamed not found
      Segmentation fault

       

      I assume it has something to do with not installing the simnow correctly.

       

      Please help.I would really appreciate that.

        • simNow Installation
          simnow.moderator

          We need to update our users manual for linux. The directory structure was copied for windows installation. On linux instead of the 'devices' folder we have the 'libs' folder which contains the .so files and 'regs' folder is not present on linux.
           
          The configuration file $HOME/.qt/simnowrc is not generated as an artifact of installing simnow, but it is generated by running simnow.
           
          We do not support or test simnow on non AMD64 based host machines. Therefore, I am not surprised simnow crashes on your host machine.

          Thanks

            • simNow Installation
              khanb

              Hi

              thank you for your email.

              I just tried the AMd 64 machine and I still get the same error while making the device groups.

              I will just give you step by step instruction of very simple example that I am trying (it will just take less than  2 min to recreate ).

              I open "cheetah_1p.bsd". Then go to "show devices". I do not add any thing. I just select the AweSim processor and the north bridge together and do "Ctrl+G". I get to step one. I edit name, description, icon and help file. Then in the "export to file" I add test.bsg in the libs folder and do "next".

              After that I just click finish as the internal-to-external maping are already shown. "HyperTransport Bus 0" and "Memory Bus". I dont do any thing in step 2 and just press finish.

              When I click finish button, the program crashes and in the shell I get the message

              "device Unnamed not found.

              Segmentation fault."

              Can you please advice. What am I doing wrong? Is there any thing I am missing, in this simple example.

              Regards