2 Replies Latest reply on Jan 7, 2010 5:59 PM by rahulgarg

    Bandwidth on radeon HD 5870 extremely below what it should be

    gpuBoy
      Something is HORRIBLY wrong here.

      When i run the PCIespeedtest utility, the bandwidth is extremely below what I should be getting(in both ubuntu 9.04 and windows 7), and the GPU->CPU bandwidth is just plain laughable. What is going on here? I have the latest drivers installed. here is the output of the speed test in ubuntu 9.04:

      ===> Testing device 0 <===
      Device type: Unknown
      Max resource 2D width/height: 16384/16384
      Total GPU memory size: 1024 MB
      Total CPU cached space size: 481 MB
      Total CPU uncached space size: 1213 MB
      GPU engine clock: 850 MHz
      GPU memory clock: 1200 MHz
      Number of timing loops: 50
      [     65536 bytes] CPU->GPU= 655.360 MB/sec, GPU->CPU 364.089 MB/sec
      [    131072 bytes] CPU->GPU=   3.277 GB/sec, GPU->CPU 655.360 MB/sec
      [    262144 bytes] CPU->GPU=   3.277 GB/sec, GPU->CPU 436.907 MB/sec
      [    524288 bytes] CPU->GPU=   3.745 GB/sec, GPU->CPU 476.625 MB/sec
      [   1048576 bytes] CPU->GPU=   4.033 GB/sec, GPU->CPU 459.902 MB/sec
      [   2097152 bytes] CPU->GPU=   3.884 GB/sec, GPU->CPU 451.972 MB/sec
      [   4194304 bytes] CPU->GPU=   3.957 GB/sec, GPU->CPU 445.255 MB/sec
      [   8388608 bytes] CPU->GPU=   3.995 GB/sec, GPU->CPU 439.194 MB/sec
      [  16777216 bytes] CPU->GPU=   3.995 GB/sec, GPU->CPU 436.907 MB/sec
      [  33554432 bytes] CPU->GPU=   3.316 GB/sec, GPU->CPU 439.770 MB/sec
      [  67108864 bytes] CPU->GPU=   3.620 GB/sec, GPU->CPU 443.666 MB/sec
      [ 134217728 bytes] CPU->GPU=   3.893 GB/sec, GPU->CPU 456.740 MB/sec
      Peak CPU->GPU Bandwidth =   4.033 GB/sec [data size = 1048576 bytes]
      Peak GPU->CPU Bandwidth = 655.360 MB/sec [data size = 131072 bytes]

      The results are similar in windows 7.  I've tested each of the PCIe slots in my machine, a nehalem with i7 and asus p6t6 WS, all with same or worse results. The above test is given from the 1st slot(the recommended slot by asus). The BIOS is the latest 0507 update which includes the new nehalem microcodes. Why is it so slow?

      Thanks