5 Replies Latest reply on Jun 21, 2010 10:57 AM by leiy

    the selected session does not have any data

    afabri

      After having installed CodeAnalyst on a Turion64 bit, XP64 machine I try to run CodeAnalyst on the example program. It runs the example program and when it is finished a window pops up with the text "the selected session does not have any data".  The same happens with my own programs.

      Any advice?

      andreas

        • the selected session does not have any data
          leiy

          How did you configure your profile? Did you turn on the "started with paused"? 

          Can you try "caprofile.exe /s /t 1000 /d 5" on command line promot? After it complete, check "dir profile.prd", what is the size of .prd file.

           

           

            • the selected session does not have any data
              afabri

              This is what I get:

               

              afabri@monet /cygdrive/c
              $ cd Program\ Files\ \(x86\)/AMD/CodeAnalyst/SampleCode/classic/Release/

              afabri@monet /cygdrive/c/Program Files (x86)/AMD/CodeAnalyst/SampleCode/classic
              Release
              $ ls
              classic.exe  classic.pdb  classic.txt

              afabri@monet /cygdrive/c/Program Files (x86)/AMD/CodeAnalyst/SampleCode/classic
              Release
              $ caprofile.exe /s /t 1000 /d 5
              Press 's' to stop
              Press 'p' to pause
              Press 'r' to resume
              Profile duration reached. Stop Profile.

              afabri@monet /cygdrive/c/Program Files (x86)/AMD/CodeAnalyst/SampleCode/classic
              Release
              $ ls
              classic.exe  classic.pdb  classic.txt  classis  profile.prd  profile.ti  t1

              afabri@monet /cygdrive/c/Program Files (x86)/AMD/CodeAnalyst/SampleCode/classic
              Release
              $ ls -la
              total 710
              drwxrwx---+ 4 Administrators SYSTEM      0 Dec  2 21:02 .
              drwxrwx---+ 3 Administrators SYSTEM      0 Dec  2 20:15 ..
              -rwxrwx---+ 1 Administrators SYSTEM  77824 Oct 27 14:52 classic.exe
              -rwxrwx---+ 1 Administrators SYSTEM 437248 Oct 27 14:52 classic.pdb
              -rwx------+ 1 afabri         None       83 Dec  2 20:26 classic.txt
              -rwx------+ 1 afabri         None      160 Dec  2 21:02 profile.prd

              • the selected session does not have any data
                afabri

                To reply to your question:  I am in Express Mode and chose Time Based Profile

                 

                andreas

              • the selected session does not have any data
                teazavr

                I had same problem under VirtualBox.

                The problem goes away under host OS.