3 Replies Latest reply on Nov 6, 2009 8:16 PM by abrahm

    Trouble with beta4 drivers

    abrahm
      black screen with beta4 8.67 drivers

      I'm running Ubuntu 9.04 amd64. I set up ati-stream-sdk-v2.0-beta4-lnx64.tgz without trouble. I can compile and run the example programs on my cpu (if I copy libaticalrt.so and libaticalcl.so to $ATISTREAMSDKROOT/lib/x86_64/).

      I wanted to take the next step, and get code running on my Radeon Mobility 4830. I extracted ati-opencl-beta-driver-v2.0-beta4-lnx.zip. In the fglrx-8.67/ directory, I run "sudo ./ati-driver-installer-8.67-x86.x86_64.run". Everything appears to build and install successfully. The kernel module can load without trouble, but I get a black screen when X starts. It appears as though my computer has completely locked up.

      If I remove the fglrx.ko kernel module, then X will start and not hang the system. I get the "For testing" AMD logo in the lower right corner of the screen. 2D performance is absolutely awful, and I get an error when I try to run my openCL applications. After the expiration message printout, I get an "X Error of failed request: ..." and then some information about failed request opcodes.

      Am I missing something?

        • Trouble with beta4 drivers
          omkaranathan

          Could you run the CAL sample 'FindNumDevices' and post the result?

            • Trouble with beta4 drivers
              abrahm

               

              Originally posted by: omkaranathan Could you run the CAL sample 'FindNumDevices' and post the result?

               

               

              I'm pretty sure this message is because I have not loaded fglrx.ko yet.

              $ ./FindNumDevices X Error of failed request: BadRequest (invalid request code or no such operation) Major opcode of failed request: 135 () Minor opcode of failed request: 19 Serial number of failed request: 8 Current serial number in output stream: 8 Supported CAL Runtime Version: 1.3.185 Found CAL Runtime Version: 1.4.467 Use -? for help

                • Trouble with beta4 drivers
                  abrahm

                  Now, I've managed to start X 4 times without freezing my computer. I've frozen my computer about 12 times trying to start X.

                  The 4 times that my computer has not frozen, I followed the same basic steps:

                  1. boot without fglrx.ko module.

                  2. start X.

                  3. load fglrx.ko manually.

                  4. wait a few minutes.

                  5. stop X.

                  6. start X.

                  Two times step 6 went perfect and I was able to find devices and run code.

                  Once, step 6 rebooted my computer.

                  Once, step 6 left me at a completely corrupt screen, but restarting X again worked and I was able to find devices and run code.

                   

                  After one of the successful starts, I stopped X and then restarted X. It successfully came up then as well.