2 Replies Latest reply on Jun 19, 2009 7:09 PM by mickpont

    Linking trouble with VS2008 & Ifort v11

    _Sigma

      I'm trying to use the fastsinf and fastexpf routines of ACML in some existing fortran code that I am compiling under Windows XP with Visual Studio 2008 and Intel fortran v11.0 build 20080930.

      My steps:

      1. Download the ifort release of ACML
      2. Replace an exp call with fastexpf
      3. Under project properties -> linker ->  input -> additional dependencies and add to it c:\AMD\acml4.2.0\ifort32_mp\lib\libacml_mp_dll.lib, which is where the library is located.

      However, upon build, it says that there is an unresolved external symbol _FASTEXPF in my function.

      I am primairly a C++ coder, so I am familiar with linking problems with that language, however I"m a bit new to Fortran, so perhaps I am missing something simple. Would appreciate any insight into this.

      //edit

      I should also note that I have tried all the variants, _mp and otherwise, static and shared. All result in the same error. I am also compiling with /Qopenmp so that shouldn't be the problem