0 Replies Latest reply on May 27, 2009 3:11 AM by nitinb

    Linux fglrx driver and suspend-resume problem on CentOS 5.2

    nitinb
      After a suspend-resume cycle, shutting down the OS causes screen flashes

      Hi All,

      I'm using CentOS 5.2 and fglrx 8.10 graphics driver for ATI radeon X1200 card. The problem scenario is as follows ( otherwise everything is fine):

      1. Suspend the system and resume it back => Resume cycle is successful and system is up and running OK.
      2. Shutdown CentOS => No shutdown messages seen and the monitor keeps on flashing white-black-white-black repeatedly, with the last text (while resuming) seen on it while its black.

      dmesg ( fglrx o/p ):
      ------------------------

      [root@localhost ~]# cat dmesg | grep fgl
      fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
      [fglrx] Maximum main memory to use for locked dma buffers: 372 MBytes.
      [fglrx] vendor: 1002 device: 791f count: 1
      [fglrx] ioport: bar 4, base 0xde00, size: 0x100
      [fglrx] PAT is enabled successfully!
      [fglrx] module loaded - fglrx 8.54.3 [Oct 3 2008] with 1 minors
      [fglrx] GART Table is not in FRAME_BUFFER range
      [fglrx] GART Table is not in FRAME_BUFFER range
      [fglrx] Reserved FB block: Shared offset:0, size:1000000
      [fglrx] Reserved FB block: Unshared offset:7ffc000, size:4000
      ----------------------------------------------------------------------

      I can see nothing much wrong in the logs. It seems like a fglrx driver issue. I tried higher fglrx driver packages too ( 8.11 to 9.x ), which crash the kernel and don't work. Does anyone has encountered such condition and know any workarounds ?

      As an aside issue ( and I think its related ), when I use vga modes other than "normal" in the kernel command line ( e.g. vga=788 or vga=791 ), The screen is completely blank while shutting down the OS; Also I cannot see any VT terminal, when I turn on VT switching( Ctrl-Alt-F[n] ) in xorg.conf.

      Following is my xorg.conf file:

      ------------------------------------------------------------------
      # Xorg configuration created by system-config-display

      Section "ServerLayout"
      Identifier "single head configuration"
      Screen 0 "aticonfig-Screen[0]-0" 0 0
      InputDevice "Keyboard0" "CoreKeyboard"
      EndSection

      Section "Files"
      EndSection

      Section "Module"
      EndSection

      Section "ServerFlags"
      Option "AIGLX" "off"
      # Option "Xinerama" "off"
      EndSection

      Section "InputDevice"
      Identifier "Keyboard0"
      Driver "kbd"
      Option "XkbModel" "pc105"
      Option "XkbLayout" "us"
      EndSection

      Section "Monitor"
      Identifier "aticonfig-Monitor[0]-0"
      HorizSync 30.0 - 90.0
      VertRefresh 59.0 - 61.0
      Option "VendorName" "ATI Proprietary Driver"
      Option "ModelName" "Generic Autodetecting Monitor"
      Option "DPMS" "true"
      EndSection

      Section "Device"

      Option "HWCursor" "on"
      Option "VideoOverlay" "on"
      Identifier "aticonfig-Device[0]-0"
      Driver "fglrx"
      # Option "OpenGLOverlay" "off"
      Option "XAANoOffscreenPixmaps" "true"
      # Option "KernelModuleParm" "locked-userpages=0"
      # Option "NoDRI" "yes"
      Option "UseInternalAGPGART" "no"
      BusID "PCI:1:5:0"
      EndSection

      Section "Screen"
      Identifier "aticonfig-Screen[0]-0"
      Device "aticonfig-Device[0]-0"
      Monitor "aticonfig-Monitor[0]-0"
      DefaultDepth 24
      SubSection "Display"
      Viewport 0 0
      Depth 24
      Modes "1280x1024"
      EndSubSection
      EndSection

      Section "Extensions"
      Option "Composite" "on"
      EndSection

      Section "ServerFlags"
      Option "DontZap" "true"
      Option "DontVTSwitch" "true"

      EndSection
      ------------------------------------------------------------------


      Please help.
      Nitin.