2 Replies Latest reply on Aug 5, 2009 7:41 AM by emuller

    Catalyst 9.4, 4870x2 and Jaunty

    emuller

      Has anyone got this working?

      I have been using jaunty for at least a month now with my 4850 and 8.600 with no problems.

      I upgraded to a 4870x2 and X segfaults on launch.  I've tried upgrading to 8.602, but it didn't help. 

      I understand I cannot downgrade to previous catalyst versions because they are not supported by the new X version of jaunty.

      I'd appreciate any pointers ...

       

       

        • Catalyst 9.4, 4870x2 and Jaunty
          emuller

          Catalyst 9.4 (8.602) and 4870x2 with Ubuntu 8.10 32bit seems to be working, i.e. I didn't need any special tricks.  I'm assuming (hoping) 8.10 64bit will work too.  I'll stick with that until Xorg 1.6 and catalyst 9.4 learn to play better together.

            • Catalyst 9.7, 4870x2 and Jaunty
              emuller

              Catalyst 9.7 for linux was released a few weeks ago and I was able to get up to 4 GPUs working with it under a fresh jaunty (9.04) install with my standard fglrx install procedures for Ubuntu 8.10 (no tricky stuff):

              X@Y:~$ ./caltest
              CAL Runtime version 1.4.344
              Found 4 devices. Using device 0.
              Device Type = GPU RV770
              Max 1D Width 4294967295.
              Max 2D Width 8192.
              Max 2D Height 8192.
              Found 1024 MB GPU RAM.
              Found 625 MHz GPU device clock.
              Found 993 MHz GPU memory clock.
              Found 10 SIMDs.
              Wavefront Size 64 .
              Device open and ready.
              Found 962 MB available GPU RAM.
              Found 1188 MB available uncached remote RAM.
              Found 478 MB available cached remote RAM.
              Kernel compile and link sucessful.
              Device sucessfully closed.

              Still no >4GPU support, but this is a definite improvement.  Lack of 9.04 support meant I could not use some of my 9.04 machines in GPGPU production.  Now I can ... Thanks AMD!