4 Replies Latest reply on Mar 17, 2009 3:03 PM by rveldema

    permission? problem running cal app remotely

    rveldema

      Hi,

         I'm trying to run a brook app remotely, I've followed the instructions from the knowledge base (patched gdm/custom.conf, chmod of /dev/dri/card0, setting new DISPLAY var etc).

      Now when running, for example, amdcal/bin/lnx64/FindNumDevices, I get on /var/log/Xorg.0.messages:

      AUDIT: Tue Mar 17 17:00:46 2009: 2618 Xorg: client 11 rejected from local host ( uid=0 gid=0 pid=8783 )

      This is on fedora 9 after a yum update. This all used to work on fedora 8 (which is no longer supported so an update was needed).

      Problem also persists regardless of 1.3 or 1.4 of brook/cal.

        • permission? problem running cal app remotely
          the729

          So the problem is that the computer running GPU programs do not have sufficient permission to access the X server on your GPU server.

          You need to use xauth or xhost command to change the privilege settings.

          Or you can simply pass -ac (no access control with xauth) parameter to the X server command line. However you may also need to use xhost to edit the white list of remote hosts.

            • permission? problem running cal app remotely
              rveldema

              That's why I have (in /etc/gdm/custom.conf):

              [server-ATIStream]
              name=ATIStream
              command=/usr/bin/Xorg -br -ac -audit 0
              flexible=true

              You can't run xhost (as it needs someone already having authorization to the server). xauth is likewise not good.

              It looks like the above 'command' line is perhaps ignored:

              [veldema@faui21k X11]$ ps ax|grep Xorg
               2618 tty7     Ss+    0:03 /usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-cookie-XX0CJFQU-for-gdm -nolisten tcp
               9963 pts/1    S+     0:00 grep Xorg