iulian_arg

problem compiling c++ brook+ generated code

Discussion created by iulian_arg on Jan 7, 2009
Latest reply on Jan 8, 2009 by iulian_arg

Hi,

sorry for posting such a noob question.

I can't compile c++ code generated by Brook+ compiler.

When I tried to compile "Sum" example,it passes brook level without error, but on the c++ level I get 41 errors like this one:

error LNK2001: unresolved external symbol "public: virtual void __thiscall StreamImpl::read(void const *)" (?read@StreamImpl@@UAEXPBX@Z)

It seems that the problem is with brook.lib file, but i can't figure it out what I'm doing wrong. I added the path to the lib file in

Project Properties>Configuration Properties>Linker>Input>Additional Dependencies.

I'm sure that the path is ok, but I still get those errors.

Are there any known issues with VS2008?

platform: vista 64, VS2008, catalyst 8.12, sdk 1.3, hd3850.

the precompiled (exe) examples located in installation folder, work fine.

 

LE: the same set of errors i get with and also without brook.lib dependency added; so it seems the c++ compiler doesn't care about my dependency.

Outcomes