1 Reply Latest reply on Oct 3, 2008 12:29 AM by brockp

    No acml 4.1.0 available for PGI 32-bit installs

    jpincus
      Only the 64-bit version has been made available

      Hi Folks,

      Any chance you could provide a 32-bit version of the ACML library compiled with PGI?  The only version of 4.1.0 availble for download is the 64-bit PGI version.  I need the 32-bit version.

      Thanks,

      JP

        • No acml 4.1.0 available for PGI 32-bit installs
          brockp

          PGI ships ACML with their product, check in:

           

          $PGI/linux86/7.2-1/lib/

           

          You should find libacml.a, libacml_mv.a in there, the headers for C should also be in the include paths.  If you want ot check which version of ACML they included you can run strings on the libraray(not fun) or use the acmlinfo() function:

           

          #include <stdio.h>
          #include <stdlib.h>
          #include <acml.h>

          int main(void){
            int *major, *minor, *patch;
            /*acmlversion(major,minor,patch);*/
            acmlinfo();
            /*printf("acml version: %d.%d.%d\n",major, minor, patch);*/

          return 0;
          }