Showing results for 
Search instead for 
Did you mean: 

Unreal Engine Discussions

Journeyman III

Frequent crashes with unreal engine

Recently purchased a new Gigabyte Radeon 6800XT

I have been unable to run multiple games, particularly those using unreal engine. Few seconds into the first cutscene of each title the game will crash to desktop.

Variety of errors reported:

"Unreal Engine is exiting due to D3D device being lost"  "D3D Device Removed" "DGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_HUNG"

Titles this is affecting so far include: The Callisto Protocol, Wolfenstein the New Order, The Witcher 3, Star Wars Jedi Fallen Order

My PC specs: Win11 Pro

Intel Core i5 13600K

Gigabyte Gaming X Z690

Gigabyte Radeon 6800 XT 16GB OC

16gb Kingston Fury DDR5

Corsair HX1000W


I have tried multiple "solutions" online. My AMD drivers, Win 10, Direct X, Unreal engine are all uptodate. (I have tried both Unreal 4 and 5).

Registry edits to add DWORD as TdrLevel in Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers

I have reseated my CPU, memory, and GPU, checked all power connections. So far unable to isolate the problem, but it seems to be a graphical error.

If anyone has solutions or has experienced such similar and widespread errors, please feel free to contribute.

1 Reply
Journeyman III

Just to update this incase anyone looking for answers.

Card has been RMA'd and fault confirmed.