Showing results for 
Search instead for 
Did you mean: 

Server Gurus Discussions

Journeyman III

Problem with Gaussian 16 qantium chemical program and Epyc 7402P

Hello. I have problems with using Gaussian 16 rev.A03 quantum chemical software on my AMD Epyc 7402P processor. I have «illegal instruction» error, when I try to execute calculation. I have tried fedora 31 (server, all updates), Ubuntu 20.04 (desktop), and RHEL 7.8 and 8.1 (server with gui). Both Gaussian 16 rev.A03 with AVX2 or SSE instructions do not work. The same program works perfectly on threadripper 1950x in fedora 31. The older versions of this program Gaussian 09 E.01 with AVX (1) instructions and Gaussian 09 D.01 with SSE are working normally on my AMD Epyc in RHEL 7.8. My motherboard is Supermicro MBD-H11SSl-I-B. Bios revision is 2.1 AGESA RomePi is based on .14_RomeCrb_0ACMK013. I do not have source code of Gaussian 16 (only binaries) but I have found it is most likely compiled with Portand Group F77 16.5, gcc included in RHEL 7.3 and Atlas library (I don’t know it’s version). Please provide any help.

4 Replies

HI Zarin,
We're  sorry you're experiencing difficulties,

We note that you're running an older version of Gaussian (16 AO3 vs current 16 C.01) and that the version of Red Hat Enterprise you are testing on is RHEL 7.8.
The highest RHEL version supported for AMD processors + Gaussian 16 C.01 is  RHEL 7.6, , as per this document:
Is there some way you could update your binary download, and/or your environment to match the versions detailed above?

Hello thak you for answer. Unfourtunaly I can not update my binaries. But as i stated older versions are working fine with epyc 2nd generation. some years ago i have seen this error on another processor: I have tried execute avx2 program on only avx1 processor. But epyc definitly has all instruction set ( and in addition 1950x works well). Maybe it is a problem how progran or operating system "recognize" my processor.

Journeyman III

HI Zarin,

According to the following cite: Gaussian16 - Center for High Performance Computing - The University of Utah, you may try to run in console `export PGI_FASTMATH_CPU=sandybrigde`. 

I hope that it will help you!

Best regards,

Thank you very much i.s.ger! I have seen that site but setenv did not work. But your command exported in bashrc worked perfectly! And a03 with avx2 now works in new Epyc Rome and Ryzen 3950x processors.

final version is ( in bashrc)

export PGI_FASTMATH_CPU=haswell

Thank all of you guys question is closed.