Showing results for 
Search instead for 
Did you mean: 

Red Team Discussions

Journeyman III
Journeyman III

Ryzen Master freezing up on start up

I just purchase a Ryzen 7 2700 off Ebay and it showed up this afternoon. Ever since replacing the existing 1600x with this 2700, Ryzen Master has been unstable. I've uninstalled and reinstalled it multiple times, mucked through the Registry and tried cleaning out any trace of it, but I still cannot get it to start.

This old thread describes the issue pretty well: Ryzen Master does not start properly 

The only difference is I get a dialog saying that Ryzen Mater has stopped working (see the attached image). It seems like every once in a while it actually launches, but 99% of the time is just this crash. I've looked through the Ryzen Master folder in Program Files and there's nothing meaning full in any of the logs.

Here's what I am currently running (and it worked fine with the old Ryzen 5 1600x I purchased brand new)

- Asus Gaming X370-F (Checked that it does support this processor with a recent BIOS)

- Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15 Desktop

- Nvidia GTX 1080

Is there anything other information I can provide to help troubleshoot?

0 Kudos
2 Replies
Journeyman III
Journeyman III

Re: Ryzen Master freezing up on start up

I've been digging into the Event View in Windows and this is showing up in there:

Faulting application name: AMD Ryzen Master.exe, version:, time stamp: 0x5d89975e
Faulting module name: ucrtbase.dll, version: 10.0.19041.1, time stamp: 0xbd1e2564
Exception code: 0xc0000409
Fault offset: 0x000000000007284e
Faulting process id: 0x31b4
Faulting application start time: 0x01d6516f663e7e12
Faulting application path: C:\Program Files\AMD\RyzenMaster\bin\AMD Ryzen Master.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll
Report Id: b71e6de1-a8fb-4600-9a3b-5c5fdde2f73e
Faulting package full name:
Faulting package-relative application ID:

0 Kudos

Re: Ryzen Master freezing up on start up

you can try ZenStates from github

or you uninstall ryzen master
download newest ryzen master
and install it
aaaand reboot

PC: R7 2700X @4.1GHz + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
0 Kudos