cancel
Showing results for 
Search instead for 
Did you mean: 

Red Team Discussions

Journeyman III
Journeyman III

Kernel power 41 rx5700xt

I have a problem and I have no idea how to fix it. All games are launched and  playing at 1080 60 fps + without any stutters and freezing. I don’t have any problems, but the other day I decided to install the AC Odyssey  and after starting the game a black screen appears and the computer restarts. In event viewer shows error kernel power 41. I decided to try the driver version 19.7.5. The game started, in-game benchmark passed on ultra settings at 60+ fps, but when it starts a new game it throws it to the desktop. I tried reinstalling various kinds of windows, installing drivers through the remote control on the video card, trying to identify problems with RAM, scanned the disk, updated the BIOS ... nothing helps.
My computer:
Amd ryzen 2700x
Sapphire PX 5700 xt

Asus prime B450 plus

RAM radeon performance series R7 2666 mhz 4 gb  x2

PSU Cougar cmx 850w

ssd A Data SU650 480 gb

0 Kudos
6 Replies
Journeyman III
Journeyman III

Re: Kernel power 41 rx5700xt

Change pci express bus slot, the card now work at pci express 2.0 (x4 mode) (was 3.0 x16 mode) the game work fine but lost -8-10 fps... 

0 Kudos
Esteemed Contributor III

Re: Kernel power 41 rx5700xt

Your RX5700XT is a reference blower right? What are the temps like? If they are high then likely more current will be used by the GPU.

You should not have to run the GPU off PCIe2.0x4.

You can do a search and you will see:
https://support.microsoft.com/en-us/help/2028504/windows-kernel-event-id-41-error-the-system-has-reb... 
also, this:
Kernel Power 41 error in Windows 10 [ULTIMATE GUIDE] 

Running at PCIe2.0x4 will reduce GPU performance and therefore reduce FPS which reduces power consumption.
If the game has an FPS Limiter, set that to a reasonable level.
If not then try running FRTC to keep FPS from spiking too high. 
As a last resort try running Radeon Chill with Chill_Min set as low as possible = 30, set Chill_Max to 300. Turn off Profile FRTC. Set Global FRTC to ~1 FPS below your monitor refresh rate or the FPS limit you want. Then launch the game from the game profile in Radeon Settings. Do not use the Radeon Overlay to change CHILL_MAX. You will very likely find that it will kill your Keyboard only input FPS, but Chill might be able to keep RX5700XT reference GPU temps down to stop power input problems. Rapid mouse movement should lock to Chill_Min = 30, or Global FRTC limit. The mouse locking behaviour is random in Chill.

0 Kudos
Journeyman III
Journeyman III

Re: Kernel power 41 rx5700xt

Solved the problem by update BIOS with empty PCI express port (w/o videocard). Now finaly iam happy with 5700 xt)

0 Kudos
Esteemed Contributor III

Re: Kernel power 41 rx5700xt

OK glad to hear it.

0 Kudos
Journeyman III
Journeyman III

Re: Kernel power 41 rx5700xt

well, decided to update the drivers to 19.9.2 and the problems starts again...

0 Kudos
Adept I
Adept I

Re: Kernel power 41 rx5700xt

try 19.10.1 most probably work fine.m8 

0 Kudos