cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

hfjhUK
Journeyman III

X570 Intermittent USB bug

Experienced DIY system builder (been upgrading / building machines since 386 /486 days) and have a severe case of the well documented intermittent USB bug on an X570 board.

System

5800x

MSI X570 Tomahawk wifi (with latest bios from 12th April 2021 - 7C84v163) 

4*8GB Ram

6900XT

2*1TB NVME

and (attempting to use Logitech k850 bluetooth keyboard mouse, which requires a USB dongle)

I have swapped the batteries in both mouse and keyboard and even typing this message the system has stopped responding to keystrokes randomly a few times for minutes at a time. I have tried the USB dongle in all three of the different USB hubs on the board.  The k850 works perfectly consistently on an MS Surface laptop. 

I also have reset the motherboard bios back to defaults and set the following to alleviate the issue;

1) Using PCIE gen 3

2) Disabling C-State 

3) Uninstalled, rebooted, and re-installed X570 chipset drivers direct from AMD (2.13.27.501)

I also have an external 4k br drive which I was also having USB issues during writes on multiple discs and multiple reboots/ shutdowns however I have a workaround which is producing better results with a PCIE to ESATA card which now works well.

The keyboard /mouse randomly starts / stops working (even on a new boot when entering Windows password /PIN) sometimes it will work, sometimes it may require 5 -10 minutes before the system accepts any key press, and this happens randomly throughout any windows session completely unpredictably.

Please advise if you want me to submit any logs that would be helpful 

1 Reply
hrpuffnstuff
Miniboss

I have a gigabyte X570 aorus master with the lastest agesa 1.2.0.2 and while my usb issues are down they still occur in a similar manner.  For me it happens while booting when my usb ports get turned off leaving me with no way to interact with windows.  I end up hitting reset and when it comes back up everything works.

In the past I also had an issue with my BT being disabled that forced me to drain power and when it rebooted BT worked fine.  With past several bios versions that issue hasn't resurfaced (fingers crossed).

I'll probably go back to Asus on my next board as this one was a departure due to lack of inventory.