Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Wonder if anyone can help explain why up CPU upgrade doesn't work?

Hi Everyone, 

I've just joined the AMD support forum community.  I wonder if someone can help me with some advice, please?

I have an ASUS A320M-K running an old A10 processor and BIOS currently 5606.  I decided to buy a Ryzen 5600G processor to upgrade it.

The instructions said upgrade the motherboard BIOS before swapping the processor, as the Ryzen 5600G may not be supported with older BIOSs.  So I tried to update to the latest motherboard BIOS version - 6210, but get an unsupported BIOS nessage. 

I get the same message for all the other BIOS versions from the ASUS web site as well - 5862, 6024, 6042, 6064, 6202, and 6204- all except 5606. I was originally on BIOS version 5603 and the BIOS update to 5606 worked fine.  

Things I've tried so far is to try updating using the EZ Update 3 program from both the BIOS and the app in Windows 10. 

I've also tried BIOS updating using FAT32 and NTFS drives. Also I've tried using the Internet update option in ASUS EZ Update 3 to search for a BIOS update, but the program states that the BIOS is already up to date.  I know this motherboard is capable of a BIOS up to 6210 though. 

I don't know if correct or not, but I've read this failure to upgrade past version 5606 (to BIOS 5862) is a safety feature because the A10 processor isn't supported past BIOS version 5606. 

When I change over to the Ryzen 5 processor, it doesn't boot.  I suspect the Ryzen processor does not work with version 5606 of the BIOS.  If it had booted I could have tried updating again.

My hardware in this system is a 256gb PCI-e M2 drive with latest version Windows 10, 16Gb of Corsair memory and a 650W Corsair PSU. 

When I change the processor back to A10, the computer boots fine, so I haven't broken anything.  

I need to somehow update the BIOS so that I can run the Ryzen processor, but I can't boot the system with the Ryzen processor installed, because the BIOS is too old.  

I thought maybe there's a writeback feature where I can upgrade the BIOS using a usb stick, but I don't think the ASUS A320M-K has this.

Does anyone have any thoughts please?

Many Thanks


1 Reply

The reason why you have the wrong BIOS version installed that would recognize and boot with the 5600G processor.

According to Asus CPU LIST for your motherboard:

Ryzen 5 5600G (3.9GHz,45-65W, L3:16M,6C) ALL 6042 GO


You need to upgrade your BIOS version from 5862 to 6042 for your processor to work and boot up.

NOTE: I have a Asus Motherboard also. when you download the BIOS file you need to run the command line batch file to rename the BIOS file to be able to be installed.

Screenshot 2024-02-23 170829.png

According to BIOS Version 5862 it remove support for Bristol Ridge and 7th Generation processors and Athlon processor. Screenshot 2024-02-23 171043.png

You didn't mention the exact A10 processor you have. It can either be a Bristol Ridge or Trinity processor.

EDIT: Reading your original post, BIOS Version 5606 was the last BIOS Asus uploaded before removing support for Bristol Ridge and 7th generation processors. That is why you are getting that error message, in my opinion.

I would open a Asus Support ticket and find out why you can't upgrade your BIOS version with your A10 processor after BIOS 5606. That doesn't seem normal.