cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

dangerclosedigital
Journeyman III

Windows 10 1903 with Hyper-V Role very slow login screen

Hey guys, I don't use my PC for gaming, I use it to host Hyper-Vs roles for my day job and for Photoshop and video rendering in my side business. I just updated my processor this weekend to a 3900x from a 2700x on an Asus x470 Pro Prime motherboard, same motherboard and same Corsair 3200 memory as it used with the 2700x processor prior to the processor swap, and now I am having issues. I came here seeking some guidance for some issues, and to see if anyone here has had similar experiences as me. I have two distinct problems.

The first problem is that my memory is no longer stable using the DOCP settings in the BIOS to read the timings from the modules. In order for me to boot and not blue screen, I must turn DOCP off and set the memory speed to 3200 manually for it to be stable. I even attempted a new install of Windows 10 on freshly destroyed and recreated partitions on an NVME drive, but even the Windows Setup program couldn't get through 100% of the file installation process without random errors, at least not until I turned off DOCP where it appeared to run fine until...

My second problems is that once I enable the Hyper-V role in Windows 10 build 1903, the role installs as it should, but the time between the busy indicator spinning on the screen during bootup disappearing and the login screen appearing can be anywhere between one and two minutes. Once the login screen appears, everything seems to be working as it should, but the initial boot time is just too much to bear. I did not have this issue until I enabled the Hyper-V role, prior to that boot/login times were normal.

None of these issues were present when I was using the 2700x, processor which used the same motherboard and memory, as well as the same Windows configuration. I game only on my xbox, and I value stability over speed so I am not attempting to overclock any portion of the system.

Has anyone else experienced these issues?

0 Likes
6 Replies
virbea
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

Here is another one experienced the 2nd issue of 1-2 mins booting.

My environment is Win10 1903 on AMD Ryzen 5 3600 with a B450 motherboard.

If I enable SVM in BIOS, then the slow booting will occur.

Under my investigation of the differences of event logs during logon session between SVM on/off,

it seems that the lsass process will get stuck for 1-2 mins, which approximately equals to the booting delay when SVM on.

I have no idea why the lsass process will have this kind of misbehavior.

I will appreciate if anyone could share more information.

0 Likes
virbea
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

Here is me again.

After updated AGESA to version 1003ABB, the problem seems to be solved.

I am not sure if this patch totally solved the problem or not, so I will keep observing it for a while.

0 Likes
mtaivai
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

I do have the same problem with Ryzen 3900X on ASUS Crosshair VII Hero (X470). Although I can still use SVM + Hyper-V, it's very annoying to wait almost 2 mins of total boot time (whereas normal would be ~20 secs). 

0 Likes
dangerclosedigital
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

Upgrading to the most recent UEFI BIOS on the Asus X470-Pro Prime motherboard resolved the extreme slowness issue for me. Considering that you too are running an Asus board, your resolution will likely be similar. Using the built-in flash utility in the firmware makes downloading and installing the update relatively painless. Prior to the upgrade, I was finding WIN32K Error 263 in my event log, which took exactly 1:40 to clear before moving on with the boot functionality, after the upgrade I am getting sub-20 second boots.

0 Likes
mtaivai
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

Yes, I do have exactly same symptoms: even the timing of 1:40 seems to be about right! Unfortunately I already have the latest available BIOS (ROG CROSSHAIR VII HERO BIOS 2501 dated 2019-07-18). 

0 Likes
mtaivai
Journeyman III

Re: Windows 10 1903 with Hyper-V Role very slow login screen

I upgraded my Windows 10 Pro to Windows Insider prerelease build 18956 and the problem is gone! So, it's possible that this is not (just) a UEFI problem after all.

0 Likes