Showing results for 
Search instead for 
Did you mean: 


Adept I

Why my new build no work? I recently bought the new Gigabyte X470 AORUS Gaming 7 WiFi to work with AMD ryzen 5 2600 x and with a Kingston HX421C14FB2/8 using a working Radeon Pro WX 7100, I try almost everything. I can't acces to Bios, no display, the mob


11 Replies

What does your manual say that boot code 24 is?

The MOBO makes one beep, in the Onboard LED for the VGA. Then the LED turn off after that short beep.

Adept II

If the RAM is on the QVL then I think you RAM might be placed in the wrong slot. I did not see a post code 24 for your motherboard in the users manual, but I did see that the codes 2B~2F are Memory initialization. So maybe the code 24 is in between code 2B and code 2F....(I think code 24 on Asus MB is memory initialization)

Clear the CMOS then try the RAM first slot on channel A, but try them all if that does not work.  If the post code does not change from 24 you should contact Gigabyte. That code cannot be referenced so it is not much use.

The four memory sockets are divided into two channels and each channel has two memory sockets as following: Channel A: slots 2 and 4   Channel B:slots 1 and 3. The manual does not give a optimum slot for a single RAM stick just for 2 sticks, 4 sticks, single-sided  and double sided. You can find a diagram of your motherboard in your user manual.

Ok Thank you for your support, Indeed I already change the RAM in all the slot and nothing the same problem. The Model Number is in the QVL for my motherboard. So right now I'm buying a new one from Amazon so I'll get a new pair on Friday, I'll update the status and hopefully all will be solve.

Corsair CMK16GX4M2A2400C16R RAM Memory Kit


Adept I

I'm updating the status of this nightmare! Now I got a Code AE. I alredy place the new RAM (from QVL), clear cmos and change the postition of the RAM in diferent Slots.

What AE means? and did I missing something?

Continue the Short Beep in de VGA LED and then it turn off (only the LED) 

No Display (never), is a new build.

Never enter to BIOS.

Thank you for all the help that someone can give me.



This website helps define all the Gigabyte codes for you: .

This is what AE means: AE            |        Boot to legacy OS from the link above.

This is from a comment from one of the Forums concerning AE code :

Did it actually boot into the OS? A "Legacy Boot Event" means that instead of using UEFI to boot, it's using the older BIOS standard to boot into an operating system. Try booting into the UEFI setup and setting it to UEFI mode.

Also from the same link a fix:

"I found a solution for the AE error code in my PC.

Given that the error code is AE - Legacy Boot event, I decided to change my SSD partitioning scheme from MBR to GPT.

(For the ones who don't know, MBR is the old BIOS style partitioning scheme, whereas GPT is the new standard for EFI systems.)

So I booted a EFI Windows installation, pressed Shift+F10 in the first install screen to get a command prompt, called diskpart util and executed clean command on the SSD.

Then, Windows setup created GPT partitions on the SSD and voi-lá: the issue is gone now!!!!

This is my particular case, but you should give it a try if you are using MBR partitions.

Afterall, it was just some hideous incompatibility issue between my SSD latest firmware using MBR partition with my board's latest EFI."

Wish you luck!

By any chance, do you have your monitor connected to the motherboard or to the WX 7100 GPU card?

If it is connected to the Motherboard could be a reason why you are not seeing anything since BIOS probably switched to the WX 7100 card for it graphics display. If you remove the WX 7100 it should switch back to the Ryzen APU graphics on your motherboard.

Note: from everything I found out about Code 24 it is not a trouble code rather a Status code.

This is from your Gigabyte Motherboard Manual concerning the 4 pin plug that arcticwind​ was commenting about:


By looking at the attached photos you provided, I can see that there is a 4 pin power connector that needs to be plugged in.  It is just below the 8 pin power connector at the top left side of the motherboard. (see pages 15 and 16 of the motherboard's manual)

Journeyman III

I do not know if this is still an continuing problem for you, but. I had the same issue and fixed it and it is working flawlessly now.

I will post the steps of what i did to fix the issue.


Step 1: Re-install Windows (Assuming that is what you're using) and DO NOT connect WIFI or Ethernet. Leave the computer offline

Step 2: Go to another computer, (Laptop or Tower. Doesn't matter) and install the drivers for the board onto a flash drive or external HDD/SDD

Step 3: Once you're into windows connect the flash drive or external drive to the computer and install your drivers. (KEEP COMPUTER OFFLINE)

Step 4: After all drivers are done and installed, restart the computer and then connect to the WIFI or Ethernet, and let windows do its updates.


That should be all. This worked for me. It seemed as if i was having issues with the raid drivers windows was installing, I also had the same issues when Driver Booster installed the same raid drivers so i would highly suggest not to install Driver Booster and leave the drivers be after that, unless you're installing stuff like AMD graphic card drivers or chipset drivers. Otherwise leave all the drivers be. I hope this helped, if you are still having issues. If not, please try to pass this around. Just in case others are having the same issues.

Journeyman III

I bought Gigabyte X470 Aorus Ultra Gaming board from Amazon UK on August and after 1 month, 3 days ago system didn't POST.

Today I was able to bring the system back to life. Used AMI BIOS dual BIOS restore sequence, pressing power-on button and reset button simultaneously and keep it pressed for 10 seconds restored BIOS from backup CMOS chip.

But, unfortunately, it seems primary chip can't retain loaded data. when I shutdown and restart, system again went to the same status-led alternating sequence. Had to restore again using power-on + reset sequence.

I haven't encountered such BIOS not retaining issue in my life. But I will replace the battery also even though I know it will not resolve the issue. I'm thinking of RMA the board and ask for a refund. Then go for a Asrock Thaici board.

I uninstalled entire Gigabyte AppCenter because only possibility of erasing BIOS I could think of is apps like @bios, mobo led colour changing app, etc. And also revert back to original F2 BIOS.

Ryzen 5 2600, Gigabyte X470 Aorus Ultra Gaming, G.Skill Trident Z F4-3200C16D-16GTZB 8GBx2, Samsung EVO 860 SSD, WD 1TB HDD

Journeyman III

24 and 40 means you booted fine, did you maybe accidentally plug the hdmi into the motherboard instead of the graphics card? This will only work with an apu, as for AE the listed meaning is boot to legacy OS I'm not entirely sure what OS you're running or how your drives are set up (gpt or MBR) but it may be related to that