Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Why does Threadripper 1950x recognize only 32gb of 64gb installed?

I've doubled my G-Skill DDR4-3000 Trident Z RAM from 4 x 8gb to 8 x 8gb identical RAM on my Gigabyte Aorus X399 Gaming 7 motherboard. BIOS and CPU-Z detect the new memory, but Windows 10 Pro x64 (Version 1803) continues to report that only 31.98gb are usable. For some possibly related but unknown reason, memory latency is also extremely slow with a Performance Test 122 score, though PassMark's world average is 42. 

Steps taken

  • Installed the latest AMD Chipset Driver (18.10.0418 as of April 18, 2018)
  • Activated Ryzen Balanced Power Plan included with the above driver
  • Aorus X399 Gaming 7 MOBO BIOS is current, F3g
  • All memory slots check out okay
  • Tested each RAM module separately with G-Skill support assistance
  • Passed Windows Memory Diagnostic
  • Activated XMP

Desktop (CyberPower CFGTRZ C Series build)

  • Gigabyte Aorus X399 Gaming 7 MOBO
  • Ryzen Threadripper 1950x 3.4ghz CPU
  • 800-watt 80 Plus power supply
  • 2 x Nvidia 1080 Founders Edition 8gb GPUs in SLI configuration
  • 1 x 2160 4K BenQ monitor, 2 x 1080 Asus monitors, all via DisplayPort




12 Replies
Big Boss

michaellinder,  I would suggest you do a Clear CMOS and see if that helps - should always be done when changing HW.  Have you tried the old quad memory set and the new memory set?  I would recommend you do (Clear CMOS each time).  What you are seeing is the results of the fancy memory testing in the new BIOS/UEFI.  The memory is detected OK but cannot be made to pass, so Windows is only presented with half of the memory.  This is fairly common.  Obviously make sure all sticks are well seated.  Please post your PassMark results.  Thanks and enjoy, John.


Thanks for your help, John. It's greatly appreciated.

I cleared CMOS (which BIOS acknowledged) but it hasn't made a difference. Windows 10 x64 continues to report only 31.9gb as usable. On reboot, BIOS made two quick attempts at posting before a successful third try without my assistance. I'm assuming this is its way of dealing with changes  incrementally.

Per your request, here are my PassMark ratings. I've asked G-Skill for their permissible settings for DDR4-3000 Trident Z RAM which are currently unavailable at its website. Beyond the RAM issue, it's surprising that dual Nvidia 1080s in SLI config would perform so poorly on 2D graphics while they blaze through 3D graphics. Do you think it's related to the RAM issue? The Disk Mark rating is low due to several storage hard drives in the system that are dragging down the speed of the three SSDs I use for Windows and other primary operations.



Thanks, michaellinderd.  You are very welcome - glad to help if I can.  Here is my PassMark:


My specifications:ASrock Fat1 X399 Pro Gaming, TR 1950X, RAID0 3xSamsung SSD 960 EVO, G.SKILL FlareX F4-3200C14Q-32GFX, Win 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler, Radeon RX580, BIOS 2.00, 2xHDDs WD

I am also surprised with your on the Video performance.  I suggest you run GPU-Z​.  Be sure to look at both cards but post only one here, especially if a problem.  Next to the Bus Interface is a large ?  Click it to run the Render test to see the connection type under load.  It may request you to DL a DirectX module.

Please run the separate quad kit test I did not explain well before.  I assume you have two four stick quad kits and can identify the original four and the new.  Put only the original in the recommended slots and test.  Remove these and do the same with the new quad kit in the other recommended four slots.  Thanks and enjoy, John.

EDIT: The multiple attempts at booting may be the memory testing and failing and retesting.


I would talk to Gigabyte about this. I have seen this complaint many time specifically on those Aorus boards. If you are not on the latest bios you could start there by updating to the latest bios. But if that does not fix it talk to Gigabyte. Did you use ram from their compatibility list for that board? If so you have good leverage for them to do something. Google "gigabyte aorus ryzen boards not recognizing 3 and 4 ram slots" you will see lots of complaints about this.


I have spoken to Gigabyte, Pokester. They suggested removing all but a blank hard drive and temporarily installing Windows on it. Didn’t work. Their only other suggestion is to remove and reseat the Threadripper CPU.

First, I cannot believe Cyberpower might have bent a pin, but even if they did I’m not a PC builder and I’m totally unqualified to disassemble the CPU housing, dismantle the liquid cooling system, pry the CPU loose, reseal the CPU snd reassemble the cooling hardware — without causing damage that’s not there now. Sounds like a Gigabyte “this’ll get rid of him” tactic.

CyberPower washes its hands, too, since “third party” parts were installed — an additional four identical RAM modules as those they installed. And because I added a Nvidia 1080 GPU, and two SSDs, my year’s warranty is null and void for having dared to add something into their precious PC. The PC biz seems to have become totally corrupt.


Wow, tough news, michaellinder.  Will Gigabyte RMA your MB?  Perhaps you have a friend that has experience building systems to help you remove the CPU and package the board to ship to Gigabyte.

My previous response (submitted at lease two hours ago!) is still:

Currently being moderated.

You stated that "All memory slots check out okay".  Does this mean that you booted with only one stick in each slot with no problems?  I also assume you booted with each stick, one at a time.  Please try my old/new quad kit test.  Good luck and enjoy, John.


Unfortunately, folks who buy Gigabyte Aorus X399 Gaming 7 MOBOs have limited slot diagnostic capabilities because of the motherboard's mandatory module deployment scheme. Apparently, if a single module, or module pairs, are not placed in these exact slots, the MOBO will not post. The best I could do is start with a single, then add more memory in pairs according to Gigabyte's schematic — and test it along the way.

Here's what happened as I added identical G-Skill DDR4-3000 Trident Z RAM modules. RAM decay became evident when I reached 6 modules. This points the failure finger at MOBO slots 7-1D, 5-1C, 4-1A or 3-1B — the only slots that hadn't been associated with an accurate RAM reading to that point. At least that's the conclusion I've reached at this stage. It's made me somewhat skeptical of Gigabyte's strategy of reseating the CPU where, in their words, "All the memory info is stored."


On a related topic, I'm told that I'll be somewhat crippled in precision juicing-up the RAM if I ever succeed in resolving this nightmare misadventure. G-Skill reports, "DDR4-3000 is not a natural memory multiplier for AMD CPUs, whereas DDR4-2933 and 3200 are native to AMD. You can attempt a lower value first then work your way up."

Who knew? I saw nothing about this in any of the fine print, and CyberPower never said a word. Seems buying a gaming build is just as dicey as a DIY project. It appears that my only project is to pay a local PC shop to dismantle the rig, send the Aorus back to Gigabyte (if they'll have it) and wait for a replacement and its installation. Sounds like weeks of being out of business.


I cannot help much with the legal issues but will keep a watch on the technical problems and respond if I think I can contribute.  The best and enjoy, John.


If Cyberpower listed that computer as having available expansion slots for memory then you have them right there. Unless they specifically claimed in writing that adding your own memory is something you can not do then they are just steering you down the road. Contact them again and tell them you will be filing a BBB complaint in their location and be filling a small claims court suit in your county. Believe me they won't want to deal with that over a less than $200.00 part.

This is one of the reasons I do not ever recommend off the shelf systems for gaming. Either build it yourself or have a local repair / system builder do it for you. You at least have someone to help you then. So sorry you are having this issue. I ran into this same kind of problem with Acer years ago after a year of fighting they did finally replace the system, it wasn't until they got the subpoena to appear in small claims court. Since that time I started using the BBB very successfully. You just find out where the company is located and what BBB jurisdiction they are in and file your complaint. No company likes having unresolved BBB complaints.

Talk with Gigabyte again and just tell them you pulled the cpu and it made no change and send them your ram stats from bellow. That should show them the have a hardware issue on the board. They may however still not do anything even though morally they should, as they are an oem to Cyberpower. Cyberpower is the one who should be taking care of you. I have heard nothing but bad things about their service over the years.

In the future if you want a prebuilt system from a company who stands behind their machines, by the house brand PowerSpec from MicroCenter. Nice machines, just like I would build myself and cheaper than I could build. You can also always locate a local pc repair shop as they typically custom build new machines too.


Have you tried to manually input your memory settings.. get off the xmp profiles, it was killing my 1700 performance, after I manually input the memory timings my ryzen system worked better..

and flash your bios to the latest version..


He has 2 of 4 slots that don't even recognize the memory, and it is all identical ram. This has been a wide spread issue on Gigabyte Ryzen boards and his PC maker Cyber Power won't do anything about it as they don't support ram he bought and installed. To them it doesn't matter that slots 3 and 4 don't work only that what they sold works as is.

Journeyman III

Problem solved (I think)

I had the same problem with my Aorus X-399 mobo.  Was running 16 meg sticks 3600 mhz from Gskill in two slots.  No problem.

Added two more and only saw 48 megs of ram and not the 64 that were installed.  Got the ram replaced, same issue.  Finally narrowed it down with the Gigabyte gal and we figured that one channel of ram was bad.  In my case it was the D channel.

Gigabyte did the RMA but it's taking forever so I bought another mobo.  Problem solved.  Heard from Gigabyte who said there was "damage" although they said they were fixing it for free. Haven't got the original board back yet but all my slots read what's in them.

Now if I could only get windows 10 to stop crashing for no reason.....