Showing results for 
Search instead for 
Did you mean: 


Adept I

Where can i find drivers of AMD Ryzen 5 4500U for ubuntu?

I can't change resolution, plug in external screen, change orientation of screen becouse i can't find drivers for my GPU wich i have with processor AMD Ryzen 5 4500U in my ACER SWIFT 3. I am using ubuntu 20.04 does any body had similar problem and solved it?

10 Replies

Went to AMD Download page and AMD only has drivers for Windows 10 and no other Operating System: 

Maybe later on AMD will have drivers for Linux Users.

You can open a AMD Service Request (Official AMD SUPPORT) and asked them where you can find Linux drivers for your APU from here: 

If Acer doesn't have any Linux Driver you can try Linux Phoronix Forum and see if anyone has one to download.

A also found only windows drivers for this processor. A also searched Phoronix Forum and found nothing. Thanks for Official AMD SUPPORT request hint! Just did it

Went to Phoronix Forum and found several threads concerning Ryzen 5 4500U processor but this linux thread seemed to be using Linux with the 4500U in its review: 

The Lenovo Flex 5 15-inch 2-in-1 laptop that I picked up for $599 USD was used for this round of testing. This laptop features the Ryzen 5 4500U 6-core CPU with Vega graphics, 16GB of dual channel memory, 256GB SSD, and 14-inch 1080p display. It's quite a nice budget laptop with very great performance for the price. The operating systems tested for this comparison included:

- Clear Linux 33390
- Fedora Workstation 32
- Manjaro Linux 20.0.3
- openSUSE Tumbleweed
- Ubuntu 20.04 LTS
- Ubuntu 20.10 Daily Snapshot
- Microsoft Windows 10

All of the Linux distributions loaded up on the Lenovo Flex 5 without any notable issues, with the sole exception being the Ubuntu releases. With Ubuntu 20.04 LTS (and 20.10 daily snapshots, for the moment) using an older Linux 5.4 kernel, the Renoir graphics aren't supported out of the box so in those cases I switched to a newer Linux 5.7 kernel with the Ubuntu Mainline Kernel PPA. The other tested Linux distributions all have newer kernels to avoid this issue and had working accelerated graphics.

Seems like AMD Generic laptops doesn't have Linux drivers but AMD generic GPU drivers does like this Vega56: 

don't know if these drivers will work in a laptop or not.

Someone else experience with Linux will need to assist you in this matter.


Thank You for Your help. that works and helped alot

Big Boss

Acer like all laptop vendors ship windows with their rigs. Linux is not widely used on new machines, it takes time for the kernel to be updated.

Use Windows and use VirtualBox if you need to use Linux for some reason

Journeyman III

On my Acer Apire 5 with AMD Ryzen 4500u and Xubuntu 20.04 linux it was helpful to add


to the kernel boot options to avoid desktop freeze after some minutes inactivities.

Journeyman III

I have a Lenovo T14s with AMD Ryzen 5 Pro 4650U. I have installed Ubuntu 18.04 LTS and I cannot: i) connect an external monitor, ii) change the brightness of the display, iii) change the resolution of the display.

Obviously Lenovo should develop Linux drivers. Do we know when this will happen?

Is there any other solution? I have tried the above suggestions without success.

Note that in Windows 10 there is not problem.


Lenovo ships machines with Windows. Linux is more widely seen now in data centers where its used for web sites etc.

Journeyman III

Yeah, I had the same problem and solved it. It is the older kernel in Ubuntu 20.04, you need at least version 5.8. I asked about it in (

You can use a hardware enablement kernel, they are made for new hardware. I paste my last post with the solution:

IT WORKS! I decided to use the command from ajgreeny (sudo apt install linux-generic-hwe-20.04-edge), it took around 1 minute to install. I did a reboot and now the HDMI-Port works and I can control the brightness. Everything else works as well, as fast as before. Big thanks to everyone, and thanks Catkiller for clarifying about the ports and for confirming that there will be a real support! You're awesome!

Edit: Two days later it's still all running well, no problems at all. My new kernel is version 5.8.0-25. I searched around and found out that this 'edge'-hwe-kernel is meant as a preview and might be a bit buggy. Just a little warning. Here is a quote from


This represents the path that provides users early access to the upcoming HWE Stack that is to be released next for the Ubuntu 16.04 LTS. The aim is to provide this early preview in order to allow users to test the upcoming HWE Stack prior to the automatic upgrade taking place. (...) As mentioned, the kernel version provided by the hwe-16.04-edge path will provide early access to the newer kernel version up to ~6mo prior to the hwe-16.04 path receiving the same."


Good luck, you can switch back to the normal kernel when it is updated to 5.8.


You saved me. I have a Ryzen 5 4500u and Linux Mint. I installed the new kernel and now everything runs better (thanks to GPU acceleration). Thank you really much!