Showing results for 
Search instead for 
Did you mean: 


Journeyman III

WHEA Logger Event ID 19 error with Ryzen 3600.



I'm having some weird issues where i have no answer to so i thought i ask here. 

The issues im having are that i replaced my RAM from G.Skill FlareX to G.Skill Trident Z Neo and exchanged my Samsung 950 Pro for Samsung 970 EVO PLUS  and all hell broke loose really. 


This means that i was stable before with 4.4 GHz Ryzen 3600, 3800 MHz CL16 RAM with 1900 fclk but now its very erratic and i get this Event ID 19 error with the following error when testing with OCCT: 

A corrected hardware error has occurred.

Reported by component: Processor Core
Error Source: Unknown Error Source
Error Type: Bus/Interconnect Error
Processor APIC ID: 0

The details view of this entry contains further information.


Something tells me that its the fclk but it was stable before but cannot get it to be stable now for the life of me. 


Here is my hardware: 

Ryzen 3600

Asus crosshair vii hero wifi with BIOS 3103 now but i tried with the latest with the newest AGESA but it simply doesn't work right so i reverted back to 3103. 

Nvidia RTX 2060

Samsung 970 EVO PLUS 

G.Skill Trident Z Neo F4-3600C16D-16GTZN.This suppose to be Ryzen optimized RAM but its not what i see as when i load up DOCP only half of the settings are actually applied.. It worked fine on my FlareX 3200 MHz kit though. This new G.Skill RAM should be better than my FlareX and testing RAM with TM5 i find no errors but when i stressing with OCCT i get this EVENT ID 19 error. 


This only happens with OCCT and in some games as far as i know and its very random. 2 days ago i tested for 6 hours without any issue but when i tried yesterday i got this WHEA EVENt ID 19 error and the whole PC became unstable.. 


I am very curious as to what can cause this erratic behavior and how to solve it. 


I really hope there is an sollution or explanation for this as i cannot use my system anymore. 


if you need more info plz let me know and i will provide all the info i can. 



19 Replies
Journeyman III



No one knows what can cause this?


Your RAM config and FCLK are first suspects. 

Set your RAM to 3200, default (auto) timings. FCLK 1600. See if error persists.

I used to have 3667/1866 clocks, but got WHEA 18. Setting 3200/1600 solved it completely. 


Well that's the weird thing, these problems happened after i switched RAM and SSD. 


Before it was perfectly stable at 1900 fclk and 3800 MHz RAM... 


My current RAM is 3600 MHz DOCP stock which also can cause issues ive read on the internet.

What an cluster**bleep** of problems with Ryzen man.. sorry for my language but this is just very strange and weird.


Similar issue. But I've got the Whea 19 in idle state only.

My RAM allows 3600MHz only via XMP, so If activate it I give Whea 19 and random resets. In case the basic Jedec 2400 or manual raise to 3200Mhz I have no issues. After lots of days spent I probably caught the culprit: global c states. Even in raise to 3600mhz I have not Whea and no resets with CStates disabled. Maybe it is the voltage issue, i dont know

+ MBD ROG Strix B550-F Gaming WiFi, BIOS 2006
+ CPU Ryzen 5 3600
+ RAM HyperX Fury 8GBx2 DDR4 3600MHz HX436C17FB3K2/16
+ SSD Samsung 970 PRO 512 GB MZ-V7P512BW
+ GPU ASUS geforce gtx 1650 super oc 4gb
+ PSU Corsair RM650x


Forgot to note:

Last chipset drives are installed, last Windows updates are installed, last stable bios is installed (2006).

No issues with CStates under the "official" 3200Mha memory speed 


I solved it for now! 


It was too low voltage.... apparently 3800 MHz requires 1.450v on the RAM in order to be stable on both my FlareX and trident Z neo kit.. 


I was too scared to push this high voltage but up to 1.5v is acceptable for 24/7 so im good for now. 

















Do you mean that the RAM vendor specifies wrong voltage in XMP? 



Some kits are better bin than others which can require more voltage for the same clocks.


But AFAIK, XMP specifies voltage, if this kit does not work at this frequency and 1.35V it should be not used in this hi-freq kit, or higher voltage must be programmed in XMP.

I guess it is the RAM vendor fail. They try raise RAM-IC as high as possible and sell the faulty sticks, isn't it?


Not really, 

My 3600 MHz kit works well with xpm/DOCP and it puts 1.350v but to achieve higher clocks it needs a lot more voltage than other kits that are binned for higher speeds. 


got it, ok. but in my case I can not achieve specified frequency (3600Mhz 1.35v), I'm not sure, but disabling CStates allows to stay on 3600 without errors and reboots. I guess it is voltage issue.


Hard to say without knowing what hardware you are using. 

What hardware are you using? Mobo, CPU, RAM etc. 


My config is:


+ MBD ROG Strix B550-F Gaming WiFi, BIOS 1205
+ CPU Ryzen 5 3600
+ RAM HyperX Fury 8GBx2 DDR4 3600MHz HX436C17FB3K2/16
+ SSD Samsung 970 PRO 512 GB MZ-V7P512BW
+ GPU ASUS geforce gtx 1650 super oc 4gb
+ PSU Corsair RM650x


All of them except GPU has been bought recently. GPU has been moved from my previous system, where been working for 1.5 years without any issues


Sorry, I forgot, BIOS 2006. I've updated it recently


your RAM is not B-die so don't expect too much from it. 3600 is fine though. 

Did you try to reset cmos and just load the DOCP settings? Sometimes you have to look for the settings in bios and dial them in manually as Ryzen has issues with DOCP at and beyond 3600 MHz.. The first 10 timings are correct but from there you have to set them manually. Maybe voltage too. I don't know anything abbout your board to be honest so its difficult.

You can try to find your answers here:™-1-7-3-overclocking-dram-on-am4-memb...




Hi there, thank you very much. Yep, I did. Just reset whatever settings andset only DOCP to the predefined profile from XMP. And it does not work))

As for manual set of timings, ok, I already set it manually, but it does not help. As for RAM: yes, it is not hi-end skicks, but it rated to 3600MHz speed so I expect it shall work properly at 3600. The higher frequencies are not interested for me while I have R5 3600.

Thank for the link, but I already use DRAM calc

3600Mhz for ryzen 5 3600 is a raise, so maybe it is not good decision to leave Auto settings for the SoC voltage under 3600Mhz on RAM. The disabling CStates maybe solve this problem indirectly. 


Sorry for late reply. 


Ryzen is very erratic as one moment you are stable and the other you are not.. Today for example im stable and no issues and the day after its showing erratic behavior. 

Its just weird that i could get 3800 MHz stable with my FlareX and cannot get it stable with my Trident Z NEO... they both B-die.. 


3600 MHz is not that hard and uncommon for R5 3600. Set Soc to 1.1 always as that is good for stability, anything beyond is not necessary. 


I never disabled Cstates as im manually overclock my CPU to 4.4 Ghz with 1.275v so i have no issues there. 


Hello there! I decided to report about changes of my issue, maybe my results will help to anyone.
To make long story short, I have replaced the CPU with 5600X.
After installing new CPU the BIOS has been reset to the defaults again, and the only points I tuned is:
1. DOCP on 3600MHz
2. Disable C-States (just in case, I had a problems with this option before).
In general, comparing to R5 3600, the only thing changed is the CPU.
All the parameters in BIOS are identical, including RAM timings, frequencies and PBO options.

The results: stable work without WHEA errors either under huge load and in idle state on 3600Mhz, 2 days uptime, no issues.
I have tested in OCCT, Cinebench R23, CTR 2.1 RC5, AIDA64 benchmark, UserBenchmark.
Of course, the tests I made are not enough to consider the issue solved for me, I will continue testing, but I already can suspect that the issue was in the bad CPU potential.
I going to enable Global C-States and make tests with the PC power cycles.
On R5 3600 I had issues with the RAM on 3600MHz with the Global C-States disabled. After 2-3 days of shutdown I can not power up the PC if RAM freq is 3600MHz on R5-3600, the MOBO QLED symptoms: DRAM LED is always orange (DRAM fail). If I reset the PC by button, it begins to work (!!!). To solve issues for next 2-3 days I need to completely shutdown the PC (including the electricity power socket) and plug it again.
So, in general, I guess I have more luck with this CPU than the previous one.

P.S. this CPU is more hot than R5-3600, I have 95*C under Thermalright ARO-M14O and MX-4 under full load (OCCT, Cinebench), the frequencies are 4.4GHz on each core (stable boost).


2 month later: still no issues on 5600X and 3600Mhz Ram with C-States enabled, bios 2006. I even upgade RAM: installed extra 2 the same sticks, 4*8GB total. Default timings by DOCP.

Now I know for sure that the main issue was the CPU that not support higher specs unfortunately. Now this CPU is working stable in another system on ASRock B450 Pro4 and with the RAM on 3200MHz, no issues.