Showing results for 
Search instead for 
Did you mean: 


Adept II

WHEA Logger Event ID 18

Computer Type: Desktop

GPU: Radeon RX 5700XT

CPU: Ryzen 5 3600

Motherboard: MSI B450 A Pro Max

RAM: GSkill Ripjaws 8GB X2 (16GB in total)

PSU: Thermaltake Smart RGB 700W

Case: Midtower with 1 stock fan

Operating System & Version: Windows 10 Pro Version 10.0.19041

GPU Drivers: Radeon Software (Adrenaline) 20.4.2

Chipset Drivers: AMD Chipset Software

Hard Disk: SSD - Crucial 1TB M2 Nvme

Background Applications: Happens irrespective of what applications running

Description of Original Problem: My newly built PC keeps on restarting randomly. Sometimes, it will run for 6-10 hours without any issue. Then other times it will simply restart when I open an application (browser, tabs, etc.) or games and sometimes it just restarts at its will. Every time it restarts, the event logger logs the below errror:

"A fatal hardware error has occurred.

Reported by component: Processor Core Error Source: Machine Check Exception Error Type: Cache Hierarchy Error Processor APIC ID: 11

The details view of this entry contains further information."

Troubleshooting: I have updated all the drivers. Deleted and reinstalled and updated all the drivers. Checked if the CPU fan is properly attached to the CPU, if GPU is properly attached, if RAMs are properly attached, and everything else. All of them seem perfectly fitted. Used various software to test CPU, GPU, RAM, etc. All came back with good results. Did memory test and DISM test. Both were successful without any error.

245 Replies

Could this be related to the reported USB issues on B500 series MOBOs?

I have a screen on my G19 keyboard so I see when it messes up first. I moved it off the type A ports and the issue happened far less often but then my Steel series headset flashed before the crash. I moved all devices off the USB A ports. The issue is pretty rare now I think, but it happened today after coming back to a restarted PC and sure enough another WHEA event.

There's a Beta BIOS for the USB fix, I'm going to try it tomorrow. I can't say for sure this is my issue but the USB has been more unstable since I got my 5800X.

I thought it was Solved for a while by moving my keyboard but later more issues when I got my 6900XT, before that I was using as 780 GTX and it felt more stable.

I'll try to rember to let you know if this helps, but I saw a lot of people with 500 series boards and some with questions on USB devices so maybe it's related.



my brother recently noticed that he has his pc rebooting out of nowhere with no BSOD.

and it just happend that i came to check his event viewer and it has some WHEA errors some with id 18

these are his specs:

ryzen 5600x (stock settings)

cooler master cpu cooler hyper 212 black edition

aorus elite b550m motherboard

xpg spectrix d50 2x8 set to 3200mhz on bios.

kingston 480 ssd

seagate 1tb HDD

rx 570 gigabyte gaming 4gb

xpg pylon 750w bronze psu


how to solve this?

i already did memtest86 and it came with no issues, even though i couldnt boot the program at first for some reason, i had to disable the ssd and hdd so it could go with the usb instead.


I tried the TUF GAMING B550M-PLUS (WI-FI) BIOS 2006 AMD AM4 AGESA V2 PI Patch A, the one that should fix the USB issues. No change still getting the WHEA-Logger error.

I've also been getting Event 6008 "The previous system shutdown at 8:39:33 PM on ‎29/‎11/‎2020 was unexpected." ever since I installed my B550M with my 5800X back in November 2020, this was the original issue I noticed that I thought related to the reported USB issues because my USB devices flashed. This seems worse than the WHEA-Logger but less frequent.

I've had both these errors occur today, they don't occur every day they're pretty rare.

I've had the WHEA-Logger error occur 12 times only since I installed my RX 6900 XT on 22nd of Jan, it didn't occur before then when I had a 780 GTX installed.

I'm sure I can fix it by going back to my old card but I'd like to find out what it is about the RX 6000 series GPUs on B500 series boards?

I'll keep digging and let you know if I find a solution to the WHEA issue.


I can confirm that with my 5900x yet i have no blue screen error, system directly jumps to bios bootup sequence.


Close the C-state control in BIOS,it will be ok. 


I think I've fixed mine

no WHEA-logger or Event ID 6008 errors since 1/04/21 it's been 6 days and I left my PC on Idle the whole time.

I emailed AMD, I'd already tried most of the things they mentioned except one.
They said set Power Supply Idle Control, from Auto to Typical Current Idle.

I wasn't sure what this was so I Googled it, I found the below from inibrius on reddit:

"Power supply idle control is a motherboard setting for older (or cheaper) power supplies. A power supply requires a positive power draw to continue to feed power to the motherboard, if it detects a low power draw it assumes that the motherboard is in sleep mode, so it turns off until there's noticeable power draw. The problem is that older power supplies were designed where a minimum draw setting may be 5w, whereas a newer motherboard and CPU may only draw 1w at idle. So Idle control is used when your computer actually powers off instead of going to sleep on idle - it sets the threshold of low power draw at idle to like 7.5w so it won't trigger the PSU to turn off.

Basically for this setting, if it's working don't change it."

As my power supply is still pretty good but from 2013 I thought I'd give this a shot, I set it to Typical Current and had no issues since, when before it was happening once or twice a day if I left the PC on.

Anyway if you have an older PSU, give this a shot, hopefully this helps some of you


I have this exact same problem, PC was running perfectly fine for 5 months and then it just started, I updated my BIOS and all my other drivers, I'm not overclocking at all, and there are no crash dumps, no BSOD, the PC just immediately restarts.

AMD Ryzen 7 38000X  CPU

ASUS Prime X570-P CSM Motherboard

Gigabyte Radeon RX 5700 XT Gaming OC 8GB

G.Skill Ripjaws V 32GB (2x16GB) 3600MHz CL18 DDR4

I tried stress testing and all kinds of things, and the problem 'only' happens when my PC is not 'idling' but close it it, like just watching youtube. So far I cannot replicate the event by tabbing in and out of games or even tabs in Firefox, but as far as I can tell, the ONLY time it ever resets is when I have youtube playing something and I'm doing almost nothing else. I tried both Firefox and Chrome, and had the same reset with both, while playing youtube video's, but at completely random times. sometimes once an hour, sometimes not for 2 days.

Oddly, I updated my sound drivers and it seemed to be completely fixed, no resets or crashes for 5 straight days, then an hour ago I had another reset, so f*ck my life here I am looking for an answer. I will do a format/reinstall of my primary HDD/windows10 and install nothing but the current video drivers and see how that goes.

I also have no idea what else might be causing it, I had no updates of any kind (drivers, windows, programs etc) before it started happening.

I have been noticing very slight screen flickers happening too when opening/closing apps or tabs, which was not happening 2 weeks ago when it started, so hopefully a reinstall will solve it for me. I will post an update in a few days if its working or sooner if not.


Estimados, tenia el mismo problemas que tienen todo reinicios frecuentes y todo eso, mi configuración:

Ryzen 5600x

Gpu asus rog strix rx 5600 xt


 SOLUCION: Instale ultima BIOS (no beta) y se arreglaron todos los problemas de inmediato. Espero a alguien le sirva.





Thanks for your advice! Can you please let me know on where to find that setting in the BIOS?

I cannot locate anything like "Power Supply Idle Control" on my Asus Dark Hero...



Under Advanced, AMD CBS and then CPU Common options on mine I think.

Click on Advanced and look for AMD CBS and you should find it.

Many thanks! Found it!  


Well, I did a full clean format and reinstall of windows, and installed only my graphics driver, and it reset again, the only difference is that normally it would just instantly reset, this time the screens went blank but the audio continued playing for a few seconds before the whole thing restarted..

Guess I'll send it back to where I bought it and get them to fix/replace whatever is wrong.. such a pain in the ass..

Adept III

i just upgrade my old i7-3770k with Asus P8Z77V-Pro to MSI X570 Tomahawk wifi + Ryzen 7 3700x + Kingston Hyper X 16GB DDR4 3600 x2 ( HX436C17FB3K2/32 ). with other old hardware that i have is :
R9 Fury X
Corsair MP510 960GB
Asus Xonar D2X sound card
Razer Taipan mouse

Ducky keyboard.

seasonic X750 Gold PSU

Every thing seem fine , Game don't have any problem, but when i watching Youtube in Firefox and try to fast skipping the video, the system will restart with no BSOD , event i disable the auto restart when BSOD in system setting.

i check the Event Viewer, every time the system restart, i get WHEA Logger ID 18 with and Critical error Kernel Power Event ID 41

after 5 days of online search try many setting in bios. turn out the PROBLEM is Radeon latest WHQL 21.3.1 driver! so i roll back to the one i use on i7-3770k system "20.11.2 WHQL" now no problem when i fast skipping youtube video in firefox and no more system restart problem.

a graphic driver can cause system restart and WHEA Logger Event ID 18 error . so try other older version of graphic driver.


OK so I tried setting my PSU to 'typical' power instead of AUTO as per Cmdr-ZiM suggestion.. 3 days now and no resets or restarts.. the only thing that concerns me is that my PSU is NOT old, or even an older model.. I'm still convinced this is some kind of bullsh*t windows update that screwed me/us, but for now it seems to be working and stable. So Thank You very much for the tip, I would never have thought of it.

@shockblade your welcome glad I could help someone

I never would of thought of it either, AMD put me on to it. It was part of their standard troublehshooting at the top of their list. I'd already done everything else on their list myself but I never knew of the PSU thing.

Your PSU doesn't need to be that old, it just needs to not have the low power mode. I'm sure mine doesn't have it due to it's age but I don't know what spec you need to check on your PSU. I'm sure System Intergraters are aware of this but I've been out of the game a while.

I'll prolly upgrade my PSU at some point to get more effeciency but I'm in no rush.


Well, after almost 4 days with no problems, I had another reset...

F&**&@FOLb FO(*F FP(@)&@)&FH#

I'm going to try a DDU and reinstall my graphics, after that, I just have to send the whole system back to get tested I guess..



I checked the event viewer, and BEFORE the crash I had TWO errors I have not seen before..

Error setting traits on Provider {8444a4fb-d8d3-4f38-84f8-89960a1ef12f}. Error: 0xC0000001


Faulting application name: Radeonsoftware.exe, version:, time stamp: 0x60491edb
Faulting module name: Qt5Core.dll, version:, time stamp: 0x5e6f5e90
Exception code: 0xc0000005
Fault offset: 0x0000000000004146
Faulting process ID: 0x2ba8
Faulting application start time: 0x01d730bcf04c7d1e
Faulting application path: C:\Program Files\AMD\CNext\CNext\Radeonsoftware.exe
Faulting module path: C:\Program Files\AMD\CNext\CNext\Qt5Core.dll
Report ID: 792af5e7-68d7-455b-b0d6-93c7cd0134de
Faulting package full name:
Faulting package-relative application ID:

I have done the DDU and clean install of my video drivers since then, so I'll see how it goes.

If I end up sending the system back under warranty, I'll be sure to find out what was wrong and post it here.

@shockblade Dang that sucks, I wonder if that error had a separate cause. It might pay to keep typical idle current on till you sort it as it will be safer with it on.

The rest of the instructions I got from AMD were only putting BIOS to defaults, making sure everything was up to date Windows, drivers, firmware, chipset, etc, and reseating things like cpu and power cables.

If nothing is working might be time to contact AMD see if they have something else to try of if it's replacement time.

Mine hasn't reoccured but I'm still not sure if my PSU should be able to support Ryzen 5000 or not.

It's a strange issue, I'll keep researching it an let you know if I find something.

Journeyman III

I also had the same issue with pc just black screening and rebooting. I also went through the swop PSU, update BIOS etc.


what seems to have worked for me was to go inti the BIOS and change CPU idle currency to normal. 


Hope this help the guys that still have issues

So i think the problem's been fixed for me. Its been a week now and i haven't had a restart/error since then. I bought an aftermarket cooler so i just "rebuilt" my computer i removed the mobo and all the cables etc and put em back together. I don't know what was causing it but for now im good.

@comp4cty that's good to hear, leave it on idle a bit. I tested for a week no issues but it came back randomly months later, I wasn't really using it much in that period of time.

I was able to reproduce it a couple of times this week but since going to the latest AGESA beta BIOS it's been stable. However I've only been running it for about 48hrs so a bit early to tell if completely solved, but it has been getting more stable the last 3 BIOSes each time.


Had one today after 10 days without.

Tested with CPB enabled only (Precision Boost, not overdrive). It took long to crash but crashed anyway. First and last AMD build. Crap company.

WHEA With Only CPB.jpeg

@Electric_Squall Remember all computer parts have a 0.5 to 3 percent failure rate, Intel usually has a 1% failure rate. You could just be that 1 in a 100, it happens, return the CPU and get another before you make up your mind.

Granted it's more annoying to troubleshoot than a completely dead part. Also it could be a bigger issue we don't know about but I haven't been able to confirm that yet.


0.5~3% ? Clear not the case regarding to this PBO/WHEA issue.

Most of the threads opened in the Processors area after zen3 release are related to this problem. The same can be said about reddit threads complaining about the same behavior.

The PBO/WHEA issue in number of complains, is only behind the USB issue.

We can see by your feed, that this issue is affecting far more than 3% of zen3 owners.


Stop defending AMD, you get nothing for doing so. Don't pretend like we don't know what we're saying. This issue is EASILY reproduceable!

CPB/PB and PBO disabled, solve this problem, so, AMD in fact, released products with a defective feature.

@Electric_Squall I'm sorry you don't like facts being pointed out. I'm not defending anyone just pointing out facts.

You need a large sample size to take the figures from, individual reports don't tell you how big the problem is. If the problem is that large it will be in the news soon enough and I'd love to read that article.

It doesn't matter if this is Intel, AMD or Nvidia I'd treat it exactly the same. I'm actually an Intel fan BTW I just don't think their current products are competitive.

Random forum reports don't really give you valid data to make assumptions on.


Just an update.

Since I set my PSU to Typical Idle in the bios, I've only had one reboot. After that I did a DDU of my video drivers and updated them to the latest ones.

Since then, I've still had some stuttering in games (Doom:Eternal / Resident Evil and screen tearing on my desktop occasionally, but no flat out crashes/reboots. I was able to replicate one crash using the app 'Wallpaper Engine', every time It was running, within 20 minutes to an hour, it would reboot, without fail, so I simply stopped using it.


Something I did not even think of until a friend pointed it out to me today, was my refresh rate. I have two monitors, and they were both running at 120hz, I thought nothing of it, but then I thought I should do some testing.
I set them both back to 60hz, and ran Wallpaper Engine again, and also ran Doom Eternal and Resident Evil Village on ultra for 30+ minutes, actually playing and stressing my system, and now I have no lag, no stuttering at all, and I have been crash free for almost 9 hours, with all my desktop screen tearing also gone. (I am running both games in 144hz since my monitors support it)

If anything else comes up I'll post a reply, but if you don't hear from me, it should be smooth sailing. With any luck, it might help someone else here.

Thanks again for all the help from the people posting here, I hope whatever ails you can be fixed.

My System Specs:
AMD Ryzen 7 3800X with Wraith Prism
ASUS Prime X570-P CSM Motherboard
Gigabyte Radeon RX 5700 XT Gaming OC 8GB
G.Skill Ripjaws V 32GB (2x16GB) 3600MHz CL18 DDR4
Corsair RM750 Gold 750W Power Supply
Samsung 970 EVO Plus NVMe SSD 500GB
Seagate Barracuda 2TB ST2000DM008 3.5in Hard Drive


Hello everyone, I've been having this issue since 6 months ago when I got my 5800X. Last month I finally went through RMA process and got a new CPU. To give you an idea, the previous one would easily crash in certain games 100% of the time within 30 mins and others were a mix bag, sometimes they would hold for 2, sometimes 4, and sometimes not crash at all. Now with the new CPU i STILL get crashes, albeit WAY less frequent, now only the previous cases of 100% change of crashing actually do crash but it happens randomly, it can take 4 or even 8 hours when it does happen. Way better but not perfect. And this is regardless of what BIOS version I have.

I doubt this is a rare issue, in fact, when I first got it months ago and searched for help in some tech discord servers I wasn't the only one with the exact same issue within 10 mins of reporting the issue. If this was rare I wouldn't get the same issue twice in a row, and quick searches reveal some people actually going through RMA 2 or 3 times until they get something stable.

It doesn't seem to be any specific hardware combination either since everyone has different setups and still get the error anyway. AMD clearly made a mistake here, and I don't understand why people aren't holding AMD accountable for this. This was the first and the last time I buy and AMD CPU, I'd rather spend more money on a CPU with equivalent specs than dealing with this issue ever again. Specially considering than after so many months AMD still didn't managed to fix it.


@shockblade Google 'windows 10 dual monitor stutter' this might be your issue, sounds similar. I also have dual monitors at 144hz, I think I just did this Windows patch when I did the last BIOS update, wasn't paying close attention to the patch number. Anyway see

@kebrus I might feel similar to you if I got 2 CPU's both causing the same issue. How can you be so sure it's the CPU though? It could be anything.

If it was that big an issue there's no way it wouldn't be news. I am keeping an eye out for news though. There was a tweet from a PC builder reporting 6% failure rate which was quite high, but they deleted the tweet after AMD investigated, maybe they found the cause or it was too small a sample size, I wish I knew the conclusion.

It could even be a software issue like above. It's annoying being so intermittent otherwise I'd already of solved it. If I was sure it was the CPU I'd already of replaced it until it was solved or replaced the whole system. It's also annoying the issue is so generic, all sorts of issues have been causing these errors long before the 5800x was released. I'm pretty sure I did Windows updates and driver changes the day I built my 5800x system but it first occurred on that day. So for me it's one of those things I did on that day, but for someone else it might be a different issue.

It would be nice and easy if it was a known big issue like the MS patch and we were all affected by it, or a proccessor recall whatever, but I think it's probably lots of different annoying intermittent issues.


Where are you seeing "Typical Idle?" Closest thing I have on my Asus TUF X570-PRO  is under Advanced-->AMD CBS --> Global C State --> (changed from Auto to Disabled). 

Is that the same thing? Should I be looking for something else?


@liquidwater AMD CBS\CPU Common Options

the Power Supply Idle Control, set to Typical.

However since the latest BIOS Update I've left it back on auto, I think the issue just didn't re-occur for a week, may not of been fixed by Typical Current at all. However it probably helps make it more stable but you shouldn't need this unless you Power Supply can't handle extreme low power states.


Thanks! I may be looking in the wrong place, but I did not see this option at all. I'd like to try it out but not sure where to even find it in the BIOS. 

I wish there was just a simpler method of the event IDs actually telling us truly what the problem is. 

I don't know if I need to RMA my 3700x or not. Was really hoping it'd be a simple PSU issue on my end (I made a thread about Event ID 18, as well), but it doesn't look like that's the only issue.


@liquidwater event viewer is actually quite good at diagnosing problems however if you rip the power cord from the wall you can't really get much information on the cause of that. It's kinda the same with all sorts of hardware issues.

You have the Typical Current option in your BIOS somewhere, it might make it more stable but it doesn't solve it.

Are you on a BIOS with AGESA I've not been able to produce the issue since.

Also AGESA came out 2 days ago and improves stability, I'm gonna stick with first because it's working and I want to be sure it's stable before changing anything, but if doesn't work try


Good question about the AGESA version. I installed the beta version of the driver ( and it says that the version is AMD AM4 AGESA V2 PI Considering that this bios itself is in beta since April, I doubt that I'd be able to get my hands on the version since I am quite dissatisfied with and the prior version. And to answer your question, did make the restarts less frequent, but it is still happening.  

Perhaps my PSU wasn't at fault and I had it RMA'd for no reason (essentially swapping a brand new unit with one that was recertified by EVGA)!

Is it even worth resetting Windows? Or should I just wait for the new BIOS version? 

This is my thread here:


That's how it works a few days ago was in beta and now is in beta for an ASUS tuf b550m, I'm sure the rest will getting it soon. However that may not fix your issue, it's hard to know what the cause is.

If you haven't done so yet you can run memtest86+ to verify your ram, best to run overnight, although I doubt it's your ram you often get BSODs but not always I guess.


I bought the pro version of memtest86 and used it when I bought the ram (with no failures) a couple years ago but I can definitely let it run again tonight. Hopefully, it's not the RAM (or actually, if it is the RAM, then perhaps it's an easy RMA and fix). Looking forward to that new BIOS. Not sure how quick the x570 will get it, but hopefully soon. 

Well I'm still crashing on AGESA, no issues for 6 days left PC on the entire time then about 10 crashes in an hour. Very strange issue.

I had to remove network cable to stop it from crashing, very strange, but doesn't crash now it's back in.


Issue is 100% solver for me, was all about the RAM frequency after all. Down to 3200 and no reboots in nearlyh 2 weeks now

I've also done the same (3600 to 3200), but still getting crashing. I've also RMA'd the PSU, but while the frequency has dropped tremendously, it's still mystery rebooting. This is unfortunate because if I was trying to download a game or do a scan, it might restart any time in the middle and then I'd have to manually start whatever it was that I was doing. 

Guys, unless you fail memtest, the chance to be a memory issue is very, VERY low. If you disable CPB/PBO your system will stop "Wheaing" so, no memory related.

On my side, I've used a DOCP profile of 3200 and also stock frequencies (2666) and no deal.

To confirm, it was just your ethernet cable?? What did you do exactly? Just remove it for a little bit and then put it back in? Any other steps? 


My memory is running DOCP 3600Mhz and it could be the cause but I've lowered it and still gotten the issue. My memory is a QVL Module, I'd expect it to work or something will be returned until it does, I expect to get what I pay for. It would be different if it wasn't QVL or I wasn't running something stock.

I suspect the instability odds are increased in combo with theninfinity fabric, gen4 nvme, and high speed ram. The more you put in the more likely to have problems, but if this is the case then that's not really acceptable. I haven't narrowed down the cause though.

@liquidwater It was constantly failing about 10 times in an hour, anywhere between between a few seconds to a few mins, until I removed the network cable and tried to boot. After it was stable I plugged the network cable back in, it was still stable so I rebooted it, no crashes for several hours.

Removing the network cable maybe had nothing to do with it, maybe a coincendence, but I do wonder if it Windows update related. I always seem to have an update or several when it occurs, it's also synching the time. Without further testing I can't confirm anything at this point.

P.S. It's dead again this morning, whatever it is, is occuring more frequently at the moment, if I can reproduce it more reliably then I can narrow it down.