Showing results for 
Search instead for 
Did you mean: 


Adept I

Whea 19 events with 3700X


I've been receiving WHEA-19 warnings (Unknown Error Source and Corrected Machine Check, with type of No Error from Processor Core) for my machine the last couple of months (since last year november maybe). It started with a BIOS update: BIOS 1403 (ASUS PRIME X570-PRO) fixed a WHEA-17 warning spam which was related to PCI Express Advanced Error Reporting (once caused BSOD for my nVidia Video Card also). This issue has been fixed now, but instead I'm receiving WHEA-19 warnings but only on startup and only sporadically. System is completely stable, there is no overclock except for the DOCP profile which is enabled (see specs below) everything is left on stock. There are only 5 warnings because the recent update to Windows cleared the previous ones. 

I managed to determine what process causes it: it is the Windows Diagnostic Policy (DPS) service which triggers these kind of warnings. I cannot reproduce the issue however because restarting the process has no effect and only happens every ~3 days.

CPU: Ryzen 7 3700X

Motherboard: ASUS Prime X570-PRO (BIOS: 2407)

Memory: G.Skill Trident Z RGB 3200MHz @ 1.35V 16-18-18-38, Hynix AFR (G Skill TridentZ RGB F4-3200C16-16GTZRX x2)

Video Card: ASUS ROG STRIX RTX 2070 Super Advanced Gaming

Storage: Samsung NVME 970 EVO Plus 1TB, WD Blue 1TB SSD and a couple of hard drives (2 WD Green hard drives, SATA)

PSU: Chieftec ECO 700W

Windows 10 update 2004

Every driver, chipset driver and BIOS is the most recent.

The latest BIOS from ASUS' website claims this AGESA version is - Update AM4 combo V2 PI"

I have fast boot enabled. Disabling fast boot from BIOS has no effect so I left it on.

See my reddit comments also: 

Another user seems to have a similar problem (TUF gaming shares the same or similar bios): 

Can anyone help me decode the corrected machine checks? What seems to be the problem? Let me know if you need any kind of data, I gladly provide anything you need.

Thank You and Best Regards,


1 Solution
Adept I

Just to let anyone know: I managed to find a workaround by disabling Fast Startup in Windows. So by disabling Fast Startup, the issue is no longer present.

View solution in original post

6 Replies
Adept I

Just to let anyone know: I managed to find a workaround by disabling Fast Startup in Windows. So by disabling Fast Startup, the issue is no longer present.

Journeyman III

I wish I could say your fix helped my issue, but I'm still getting a lot of WHEA 19 warnings.


What is your configuration? Have you tried updating the BIOS to the latest? Can you post some of the messages?


CPU: Ryzen 7 3700X

MB: Asus Crosshair VI Hero w/wi-fi

RAM: Corsair Vengeance LPX 32 GB (2 16GB)

Graphics: MSI Radeon RX 5700 XT

Drives: Sabrent Rocket Q 1TB NVMe PCIe M.2 2280

   Crucial MX500 500GB

   Seagate Barracuda 2TB HDD

PSU: EVGA SuperNOVA 1000 G5, 80 Plus Gold 1000W

OS: Windows 10 update 2004

I just found out that there is a new BIOS update for my MB, so I'll try applying that to see if it helps.


Details of selected warning:


ErrorSource 1
ApicId 3
MCABank 0
MciStat 0xd020000000100011
MciAddr 0x0
MciMisc 0x0
ErrorType 8
TransactionType 0
Participation 256
RequestType 256
MemorIO 256
MemHierarchyLvl 1
Timeout 256
OperationType 256
Channel 256
Length 936
RawData 435045521002FFFFFFFF03000200000002000000A803000014121300140A14140000000000000000000000000000000000000000000000000000000000000000BDC407CF89B7184EB3C41F732CB57131B18BCE2DD7BD0E45B9AD9CF4EBD4F890FEFAEC0144A3D60100000000000000000000000000000000000000000000000058010000C00000000003000001000000ADCC7698B447DB4BB65E16F193C4F3DB0000000000000000000000000000000002000000000000000000000000000000000000000000000018020000800000000003000000000000B0A03EDC44A19747B95B53FA242B6E1D0000000000000000000000000000000002000000000000000000000000000000000000000000000098020000100100000003000000000000011D1E8AF94257459C33565E5CC3F7E80000000000000000000000000000000002000000000000000000000000000000000000000000000077010000000000000002020000010000100F87000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000300000000000000000000000000000000000000000000000000000000000000000000000000000007000000000000000300000000000000100F8700000810030B32D87EFFFB8B17000000000000000000000000000000000000000000000000000000000000000035B506FC1F5E62459F250A3B9ADB63C301000000000000009D004020000000000000000000000000000000000000000000000000000000000000000000000000020000000200000057F1C4C515A7D60103000000000000000000000000000000000000000000000011001000000020D000000000000000000000000000000000000000000300000000000000B00000000A36033A000000007D000000070000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000001B00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000


No luck after updating the BIOS, I still get a lot of Event ID 19 warnings in Event Viewer. Now the source is different from the one in my screenshot, it now says Error Source: Unknown Error Source.


I had thousands of those.. I found this by google so I am sure you solved it yourself by now but to help anyone else looking, if you have your RAM overclocked try raising the VDDG CCD / VDDG IOD and the VDDP voltage in the bios settings. I raised all 3 by 0.05 volts and all the WHEA errors went away.