Showing results for 
Search instead for 
Did you mean: 



What is the current best bios version for AMD Ryzen Threadripper 1950x (Auros x399 Gaming 7)

Looking for the most stable, and most current bios revision for this specific setup.

It was shipped with F2g -> X399 AORUS Gaming 7 (rev. 1.0) | Motherboard - GIGABYTE Global 
Currently running F10, as F11e had insane heat problems and was just a disaster.
V. F10 however, is using the new Agesa SummitPI (SP3r2- and I wonder if that is leading to my current problems being unable to enter X.M.P without all of my cores being locked at 532mhz. 

To put icing on the cake, since upgrading from the BIOS it shipped with, I have not been able to enter XMP functions at all. I have tried resetting all settings in bios, re-installing windows, Pressing the butting for CMOS-reset on the board.

I'm at a loss. Does anyone have any idea? I can't be the only one to have this setup

9 Replies

My mistake, it was shipped with F3g **


choppstikk, please post a screenshot of Ryzen Master (RM).  As randa71, you definitely want to be on the latest AGESA.  My MSI  MEG X399 Creation has been on for some time.  I encourage you to try it but mainly I encourage you to raise a royal stink with Gigabyte Support!

randa71, please post a screenshot of RM also.

Both, please make sure you have the latest chip set drivers from the AMD Driver Download Site - very important!  Also both, post your specifications.  Be sure you are following the manual's instructions and do a Clear CMOS.  Simply pushing the button is not enough!

Here's my specifications:

MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, Aquantia 10 GbpS Ethernet NIC, UEFI E7B92AMS.120, AGESA SummitPI-SP3r2-

Thanks and enjoy, John.


See, but my problem is I am using the Threadripper 1950x not the 2900' series. Yes I have the latest chipset drivers from AMD. Yes I know how to manually CLR CMOS on my motherboard. I need information regarding the 1950x series.

I will comment with some screenshots of my current setup.

Adept III


I have the same configuration and i have this problem: Threadripper 1950X first and last core are always stuck at 3.7 ghz or more with bios F10 or F11e...for this reason i have written to Gigabyte support and the send me a new bios (F12d with agesa to see if this problem was resolved. I've installed yesterday and unfortunately the problem remains. So i've replayed sending screenshots were first and last cpu core are always stuck at 3.7 ghz or more with Windows power plan set to energy saving. I'm waiting for their response. The only bios were there isn't this problem is F3j. 


Motherboard ->

   Model - Gigabyte x399 AORUS Gaming 7

   Socket - SP3r2 (4094)

   North Bridge - AMD Ryzen SOC rev 00

   South Bridge - Amd x399 rev 51

   Bios - American Megatrends Inc. F3g (10/03/2017)

   AMD AGESA - ThreadripperPI-SP3r2-

Processor (CPU) ->

   Name - AMD Ryzen Threadripper 1950X 16-Core Processor

Memory is Gskill Trident Z RGB - F4-3000C16-8GTZR x4 total 32GB

SPD Ext. is 2.0 ready. ( Current clock is 2133 standard default)









choppstikk, I also have a 1950X with these specifications:

ASRock Fatal1ty X399 Pro Gaming, Threadripper 1950X, 2xSamsung SSD 960 EVO RAID0, 4xSSD
960 EVO on ASRock Ultra Quad, 1TB & 500 GB WD Black, G.SKILL [Flare X (for AMD)] F4-
3200C14Q-32GFX, Windows 10 x64 Pro, Enermx Platimax 850, Enermx Liqtech TR4 CPU Cooler,
Radeon RX580, BIOS 3.30, AGESA ThreadRipperPI-SP3r2-

I really want to see the screenshot of Ryzen Master (RM).  Here is mine:


And 1950X specifications:


What is the Wattage of your power supply, OS and CPU cooler?  I hope you have contacted Gigabyte.  Is your memory really a quad as mine or 4 individual sticks (not good)?  I suggest you do a Clear CMOS, update the BIOS to the latest, do a Clear CMOS, start Windows and post a screenshot of RM.  Thanks and enjoy, John.


 Fan : Asetek 570LC 120mm (Fatboy) Liquid CPU Cooling System w/ Copper Cold Plate (Single Standard 120MM Fan)
512GB WD Black Series PCIe NVMe M.2 SSD
256GB WD Black Series PCIe NVMe M.2 SSD
5TB (5TBx1) SATA-III 6.0Gb/s 64MB Cache 7200RPM HDD (Single Drive)
32GB (8GBx4) RGB Lightning DDR4/3000MHz Memory Module (GSKILL Trident Z RGB) (F4-3000C16S-8GTZR)?
( I did some research and I think I was sold 4 x single channel 8gb for wtf ever reason?)
MOTHERBOARD: GIGABYTE AORUS X399 Gaming 7 ATX w/ RGB, Digital LED Support, 802.11ac, USB 3.1, 5 PCIe x16, 8 SATA3, 3 M.2 SATA/PCIe
POWERSUPPLY: 1,000 Watts - Standard 80 Plus Gold Power Supply
VIDEO: GeForce® GTX 1080 Ti 11GB GDDR5X (Pascal)[VR Ready] (Single Card)


Sorry for the late reply. 

AMD ryzen breaks my pc causing tons of issues. Not going to reinstall it just to clear my cmos 5 more times

Journeyman III

Hello Guys,

I also have and 1950x with the Aorus Gaming 7.

I'm still on the F3g bios as all other bios updates give me problems.

Up to bios version 11 the clock speeds do not drop when idle ;(

And with the new 12 bios version I get a post error A5 and i can not apply any XMP.

After applying the XMP the PC restart 3 times when booting directly after.

My Gskil Ripjaws 3200 run perfectly on the F3g bios but will not get past 2166Mhz in bios 12.

I tried changing the DDR voltages etc, no luck.

So it seems I'm stuck on the F3g.

That's a shame for a motherboard for almost 500 Euros ;(

I probably go for another brand next generation as I lost my faith in Gigabyte.