Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Virtualization BSOD


I bought in June 2018, an AMD 2700x processor. When I turn on virtualization, and start a virtualization software such as: VMWARE, VirtualBox. Or android emulator: Nox and Bluestack. I have BSOD.

I made memtest86 +, I have no RAM error.

The bios is in the latest version..

Has someone already had this problem ? And how to fix it?

Configuration :

Motherboard: MSI X470 Gaming Pro

RAM : DDR4 HyperX Fury 2x8Go, 2133 MHz, CAS 14

Processor : AMD Ryzen 2700x

Graphicss : GTX 1060 6GB

13 Replies

pikouik, need to know more.  Please compress your minidump folder and upload it where we can DL it.  More specifications: power supply, OS exact version and patch level, UEFI version, other HW such as drives.  Enjoy, John.


Thank you for your answer.

I have the latest version of bios (version : 7B79v14), and all my drivers are up to date.

I tried to create a minidump but the folder or it must be create remains empty.

Configuration :

OS : windows 10 1709

UEFI : legacy

Motherboard: MSI X470 Gaming Pro

RAM : DDR4 HyperX Fury 2x8Go, 2133 MHz, CAS 14

Processor : AMD Ryzen 2700x

Graphicss : MSI Geforce GTX 1060 go

Power : Be quiet ! Pure Power L8 CF, 500W

Hard disk 1 (c:) : Samsung SSD 840 EVO 250Gb

Hard disk 2 (data) : Seagate Barracuda 1 To

Hard disk (data game) : Seagate Desktop SSHD 1 To


pikouik, your problem is most likely that your power supply is too weak!  I would use a 750 Watt supply but you may get along with less.  Newegg has a good power supply calculator and I suggest you try it.  I usually take its recommendation and add some to it.  I would also recommend you upgrade to W10 1809 but not until you deal with BSOD problem.  Please do post the Stop code.  If you do not remember, them look in the Computer Management-Windows Logs-System.  Enjoy, John.


Thank you for your reply.

When I wrote my answer, I had the same feeling for power. I will buy a new power and I will try.

Journeyman III

I have a somewhat similar system build and almost the same problem - however I get no BSOD and instead a full system halt. Nothing shows up in event logs.

OS: Windows 10 1804 Enterprise

UEFI : legacy

Motherboard: MSI X470 Gaming M7 AC (latest Bios - 7B77v15)

RAM : G.SKILL TridentZ RGB Series 32GB (2 x 16GB) DDR4 3200 CAS14

Processor : AMD Ryzen 2700x

Graphicss : Radeon VEGA FE

Power : EVGA SuperNOVA 1000 G1+, 80 Plus Gold 1000W

Hard disk 1 (c:) : Samsung M.2 960 500GB

- other hard disks.. 2tb Micron SSD, 2x 3TB 7200k rpm

So far, I have perfect system stability as long as I am not running any Hyper-V virtual machines. I can run games, have multiple programs open. I can run Prime95 torture test for hours.

If I launch a Windows 7 32bit virtual machine, my system hard locks (mouse freezes, no response to pings) once it starts to log in. I've tried uninstalling/reinstalling Hyper-V. This has happened with all recent versions of Windows 10. This happens using the RemoteFX 3d video card or when I remove the card.

I contacted AMD tech support and they advised me to use DDU Utility to remove all AMD drivers in safe mode and then reinstall the latest (which I will try tonight). However, I am thinking there are still Ryzen virtualization stability issues since there are so many people reporting them - even with the latest Ryzen processors.

Is this a known issue? If so, I cannot find anywhere to read about it.

Journeyman III

I have done the DDU utility and reinstalled the AMD graphics drivers. The issue with Hyper-V is still there. If I don't launch any Hyper-V virtual machines, my system is perfectly stable. If I launch a Windows 7 32bit VM, it halts when Windows is logging in.

I would like to know if more people are still having this issue or if this issue was already mitigated and I am missing a hotfix or something.


brx, I run a VM (W10 x64) often and it works fine.  I have never had any problems, but always run a 64 bit W10 VM.  What is this, never heard of it?:  brx wrote: "OS: Windows 10 1804 Enterprise".  Do you mean 1809?  Where did you get it, 64 bit or 32 bit?  Where did you get your AMD chip set drivers?  You should only get them from the AMD Driver Download site.  Are you OCing at all?  Enjoy, John.


According to Microsoft Forum you can run Virtual Windows 7 x32 on a Windows 10 Pro x64 computer.

It gives several links on how to set up so you computer will run VM with Hyper-V and BIOS: Can I run a 32bit virtual machine on a 64bit windows 10 system? - Microsoft Community 

From above link:

Andre Da Costa

You will need to be running Windows 10 Pro.

You can also use CPU ID to determine if your processor supports virtualization:

CPU-Z | Softwares | CPUID

Also, you can review how to setup Hyper-V

How to setup a virtual machine using Hyper-V

If your computer doesn't support Hyper-V, you can use the free Oracle Virtualbox as an alternative:

How to: install the latest Windows 10 Build in Oracle VirtualBox

Windows Insider MVP
MVP-Windows and Devices for IT
EDIT: What is the exact BSOD error you are getting or any other errors?
A useful tool is running DXDIAG and looking at the text file. Towards the last category in the file, it provides data on any files or programs including Windows files or services that are having problems.
Adept I

Please Help!

I have a AMD Ryzen 2600X and have been trying to install VMs on Virtual Box for my Windows Server Course, I have installed Windows Server 2016 Datacentre Desktop Experience Evaluation onto Virtual Box I have also been receiving multiple BSOD's I have tried a number of different Configurations, I also ran the Hyper V Compatibility tool to check I had all the correct BIOS Settings and it came up all OK.

I tried disabling SMT, AMD's hyperthreading both on and off no difference, However I did notice it did seem to perform better( Still crashed eventually though) on One CPU with 4GB of ram selected I got more BSOD's when I had 2 or 4 CPUS set.

When I had both a Domain Controller and my SQL Server on separate VM's running it would take maybe 1 min and atleast one of the VM's would Crash, and before anyone asks is it because I had too many system resources assigned I didn't, I have 16GB of RAM, and was careful not to over assign ram or CPU my exact specs are

2600X Ryzen CPU Gigabyte X470 Ultra Motherboard, Trident Z 3200 mhz CL14 RAM, Vega 64 Graphics card SSD and HDD, I am running the latest windows build I think its 1809, maybe I should see if 1903 is available? Actually it might actually be 1903 if it is out, I know I have the latest I am pretty sure I had to download from Microsofts website. (I will check tonight)

I also have the latest Virtual Box installed latest Graphics drivers, and my BIOS Revision is F3 from memory. When I get back home I can check these details. I had all the default settings selected so had all the performance settings AMD vt etc all turned on.

Who can help me with this problem I really need to run a Virtual Machine for my class I need to run 3 actually in total on the one machine and its no where near stable enough. Should I try Hyper V or VMWare instead of Virtual Box?

Also I am seriously considering selling my Ryzen for a Intel based system as I need this for my class. I thought the 6cores and Ryzen would be good enough but it clearly is not well optimised at all, at the very least on Virtual Box I never had this trouble on my i5

Please someone help!?




Since this concerns a Server Environment even though it is a class, Try posting at AMD Server Gurus . The AMD Forum concerns Servers software and hardware. I imagine someone there can instruct you or at least direct you on how to create a VM in a Server using Ryzen. 

I directed you that particular AMD Forum since you are using a Server Windows software.


Dunx,  I am willing to try to help you, but need a lot more information.  Please do a winver in a Run dialog or a Command prompt on host and post the results.  Please start by opening your own thread with an appropriate tittle. Is the BSOD occurring in the host or the VM?  I am really curious why you are not running Hyper-V.  I have never installed a server Windows but have used Hyper-V extensively and it works great.  No need to do anything really except to enable SVM (Secure Virtual Machine) in the BIOS.  Hyper-V needs enabling in Control Panel.  Don't need to mess with all that other stuff.  Looking forward to seeing your thread here.  Thanks and enjoy, John.


This VMWare website concerning the Server software you are using may be of benefit in correctly setting up VM on your Server computer: Install Desktop Experience on Windows Server 2012, 2012 R2, or 2016.

In the above link it linked to this page on setting up various VM: Creating a Virtual Machine for Cloning and Creating and Preparing a Virtual Machine for Cloning  

Adept I

In some antivirus softwares, there is virtualisation fonctionnality. disable it and it should work. I searched for hours searching to fix it, I had SYSTEM_SERVICE_EXCEPTION and KMODE_EXCEPTION_NOT_HANDLED bsod, checked everything in bios, did a lot of tricks. I uninstalled Avast and it worked, but you can also disable virtualisation in avast. Also disable completely HYPER-V fonctionnality by going to Add Remove Programs the Add Remove Windows Functionnalities.