Showing results for 
Search instead for 
Did you mean: 


Journeyman III
Journeyman III

Using Ryzen 2700 and EVGA GTX 950 won't POST, in 2 different b350 MBs


Previous MB: ASRock Fatal1ty AB350 Gaming-ITX/ac with P4.50, or P4.51D bios

Current MB, exhibits exact same issue: Gigabyte GA-AB350N-Gaming WIFI with F22, or F23D bios

CPU: AMD Ryzen 2700


Ram: Patriot 16GB Kit (2 X 8GB) 3400 MHz (PC4-27200) Viper 4 Series DDR4 Ram

PSU: Cooler Master 750w Bronze

Alternate PSU: 1kw PSU of unknown brand (both PSU's verified working in other builds)

With any of the above hardware combinations, I cannot get to POST.  I have tried many different bios setting combinations, and cleared CMOS many many times.

In every case, I cannot even get a beep code, but the CPU and GPU fans spin.  USB devices like thumb drives do not light up.  It's as if the bios doesn't even start to initialize.

However, if I swap the Ryzen 2700 out with a AMD A8-9600 APU, and force it to use the GTX 950 rather than the IGP, everything works without any hassles.  I can easily boot into linux and play games.
I can also use the Ryzen 2700, but swap out the gtx 950 with a EVGA 560 TI, and everything works, with no changes to bios.  Again, boots up no problem.

This happens on both the ASRock I previously had (RMAed yesterday), and the Gigabyte I just received today.

I have posted about this problem elsewhere, but no resolution yet:

EVGA Nvidia GTX 950 won't POST, EVGA 560 TI works - Motherboards

AB350 ITX/ac with P4.50 bios and GTX 950 - ASRock Forums

So in summary, all hardware is known to work separately in different combinations, but when the R7 2700 is used with the EVGA GTX 950, nothing works that I have tried.

I know it sounds like I've just managed to hook something up wrong consistently, and I wouldn't believe this story either if someone told it to me, but I assure you I've worked very hard to resolve this issue.

I've been very thorough, and have tried stable and beta bios's for both motherboards.  They both behave the same with the GTX 950, so I feel it has to be AMD's issue now, somehow.
Can anyone help me with this issue?

0 Kudos
1 Reply
Journeyman III
Journeyman III

Re: Using Ryzen 2700 and EVGA GTX 950 won't POST, in 2 different b350 MBs



0 Kudos