Showing results for 
Search instead for 
Did you mean: 


Adept I

USB issues on B550

Hi, i own a Ryzen 3500X with a B550 DS3H , with its latest BIOS F13.

I have a RTX 2060, so no pciE 4.0 here...

But i have all sorts of USB issues, every keyboard has chattering (some usb ports more than others), every usb wifi adapter or bluetooth will randomly disconnect (in particular during heavy cpu loads or heavy storage loads).

I am at a loss here, i don't do any overclocks , everything here is at stocks speeds and features.. (Issues are appearant on Linux aswell).

At this point the CPU or Motherboard are faulty i guess , is there any upcoming AGESA update that is going to fix this pherhaps?

12 Replies

Have you tried turning off 'usb selective suspend'.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

This an option on Windows 10 power options?


Do you have the latest BIOS and Chipset drivers?


Yes, latest bios and also latest chipset

Journeyman III

I'm experiencing the very same problem on an Aorus B550i with a 5900x, also bios version F13; it is practically impossible to use the mouse while there is more than one peripheral connected to another usb port. I've tried all solutions present in other discussions with 0 results. This problem is present both in windows and linux (ubuntu 21.04). At the moment I've "solved" connecting the mouse to the usb typeC with a usb C docking station. Of course this is not a solution at all since I should be able to use the mouse attached to every usb port regardless the other usb are connected or not.


I am also having this issue. Brand new PC - B550 AORUS PRO AC, AMD Ryzen 7 3700X.  Under heavy load (Especially when I'm gaming, most prevalent when online.) All of my USBs disconnect and I'm often forced to power cycle my PC to get things working again. I've updated drivers, Windows, and my BIOS to the most recent and nothing has helped. This is my first AMD PC and it's looking like it may also be my last. A brand new computer shouldn't have to have work-arounds to work. Any help would be appreciated!

Journeyman III

Same problem here. I have a Ryzen 5 3600 with a Gigabyte B550m Aorus Elite. The BIOS is version 14e with AGESA Combo V2 version A. I formatted the PC yesterday (I put windows 11), reinstalled all drivers with the latest available from AMD. As I write this message, I had to remove and replace the USB mouse 3 times. It's impossible to go on like this... It's been for months and it's only getting worse.


From your post and all the other posts from Users in this thread having a  similar issue with USB it sounds like BIOS issue since all the Users have B550/M motherboards.

Plus Gigabyte did have a BIOS update to fix  the USB issue earlier.  So possibly it has come back again. I would suggest everyone open a Gigabyte Support ticket if the latest BIOS version didn't fix the USB issue.

For the OP's Motherboard the latest BIOS version is now F14e.


That's interesting, I remember there were a lot of complaints about USB connectivity issues back about a year ago with X570, but after AMD addressed it with an Agesa update they pretty much died down.

And everyone posting on this thread so far has a Gigabyte mobo.....hmmmm.  My Asus Strix B550-F mobo has no issues with USB, and it's also on Agesa   Edit:

So maybe try a different BIOS version to start with.



Not restricted to Gigabyte, I have an ASUS Prime B550M with the same issue

AMD Ryzan 5 3600, Asus GeForce GTX 1650 Graphics (522.30), Asus Prime B550M-A LGA 1200 mATX Motherboard, (BIOS 2003) Cooler Master MWE White 230v 550W 80+ V2 Power,500GB SSD, 16GB DDR4 Ram, 2TB HDD, 32inch Phillips 1920 x 1080 Monitor, Samsung 28 inch 3840x2160 UHD 4K LED Monitor. Win 10 21Hl, Build 19043.11466

Are there any entries in the System Event viewer when the USB disconnects happen?

I'd disable USB Selective Suspend in Windows Power plan settings, I'd also go into Device Manager, right click Properties on all USB hubs and under Power Management uncheck 'Allow the computer to turn off this device to save power'

If disconnects are happening under heavy load, it could be a SoC voltage issue - might be dropping a bit too much.  HWinfo is useful for monitoring, pay attention to the Min values.  I'd try bumping up SoC voltage in small increments to see if it helps.



Maybe it will help you to not think about wrong causes.

I'm using B550 motherboard with undervolted soc (1V) for year with load line calibration level 4. I need it run with low power to release some power for CPU cores within default limits for PPT.




I changed CPU to 5600x at 23.04.21 and it just works like that, before it was zen 2 CPU.

No issue with USB devices even with OCCT load simultaneously on CPU and GPU.

My current AGESA Combo V2 PI Patch C.