Showing results for 
Search instead for 
Did you mean: 


Adept I

Upgraded to a new Ryzen 7 5800X CPU today...then possibly ran into a casualty

Hi all.  Long time forum member across the Internet, first time poster to this forum.  So just today in my current system my friend and I upgraded my CPU from an AMD Ryzen 7 3700X CPU to an AMD Ryzen 7 5800X CPU.  We did have a little bit of a bump in the road (my friend dropped the 5800X CPU into the case unprotected and it did collide with a couple of things and bent some pins [which he reset with a sewing needle]) but other than that the install was smooth...until we turned the PC on.

The machine now will not boot with memory in dual channel.  At all.  On my ASUS ROG Crosshair VIII Hero mobo, it gives a 0d Q-Code message and the memory problem light comes on.  After some troubleshooting (which included clearing the CMOS) I did get the system booted again...with one stick.  I can get the machine to boot to Windows with 1 stick (either memory stick) in DIMM slot 2A.  Cannot get it to boot with any stick in slot 2B on the motherboard or in dual channel.  I'm thinking I have a damaged CPU or a bad motherboard DIMM slot which would be odd as the latter wasn't touched at all during the upgrade process.  What do you all think though?  Thanks in advance for your answers and advice on this one and until next time I am out!

1 Solution
Community Manager

Definitely sounds like a bad CPU pin or perhaps a faulty board. Based on your post, it seems more likely the CPU would be at fault.

View solution in original post

9 Replies
Community Manager

Definitely sounds like a bad CPU pin or perhaps a faulty board. Based on your post, it seems more likely the CPU would be at fault.

likely the ram need add more volt or change other ram just troubleshoot it

Can you put the old cpu in and start the system?

Hi all.  Thanks for all the answers so far.  As a matter of fact hrpuffnstuff I do indeed have the old CPU still.  Part of my troubleshooting later today was to change out the CPU for the old one to see if the issue persists on the old CPU.  Latest troubleshooting I did today is to flash the BIOS of my motherboard to the most current non-BETA version and then I tried running both sticks again.  Issue persisted.  One other thing on my mind: On X570 motherboards when it comes to CPU power there's an 8-pin and 4-pin power connector for the CPU.  At the moment I only have the 8-pin plugged in and not the 4-pin.  For the Ryzen 5000 series CPU's is it mandatory to have both the 8-pin and 4-pin power connectors plugged in for the CPU to completely work?  Thanks for the answers and further advice and until next time I am out! 

Journeyman III

So sad! I hope you get your 5800x working! :'(


Edit: I have added noob in my profile somewhere, so it says noob everytime i write something lol! 

Sorry its not you!

Edit2: fixed it you properly didnt even see it


5800x is powerful cpu with more ram power... likely it really choose the ram

tried slot 1 & 2 and not 1 & 3 for not using dual ddr test......

Hi all.  So it is confirmed.  My friend and I finished our troubleshooting.  The Ryzen 7 5800X would only boot with 1 stick of memory period.  Anymore than that and my ASUS ROG Crosshair VIII Hero motherboard would flash the 0d Q-Code and wouldn't boot further.  When we installed the old Ryzen 7 3700X CPU all memory worked again.  So I have a CPU that needs a replacement.  Time to get an Warranty replacement call going with AMD.  Thank you everyone for your help and until next time I am out! 

just to confirm .. do you test other brand memory?

Journeyman III

May be CPU is faulty, try some old CPU and then try the system might run.