cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

liav24
Journeyman III
Journeyman III

Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

 
 

Hi

I updated my Bios to the latest Beta version (2021-02-04) 7B79vAK2(Beta version), and i can't see anything on the screen after replacing to the new 3600X.

The computer turns on, CPU fan is working and so as the RGB and everything else - but I get DRAM lights on. Ram sticks installed are Geil Super Luce 3000mhz and works fine with the 2600X CPU

The screen won't turn on like there is no GPU connected.

I replaced again to the 2600X and now it works fine.

What do I do?

0 Kudos
5 Replies
kchan
Journeyman III
Journeyman III

Re: Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

Do you see anything at all on boot? Which video output are you using? 

0 Kudos
liav24
Journeyman III
Journeyman III

Re: Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

 
 
 
 

Hi

I got nothing on the screen, it wont turn at all when i press the ON button.

Im using the regular HDMI output from the GPU (not the MB).

 

0 Kudos
kchan
Journeyman III
Journeyman III

Re: Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

Can you check and see if secure boot is enabled? 

0 Kudos
elstaci
Esteemed Contributor III

Re: Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

Remove all of your RAM sticks EXCEPT one and see if you get video.

Also do a CMOS CLEAR to reset the BIOS back to factory default.

I had a similar issue when I upgraded to a Ryzen 7 3700X. I had no video at all. I reset my monitor's settings to default and that work once but once I rebooted I lost video again.

But in my case I had the GPU & BOOT LED trouble LEDs lit on my Asus motherboard.

Found out I needed to put BIOS in CSM Mode (Legacy) for my monitor besides resetting my Monitor's Settings to default to get video on it.

But I also had my HD Smart TV connected to my GPU card via HDMI cable while my Monitor was connected via DP cable. For some reason I had video output on my 2k HD Smart TV and not on my 4k Monitor (using both DP and HDMI cables).

I was then able to enter BIOS and set it to CSM Mode. When I installed the BIOS it automatically set BIOS in UEFI Mode. Thus I had no video when booting up. BUT I had video as soon as Windows started. 

But since your Motherboard is showing RAM Trouble LED as being lit that indicates that your RAM may not be 100% compatible with the Ryzen Matisse processor. Thus using one RAM stick might work and you might be able to boot up and get video.

0 Kudos
liav24
Journeyman III
Journeyman III

Re: Upgraded my 2600X to 3600X on X470 gaming plus - screen won't turn on

I did it all , same thing \=

Cleared CMOS before CPU installation, changed the BIOS to another, the Dram light was still on.

I replaced again the 2600X and viola the lights starts but goes fast between the DRAM / VGA / CPU and the PC runs fine.

I don't know maybe the 3600X on this MSI X470 with the Geil SuperLuce RAM does the problems (but works flawlessly with the 2600X).

I took the RAM out completely still DRAM light was on

I used 1 stick in every socket (both of them apart).

I even tried this weird method of taking the RESET SW jumper and nothing.

The BIOS was set on LEGACY+UEFI (there was also only UEFI I could only choose one of these two).

I really appreciate the help

0 Kudos