Showing results for 
Search instead for 
Did you mean: 


Adept I

Troubleshooting: clock_watchdog_timeout error


I am having issues with two AMD system fresh builds, bot are receiving BSOD error "clock_watchdog_timeout error"

System 01:

Motherboard: Asus PRIME B450M-A

BIOS: 2.17.1246

Processor: AMD Ryzen 5 3600X 6-Core

Memory: Corsair Vengeance LPX 32GB (2x16GB) - CMK32GX4M2B3200C16

Video Card: EVGA GeForce GTX 1050 Ti GAMING, 4GB GDDR5, DX12 OSD Support (PXOC) (04G-P4-6251-KR)

Hard Drive: ADATA XPG SX6000 Lite 512GB M.2 2280 PCIe Gen3x4 NVMe Read

CPU Cooling: AMD CPU stock fan

OS: Windows 10 Pro 64-Bit (10.0, Build 10240) I have also used newer builds but received the same errors

System 02:

Motherboard: ROG STRIX B550-F GAMING (WI-FI)

BIOS: Version 1004

Processor: AMD Ryzen 9 3900X

Memory: G.SKILL F4-3200C16Q-32GTZR Trident Z RGB Series 32GB, 288-Pin SDRAM DDR4-3200MHz (PC4 25600)

Video Card: ASUS GeForce RTX 2080 O8G Dual-fan OC Edition GDDR6 | 1830 MHz Boost, 14000 MHz Memory | PCIe3.0, 1xHDMI 2.0, 3x DP, 1x USB Type-C | DUAL-RTX2080-O8G

Hard Drive: WD Black SN750 500GB PCIe Gen3 x4 NVMe M.2 2280

OS: Windows 10 Pro 64-Bit (10.0, Build 10240) I have also used newer builds but received the same errors

CPU Cooling: NZXT X63

Power Supply: Corsair HX750 80Plus Platinum

Both systems experience the same issue.

System 02:

  • I tested with two different processors (System 01 and 02 processors),
  • Two different motherboards (exchanged the original),
  • Three different graphics cards (Both NVIDIA and an AMD 5700XT),
  • I have removed the M.2 drives and tested using a 2TB Seagate hard drive.
  • Two different Corsair 80Plus Platinum power supplies 750w
  • Updated the BIOS Settings and default BIOS settings
  • Reinstalled multiple versions of Windows 10
  • The system was running fine for about three weeks then this happened out of no where
  • When I try to install the drivers for the NVIDIA card I receive an error: This NVIDIA graphics driver is not compatible with this version of Windows. Even if I use the NVIDIA experience and have it auto download the drivers.

System 01:

Pretty much the same as above, except it never worked...

Are AMD processors this bad? I haven't used AMD since my Athlon 1600XP, and have had a few Intel systems since then and all were rock solid. This is a horrible experience with AMD and I am looking for help, someone has to have had this issue, I see a lot of post but no one is listing how they solved it.

Asus wants me to send the board back, but they wont pay for shipping on a two month old mobo... So I would not recommend buying Asus at this point because their Canadian customer service sucks.

1 Reply

check your disk controllers for ASmedia, if present, change to standard SATA AHCI drivers