Showing results for 
Search instead for 
Did you mean: 


Adept I

TR 1950X Performance unusable / stuttering in Windows

TR 1950X Performance unusable / stuttering in Windows


I have a big issue with my 1950X system, which I was not able to solve on my own. Before explaining the issue, here are the system specs:

  • AMD TR 1950X
  • ASUS PRIME X399-A (Bios Version 1203 – latest)
  • RAM: 4x8GB Corsair Dominator Platinum 3200 MHz ((16-18-18-36)) D.O.C.P profile ON
  • GPU: NVIDIA RTX 2080 (@latest Studio Driver – same issue with older drivers)
  • System Drive: Samsung SSD 960 EVO 500GB
  • Power Supply: Corsair AX650
  • Cooling: Custom water-cooling
  • Windows Version: Windows 10 Pro Build 19042 (had the same issue also with older builds)
  • (6 Sata Drives, 2 USB Drives, 1 NAS) attached to the system

I mostly work with 3D Software packages like Autodesk Maya (Arnold), Rhino3D, Adobe Suite and casually ArchiCAD. I really don’t care about gaming performance.

When I bought the system, it was working as one would expect. Back in the day, I still had an AMD HD7970 GE GPU in the system, which later on got replaced by a RTX 2080.

Now to the actual problem:

My system got very slow. Not the raw performance itself while rendering for example, but in the “every minute tasks” like browsing within windows explorer, copying files, loading small files into the Software etc., saving images and so on. And the longer my PC runs, the slower it gets, the more programs I have running (even if just on standby – not at all asking the system for performance) the slower the system gets. If I restart it, it is acceptable for like 30 min, and then it just degrades completely and becomes unusable. (It feels a bit like all drives go into hibernation mode after each klick and they have to resume again - so basically stuttering).

I don’t remember when the issue started, must have been around 1 year ago or more, not sure unfortunately. The issue slowly sneaked in, so after a while I thought a clean install of Windows would solve the issue. After a clean install, it worked for like 1 week, and then it started to behave like mentioned above again. Probably it worked shortly, since basically it took me forever to install all the software again and set up my working pipeline.

I actually don’t remember, if the issue started since I bought the 2080. Like I already mentioned, the issue sneaked in slowly, that’s why first I thought it was a “messed up windows issue”.


I checked many forums and already checked/tried:

  • Windows Clean install
  • Temperature (the system never goes over 54 degrees Celsius)
  • Disabling HPET in Windows
  • Disabling Power Saving features within Windows and BIOS (Spread Spectrum, Cool and Quite etc.)

At this point I am out of ideas what it could be. Since the System was quite expensive back then, and should still work for a few years, I really have to fix the issue, since it completely disrupts my workflow.

I appreciate any help! Thanks in advance!


15 Replies

Well,since the issue seems to be GPU related, have you tried any form of GPU diagnostic? If you replace the studio driver with standard DCH Windows Gaming drivers for it, does the system increase responsiveness?

Thanks for the reply!

 I replaced the Studio Driver with the Standard Gaming driver, but it didn’t have any affect. I am not claiming it has to be the GPU. I just read, that sometimes one could run into issues with 1st Gen Ryzen and Nvidia GPUs, even if that is hard to believe (personally).

Unfortunately, I can’t test it with any AMD GPU, since my old HD 7970 GE died and I don’t have one lying around. What strikes me, is that the performance while Rendering is great, always has been. Doesn’t matter if I render with GPU or CPU. It seems some kind of latency issues, on the software side, which I’m unable to locate unfortunately. I found some examples online, where people with a similar rig have encountered the same issues, but their troubleshooting suggestions didn’t work for me.


In task manager, under the GPU tab (or any gpu monitoring program), do you see any load on the video card? Im not looking for anything in particular, i'm looking for abnormal events, such as GPU failing to increase clocks, gpu memory usage very high, GPU load when not doing anything and so on.

No, everything seems quite normal. GPU is hovering around a few % and the Vmemory is not even half full (Of course, this changes when I start to render) but the problem is not specific for when I do render.  It just feels like a 20-year-old computer, with a super-fragmented HDD under Windows XP after 10 years without a clean windows install (you know what I mean).

A cinebench test looks pretty much how it should, which basically proofes that it is not a specific hardwareproblem. One thing came to my mind: at the same time, when I started having this problem, I bought and started using Acronis 2020 for backups. It only does the backup once a week though, so I don’t see how that could slow down the system this much all the time, especially since in the task manager there is nothing special going on and I have this stuttering all the time anyways.

The moment I use many programs at the same time (especially the adobe suite together with Rhino3D or Maya), it gets completely out of hand and working starts to become impossible (it is impossible that the system is overloaded, since in the task manager i have like 30% Ram in use, CPU is hovering at like 4-5% aswell as the GPU)


That Vram hovering around half usage when not doing nothing is peculiar since W10 WDDM is much more advanced than Vista (it happened there). If you feel like it,could you please record a system diagnostic document via HWINFO? Download and install HDwinfo64, open it,close the summary (the small menu showing the GPU you have and the CPU etc) and click sensors. In the lower left pane,there is a menu with a green plus (start logging). Press it, name the location of diagnostic file and minimise the program then start doing stuff for 10-15 minutes. Stop Logging ,and upload the file somewhere so that I/we can access it. It will be a rather odd .CSV file destined for microsoft excel/libre calc so you might have issues uploading it as it is (.CSV) so before doing so, archive the file. Best of luck

Sorry if it took a while, I couldn’t access my computer during the weekend.

I recorded the system diagnostic as you suggested. I had a moment today, where everything ran as expected. Explorer and software were super snappy. I thought maybe the change from studio driver to game driver did the trick, but after a while it started again, and after a few hours I was back in crazy-town.

I uploaded the Log File. You can find it here:

I really appreciate the effort. Thanks in advance!


Based on the report in Hwinfo you have a memory leak somewhere in the video  driver. The GPU vram is constantly allocating @4gb vram dedicated and this is excessive even when considering multiple gpu monitors.

Thank you for the reply!

Are you sure that 4GB is not reasonable? I have multiple files open while I am 3D modeling and working, and often listen to YouTube podcasts in the background. I have a 4K screen and a 2560x 1080 Ultrawide Monitor attached to the system.

My colleague has a computer with similar specs (Same GPU, but instead of a TR 1950X she has is a R9 3950X). Besides that, the System is basically identical, in she has no “stuttering” at all. That’s why I was pretty sure it has something to do with the CPU or at least some setting related to it.

How is it, that while rendering and using up all the VRam, I don’t encounter any noticeable performance issues (I mean I do, but again only in this random task like browsing the windows explorer, or for example loading an image into Adobe Photoshop, not during the rendering itself)

But assuming it is a memory leak, how should I counter the problem. Installed a different driver didn’t solve the issue.


I’m thankful for every single suggestion!


The memory leak doesnt mean the driver is bad, it might mean that something hangs in memory and doesnt release it while also consuming ram without any justification (this could be a game, your 3d program launcher and so on). Lets do a diagnostic startup from msconfig (open run ,write msconfig and in the first tab select diagnostic startup). If you want do come back out of diagnostic startup, open msconfig again and select normal startup. Cheers.

Thank you for your suggestion! I opened msconfig and selected "diagnostic startup" as you suggested. After that I restarted my PC but ended up having an error message that my PIN is not available. When I click for setting up a PIN it says it has to install an app but it doesn’t do anything. So the problem is that now I cant log into my PC anymore. I could try starting my windows from a USB device and see if I am able to find a way to  log in again. Do you have any suggestion what to do in these cases? It seems to get from bad to worse unfortunately.

Thank you in advance!


W10 PIN is available only after you set up a password first. Can you login using that?


I could not set a password. I tried more or less everything (CMD, save mode, automatic repair etc.) but I could not log into windows anymore. The only thing which helped was a system restore. I lost a few files but fortunately I backup every week. Have you any idea how I could proceed. I really need to fix the stuttering?

Should I try with the “selective startup” of turning off the PIN option before I do a diagnostic startup to avoid the same issue again? ( ? I don’t know if that helps. I’m out of ideas, and I really would love to narrow down the issue.

I am thankful for any ideas!


Try setting up windows without any logon credentials (or just a password) , to avoid such issues in the future.

I setup windows without any logon credentials now, and the diagnostic startup mode works now. Unfortunately, I can’t really work in that mode, since all my Software is not working properly when I’m offline (I need to be connected online). I tried playing around within windows explorer, but its hard to tell if there is any change to the system performance, since usually the system gets only really slow when I have multiple programs open simultaneously and especially when it is running for quite a while. So, I couldn’t emulate my usual workflow. What else could I try or should I try?

Thank you in advance!


It might be completely unrelated and I'm hope that by now you have fixed the issue but most of the issues I had with my TR vanished when I realised I was running on windows Legacy BIOS and not my MB's UEFI!

As soon as I got it fixed and I logged in, I might have shed a tear :')