Showing results for 
Search instead for 
Did you mean: 


Journeyman III

threadripper 2970wx

Hi All,

This is just a copy from the Reddit post.

Computer Type: Desktop

GPU: EVGA GeForce RTX 2080 Ti XC GAMING, 11G-P4-2382-KR, 11GB GDDR6, Dual HDB Fans & RGB LED

CPU: AMD 2nd Gen Ryzen Threadripper 24-Core, 48-Thread, 2970WX 4.2 GHz Max Boost (3.0 GHz Base), Socket sTR4 250W YD297XAZAFWOF Desktop Processor

Motherboard: MSI MEG X399 CREATION sTR4 AMD X399 SATA 6Gb/s USB 3.1 Extended ATX AMD Motherboard

RAM: G.SKILL TridentZ RGB Series 64GB (4 x 16GB) 288-Pin DDR4 SDRAM DDR4 3000 (PC4 24000) Desktop Memory Model F4-3000C16Q-64GTZR

PSU: CORSAIR AXi Series AX1200i Digital 1200W 80 PLUS PLATINUM Haswell Ready Full Modular ATX12V & EPS12V SLI and Crossfire Ready Power Supply with C-Link Monitoring and Control

Operating System & Version: WIndows 10 PRO 1809

GPU Drivers: 430.86

Chipset Drivers: Im not sure how I acquire these?

Background Applications: Creative Cloud, One Drive, Free Download Manager, Nvidia Console, Bluetooth

Description of Original Problem:

Apart from the massive trouble just trying to get windows to install on this and with a lot of trouble from the MEG motherboard and its terrible updates, I've finally managed to get things running.

I've installed the creative cloud and of the bat the system is performing really poorly with bad feedback when moving objects around or animating in After Effects. Even the benchmarks seem below average comparatively to similar systems. Looking at Task manager, my CPU seems to be well below the base clock speed @ 2.12Ghz , and when running benchmarks that fully utilize the CPU, barely boosts to 3.5Ghz. I'm not sure what the issue could be here. Perhaps voltages are wrong? Is there an option in the BIOS I need to change?

Troubleshooting: Apart from running a stress test on the machine for about half an hour, I havent really done anything. I've updated all the drivers from MSI website.

CPU-Z and GPU-Z images if that helps:

14 Replies

brashen, I have the same MB as you and a 2990WX.  Here are my specifications:

MSI X399 Creation, Threadripper 2990WX, 3xSamsung SSD 970 EVO RAID0, 4xSSD 960 EVO on
MSI AeroXpander RAID10, 1TB & 500 GB WD Black, G.SKILL Flare X F4-3200C14Q-32GFX,
Windows 10 x64 Pro, EnerMax-MaxTytan-EDT1250EWT, Enermx Liqtech TR4 280 CPU Cooler,
Radeon RX580, Aquantia 10 GbpS Ethernet NIC, UEFI E7B92AMS.130, AGESA SummitPI-SP3r2-

I will take a look at your problem.  Please post a screenshot of Ryzen Master (RM) - simply drag-n-drop the image in your reply.  If you have not, please do a Clear CMOS using the instructions in your user manual.  Please get your chip set drivers here (important!).  Thanks and enjoy, John.

Hi misterj,

Thank you for the reply, I've downloaded and installed the chipset from the provided link. I haven't yet done a Clear CMOS as I have a few deadlines I need to work on before I try to troubleshoot further. I've attached the RM image as requested.

Thank you for the helppastedImage_1.png


Thanks, brashen,  This all looks good to me.  Ultimately, please run Cinebench R20 and get an RM screenshot during running.  I ran it yesterday and got about 11,000.  Please take a look at this and the coreprio pointed to.  Let's wait until we have a better idea of what is going on.  I run it all the time on my 2990WX,  Thanks and enjoy, John.


Thank you mister,

I'll run the benchmark tomorow and I already tried getting the coreprio to work, there wasn't any marked difference. I'm wondering if I'm undervolting the CPU, what's the normal voltage for the threadripper? 


brashen, you should not need to adjust anything.  That is why I asked you to execute a Clear CMOS.  I run my 2990WX with no tweaks and get about 11,000 on Cinebench.  I also wanted you to wait to run coreprio until we determine what is going on.  Please STOP the coreprio service.  The strange thing about it is it seems to help about 50% of the time and very little on Cinebench.  It helped a lot on Indigo.  I hope you read my thread I pointed to.  We are hoping that MS will address the scheduler problem soon.  I have been trying to determine if 1903 addresses it.  I installed it yesterday - looks good so far, but have not looked at the scheduler problem.  Please post you CPU cooler.  I just looked at my Core Voltage and it was bouncing around a lot around 1.16 Volts, commensurate with yours.  Enjoy, John.

Journeyman III

Hi misterj,

Sorry for the late reply, but I've run the Cinebench R20 benchmark and got a score of 9116, which was on par with  another person's bench of 9277, Though I noticed that the computer never ran above 3.5GHz whne its supposed to boost to 4GHz. I did change my power settings to high performance. I havent cleared the CMOS yet as I have a lot of work to do and cant afford things to go awry at the moment. Will get back to you when Im done.

Thank you for the help so far, I'm looking forward to seeing the what the 1903 update will do.


Thanks, brashen.  I need to see your RM screenshot when running CB and also need to know what your CPU cooler is.  Thanks and enjoy, John.

EDIT:  Please look at this video.


Remember that the maximum boost clocks listed for a CPU are usually for lightly threaded workloads.  So when only a few cores are in use, the processor will boost those higher.  If all cores are in use, the boost you observe will definitely be reduced.


ajlueke, I do not agree.  Boost is much more dependent on the quality of the CPU cooler and settings in RM.  Right now brashen has a clearly defined PPT problem - please see RM screenshot below.  Until that is dealt with, it is not possible to comment on what the maximum boost can be.  Enjoy, John.


brashen‌ mentioned that his boost clock was "supposed to be 4.0 GHz".  And was only seeing 3.5GHz.  This is probably a reference to the max boost clock of 4.2GHz quoted for his processor by AMD in the specifications.

I was merely pointing out that the max boost clock usually references the maximum clocks you would expect to see, which typically occur under lightly threaded workloads.

So the fact that he doesn't see above 3.5 on all cores is not, in fact, unusual.

Sure, you can raise the boost clocks by messing with voltage limits and cooling, but the all core boost will still be lower than those under lightly threaded workloads.


Thanks, ajlueke.  It appears that AMD expects the user to at least OC the processor and use a Quality cooler to achieve the boost maximum.  I would agree with you that a user will probably not get very close to the maximum boost without OCing.  When brashen returns and lets us know what OCing is acceptable, we should find out.  I think he can get very close.  Please see this thread. All 32 threads are running.  The maximum boost for the 1950X is 4.0 GHz but I stopped raising the PPT limit at 400 and could go to 500 Watts .  Also see this on PBO and watch the included videos.  I know some users will not agree to any OCing as it voids the warranty but many will because Ryzen does this very well.  The internal (SoC) protects the processor and prevents thermal runaway.  Enjoy, John.

Journeyman III

Hey misterj,

I've attached the requested image. Also my cooler is the be quiet dark rock 4 pro. Watched the video you sent, Im pretty sure I'm not running into any temperature bottlenecks.pastedImage_1.jpg



Thanks, brashen. You are correct, your maximum temperature is 68C.  The problem is PPT.  Your processor will throttle on PPT, TDC, EDC or temperature.  When any approach their limit, throttling will be invoked - reduce CPU clock and Voltage.  If you want to run faster you will need to increase the PPT limit and this is done in BIOS.  I raised mine to maximize performance for Indigo - see here.  You can also try coreprio and see if that helps.  Remember it helps only about 50% of the runs, so try it several times.  I think raising PPT limit will be considered OCing and void your warranty - read the RM warning.  The EDC reading is not available on the WX processors right now.  AMD is aware and hopefully it will be corrected.  It is my understanding that it is still applied.  There is a good reference on the RM page at the bottom for the QRG.  Thanks and enjoy, John.

EDIT: Are you running W10 1809 or 1903?  It is beginning to look like 1903 (I am running) has at lease some scheduler changes.  I have removed coreprio from my system but have run out of PPT, as you have, and will need to adjust that to get better results.  Latest CB R20 is 11124.

Adept I

 MSI MEG X399 CREATION   search for internet driver download . And keep it for later os installation .

  The problem i think that your cpu has throttle temperature so that the cpu drops the frequency . Only by this way . What cooling system are you using ? . Buy a better one .

   And so this machine gives the service for cloud computing .  How much for a month ? . I do not know how to contact with you in this forum .