Showing results for 
Search instead for 
Did you mean: 


Adept I

Threadripper 1950X Suddenly Wont Boot

I have a Gigabyte AORUS Gaming 7 with a Threadripper 1950x that was working for almost a year. Tried to start it up and it will not even post. The board immediately shows CPU light and post code of D0. I have a 1000 watt Cougar CMX power supply and AORUS Radeon RX570 video card. Everything has been running smoothly and this rather abruptly happened. Nothing has ever been overclocked and ran the stock configuration. 

The key here is everything was working for a long time and then nothing. Everything is still in warranty. I tried resetting the BIOS but it wont even do anything.

As another note, all fans spin when powered on and the vga lighting cycles normally. 

6 Replies

Gigabyte LED Error code "D0" is this - D0 | CPU initialization error.

According to this previous Gigabyte Support Thread "DO" really indicates a Motherboard issue rather then a CPU issue. 

In another Gigabyte thread with "DO" error the User RMAed the Motherboard and the replacement worked fine and fixed the "D0" error .

I would open a Gigabyte Support Warranty request and see if they recommend to RMA the motherboard to check the motherboard's BIOS.

I did try the emrgency reflash and it did not change in status. I am getting another power supply to make sure that is not an issue then I will proceed with an RMA on their side. The re-flash should have reset to defaults and it did not because the lighting on the motherboard is off and it should be red by default.

Thank you for the quick response. It is greatly appreciated. I suspected the same but it is always good to hear someone else add their confirmation.

Maybe you might also put in a AMD WARRANTY REQUEST to see if they recommend to RMA your processor if it is less than 3 years old.

You can open a AMD Warranty Request from here: 

EDIT: Best way to eliminate the Processor or the motherboard is by installing the Processor on another compatible Motherboard. If it boots up, it is a sure indication you have a defective Motherboard if it doesn't boot up than you have a defective Processor.

After running through the q-flash, I was able to see the motherboard reset to default today. After that, it is now stuck in a boot loop sequence and that is a giveaway that the motherboard has a problem. 

I have an RMA in with Gigabyte and hopefully that will end the problem. 

Turns out, the problem resolved itself magically then several months later I ran in to this problem again so I bought a new motherboard. The processor did not work in there either. Used all of the parts in a different build (AM4) and the other parts worked like a champ. The testing in another board game me the answer I was looking for and AMD replaced the processor after a very quick RMA process. I guess I just got lucky that it continued to work for a while after the first incident but it did start crashing a lot after that first round.

Thanks for the update.

Many Users just RMA both the Motherboard and Processor at the same time unless they are positive it is one or the other.

Just saves time of replacing one part and then have to wait to replace the other part if they aren't sure which one is defective.

Glad you finally got your computer working again.