Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Threadripper 1950x overheating and shutting down

Hi All

My system was working since 5 months with no issues and suddenly it started heating up and shutting down

Config I have:-

AMD Ryzen Threadripper 1950x

ROG STRIX X399-E GAMING motherboard

Enermax Liqtech TR4 360 AIO Liquid CPU Cooler

NVIDIA GeForce GTX 1080 Founders Edition

G.SKILL TridentZ Series 64GB (4 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200

Samsung 960 EVO


I recently cleaned the whole desktop (after the heat up) and reapplied ARCTIC MX-4 - Thermal Compound Paste.

I am wondering if my AIO is even working. The fans and AIO pump goes in different ports on motherboard. The fan are working for sure, how do I know if the pump is working or not?

Plus could this be an issue with corrupted CPU.

When I start the CPU, it start from 50-60 and even if I do not do anything it keep climbing up to 100 and shut down. (tried that twice, then just let it be shut)

Attaching the pics of my setup, in case any of you think any of the wiring is wrong

Thanks in advance

12 Replies

timtim, it absolute sounds like the water pump is not working!  What RPMs does your display says it is running?  I have a different model of EnermaxLiqtech and it is turning about 2800 RPMs.  Good luck and enjoy, John.


Thanks for the response. I think I am doing something wrong while connecting my AIO pump may be.

I read about it (googled it basically) and there are few folks that have put the AIO pump in cpu fan - I tried the same but am getting CPU speed error.

When I go into BIOS, I can not see the rpm on that pump.

Can someone with similar setup tell me where I should put the AIO pump and how I can monitor the rpm for the pump. I am not finding that detail in bios (the rpm part).

So when I was just using the AIO pump wire in CPU fan (without plugging the AIO fans into MB......I was getting the message.......CPU fan speed error (as soon as I was starting the cpu)....set rpm in BIOS. When I went inside BIOS, I saw this pic attached.

But then I added AIO fans to cpu-opt pin in MoBo and the cpu started with no errors. But I still see high temperature in idle mode (reached 71 C in 5 minutes)

PS: one of the tube of Enermax is getting hot while other is cool. I can feel some vibration when I touch the tube, so not sure if it is working or not.


So I put it back to AIO Pump socker and checked the BIOS. It was working at 2800+ rpm.

But the MoBo guide is bit vague about which wire to put in the AIO they say put the AIO Fan socker in there.


Sounds like the cooler has died.

If you touch the tubes running from the CPU..does one of them feel warmer/hotter than the other...a sure sign the pump is dead or there is a blockage somewhere.


Thanks yes, one tube is much hotter than the other. Though there are vibrations and the bios is showing rpm.

Is there any warranty service for this AIO, I am unable to find it on there website. Enermax says to deal with the shop that sold it. I moved to another country, so that may not be possible any more.

Which other cooler is best for threadripper in your experience? Might have to buy a new one, I guess.


timtim, you need to make a decision soon, before you fry your CPU.  Either talk to Enermax, very good company, or buy a new cooler.  Can you call them on the phone?  Corsair makes good AIO coolers for TR and about the same price.  Be sure they are designed for TR and cover all chips in the module.  I am running my Enermx Liqtech TR4 280 at 12 Volts and it turns about 2800 RPMs.  Right now my CPU is at 25C.  Good luck and enjoy, John.


OK so the cooler is definitely toast. Any RPM reading may be the shaft spinning while the impeller is not moving for example. Maybe it has an air pocket...etc etc...stop using it to avoid damage to CPU. Just replace it.

I built myself a custom loop...never tried any AIO cooling so I don't know what to recommend.

Journeyman III

My enermax liqtech tr4 360 also died, the first gen that starts with serial 17 were bad and the liquid gums up, enermax sent me a new one for free. Open an rma with them and they should take care of it.

Journeyman III

Thanks everyone, appreciate the input. Will change the cooler fast. Do not worry, I am not using it at all, till I fix this.

Will try to see if Enermax would honor a replacement, worst case will get another brand now.



Adept I

1. 1st  I should point out that there is a vibration in the tubing, as well as a temperature difference, which indicates that there is at least SOME flow.

2. 2nd you said that the problem started after you reapplied the TIM. could it be a problem in the TIM/ water block mounting?

Journeyman III

Did your machine work with a new cooler?  I just got a new TR 3960x - the new one.   It's overheating and shutting down.  I used a Corsair H115i, which is on the list of AMD recommended coolers.  When I first built the machine it started up and I was able to install windows 10.  Then, after about an hour where I wasn't running any apps, the machine shut down.  I've ordered an air cooler (Wraithripper) to try another cooler and see if that's the problem.

Just curious if a new cooler worked for you and which one you went with? 


I went with "Noctua NH-U14S TR4-SP3 premium-grade 140mm CPU cooler for AMD TR4/SP3" and so far its been working great, i feel the unit I got earlier was faulty from the start, because the new Noctua does much better job than water cooler Enermax Liqtech TR4 360. Temp stays between 40-50 C most of the time. Though to tell you the truth, I rarely stress the system anymore like I used to.