cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

warsoul
Newcomer

Terrible Stuttering with threadripper 1950x

AMD threadripper 1950x (Chipset drivers from AMD)

Asus Prime-a X399 (Bios 503)

64gb ddr4 3200mhz cl14 tridentZ

Samsung 850 Evo SSD 512gb

HyperX 120gb

EVGA GTX 660sc

WD 2tb HDD

Corsair H100iv2

Corsair Obsidian 750D Airflow

Corsair HX 1000w

Windows 10 Pro 64 bit

Nvidia Drivers 397.31

What i tried to fix the Stuttering :

1- Installing AMD Ryzen Master to launch in gamemode

2- Installing the lastest Asus AI Suite

3- Disabling the HPET

4- Disabling SMT

5- Installing AMD chipset drivers instead of Asus ones

- No results, my mouse lag on the desktop and my computer seems to throtling even if my temp are between 31 to 58 degree in CoreTemp or Ryzen Master.

- My chrome take 3 to 5 seconds to open, my hyperlink in my email take 10 seconds to open. My i7 920 D0 was 3 times faster for a 9 years old CPU.

- I was running my game at 60fps+ with my i7 920 and now with my threadripper 1950x, my games starts at 140fps but slowly drop to 30 fps in less than 2 minutes and the games are unplayable even in game mode.

I'm poor and handicaped, i saved all my pennies for 3 years to build the best CPU i can afford for my Zbrush Workstation. I'm litteraly crying now, even if i am 38 years old. 3000$ spent for something worse than my 9 years old Workstation. Please Help Me !

0 Likes
34 Replies
Matt_AMD
Community Manager

Asus AI Suite enables HPET. HPET is known to cause stuttering issues with NVidia GPUs, so i would look to uninstall AI Suite and make sure HPET is definitely off. I've seen many NVidia users have the same issue as you unfortunately. https://www.reddit.com/r/AMDHelp/comments/6wmhrf/help_threadripper_1950x_asus_zenith_x399_lag/

I have an identical system as you, same Motherboard and everything(Threadripper 1950x ), but with a Vega GPUs and see no stuttering at all.

Disable HPET: https://www.ghacks.net/2013/04/18/try-changing-hpet-settings-to-improve-your-pcs-performance/

0 Likes

Already tried that with no success.

I'm reinstalling Asus AI suite, just in case.

I looked into others forum and they said i need the 8 pins connectors + the 4 pins connector for the CPU. My Corsair HX 1000w doesn't have a 4 pins connector at all only the 8 pins one. In the User Manual; it say plug the 8 pins connectors or the 8 pins connectors + 4 pins connectors.

Can't find the HPET setting in my asus prime-a Bios ?

I used the CMD command to disable it : bcdedit /set useplatformclock false

0 Likes
Matt_AMD
Community Manager

Hmm, interesting, that could be an issue. In both of my Threadripper systems i have all the relevant CPU/PSU pins connected, definitely worth trying that first with a better PSU.

0 Likes
Matt_AMD
Community Manager

Yes it's a windows setting as Asus AMD boards don't have the option exposed in the bios. I would look at the PSU issue first, you need all the pins connected.

0 Likes
warsoul
Newcomer

Why my HX 1000w from Corsair doesn't have that 4 pins connector ? Can i get a fitting for my extra 8 pins connectors i got ? I have two 8 pins but no 4 pins, weird ?

Where i can find a list of all PSU compatible with the asus prime-A and threadripper 1950x ?

All nvidia card get thoses issues ? Even the new GTX 1180 or gtx 1180 and gtx 1080 ti ?

Edit : Never Mention, i'm an idiot, i can split my 8 pins into 2x 4 pins. Sorry !

0 Likes
Matt_AMD
Community Manager

I'm not that familiar with Corsair PSUs or Nvidia GPUs, so best to direct any questions relating to those products to the manufacturer's.

0 Likes

warsoul, where did you get your chip set drivers?  I think you should get them here.  I assume you have the latest video drivers but how about the GPU firmware?  I would think you should best run factory default settings, including SMT but not HPET as amdmatt points out.  Is BIOS/UEFI 503 the latest?  What version of W10 (command prompt - winver) - I'm running 1709.16299.371 and 402 is available.  Enjoy, John.

0 Likes
Matt_AMD
Community Manager

0503 is unfortunately a fairly old bios, but is the latest one available for the Prime A, which has only received three bios updates since launch.

0 Likes

Actually, he should get his chipset drivers here, imo:

Chipset

AMD updates them regularly (about once a month) and the direct link is always good, I've found.

0 Likes
warsoul
Newcomer

!Nope, it doesn't help at all ! Sames issues with 8 pins + 4 pins and no HPET and no AI Suite

0 Likes
warsoul
Newcomer

Even my UFEI Bios Lag !

0 Likes
Matt_AMD
Community Manager

When you move the mouse? I also see that, appears to be a Motherboard issue as it happens on the Prime A and the Zenith Extreme Asus boards.

I would recommend reporting the issue to Nvidia to see if they can reproduce it as it does not occur with AMD GPUs.

0 Likes

Threadripper 1950x isn't compatible with Nvidia GPU ? I haven't been warned before i purchased my threadripper 1950x. Where did AMD mention theses warnings on Nvidia GPU ?

The mouse lag all the time in bios, more i stay more the mouse lag. Look like something is collecting garbages without being able to flush it.

Did i call an RMA for my motherboard ?

0 Likes
Matt_AMD
Community Manager

It's compatible, but looks to be an issue with NVidia drivers/GPUs which causes stuttering based on other reports. As there are no drivers required for the CPU, you would need to raise it with Nvidia directly for further investigation.

0 Likes
warsoul
Newcomer

Win 10 pro 64 bit version 1709 16299.402

I installed the asus chipset drivers 1st, then i switched for the AMD after reading on forums.

I reseted my bios setting to defaults, disabled the fast boot and turned off HPET with prompt command

I use the Ryzen Balanced Power Plan too. Forgot to mention that.

0 Likes
Matt_AMD
Community Manager

I'm out of ideas, the only difference between our systems is the graphics card.

0 Likes
warsoul
Newcomer

G.SKILL TridentZ Series 64GB (4 x 16GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) Intel X99 Platform ...

SAME DDR4 ? I choosed this one who was on many 1950x build to be sure. The Intel x99 thing can be the issue ?

How i can clean Unistall all chipset drivers for a clean install ?

0 Likes
Matt_AMD
Community Manager

Yes same memory, though i am using 32GB, Samsung Trident Z 3200Mhz CL14.

IMG_3736.JPG

0 Likes

Damn ! We can run 128gb at 3200mhz ? CL14 ?

0 Likes
Matt_AMD
Community Manager

I've edited my post above, I'm using 32GB total, 8GB DIMMS.

Check with the Motherboard QVL to see what speeds have been validated at 128GB, i would hazard a guess that 3200Mhz CL14 is unlikely.

0 Likes

What i saw was something around 128gb at 2933mhz max for stable build.

0 Likes
warsoul
Newcomer

I plan to buy a GTX 1180 in july at launch, did AMD will have issues with it on a asus Prime-A x399 ?

For now i have to deal with this stutering issues on my EVGA gtx 660sc. I'm a cool and nice guy and i know my gtx 660 is pretty old but imagine a 3 years saving for a 3000$ cad upgrades which lead to 25fps compare to my 60fps+ with my old rig. It's an hard blow to take and dammit tasty blow. I hope you will find a fix soon and ask asus to fix their things too.

0 Likes
warsoul
Newcomer

pastedImage_0.png

pastedImage_0.png

pastedImage_0.png

0 Likes
waltc
Miniboss

You don't think your GPU is a big bottleneck on this system--I mean, are you gaming at 1080P or something?...;) That GPU is--what--six years old?  If you are running @higher resolutions then it pretty much has to be your GPU.  I would seriously start saving your pennies for a decent GPU--you'd flip out at the performance difference in your 3d games (are they 3d or 2d?) you'd see just throwing a $250 8GB RX-580 in that monster (If you can find one selling at MSRP.)  Good luck--you have a seriously imbalanced rig there, imo.  Is nVidia even updating that these days?  Just a thought for you to consider.

0 Likes
warsoul
Newcomer

Answer on Nvidia Forum :

Have you totally exited corsair link?

hpet doesn't cause nvidia stuttering at all /unless theres a pre-existing platform issue with it such as manifested with som amd and intel chipsets/

not to mention his precious Zen platform requires hpet enabled to work properly.

the HX1000 comes with a 4+4 aux power pin, the mainboard only needs the one 8 pin socket connected, you don't have a lack of power here.

The asus bios stutters because you don't have a UEFI capable video bios, so it is operating in legacy mode with a SVGA resolution and no hardware acceleration.

a GOP enabled vbios enables some amount of uefi acceleration.

This bios rom should fix that

5- Installing AMD chipset drivers instead of Asus ones

AMD's sata driver is a source of stutter (has been for years)
https://www.reddit.com/r/Amd/comments/89vpm0/amd_sata_controller_drivers_stutter_for_anyone/

There are also cases of SSD's trying to go to 'sleep' when they shouldn't be

Further research led me to the conclusion: host (Windows) tried to save power by telling ssd to go to sleep. Then ssd hanged (stutter), after some timeout, host restarted ssd.


https://www.tenforums.com/tutorials/72971-add-ahci-link-power-management-power-options-windows.html

0 Likes
Matt_AMD
Community Manager

To clarify, we don't have a Sata driver, we use the in the box driver provided by Microsoft and Linux.

HPET was required for early builds of Ryzen Master Tool, however it's no longer required and actually disabled by default on my systems.

I hope either flashing your video card bios and or using those other tweaks mentioned in the GeForce forum thread helps to resolve your issue.

warsoul
Newcomer

My coretemp warn me 1 boot on 3 with a popup saying that one or two of my core hit 229c in coretemp.

This guy has the same issue : My threadripper reaches 229 C. - CPUs - Tom's Hardware

That's wrong reads ? False positive ?

0 Likes
Matt_AMD
Community Manager

False reading, if the temp was 229c your system would have melted. Ryzen Master Tool or the latest builds of HWINFO64 should provide correct temperature readings for Ryzen Processors.

0 Likes
warsoul
Newcomer

I fixed my fps drop to 25fps by refirbushing my gtx 660sc with new thermal paste and a good cleanup. My blower was clean but the radiator was cloged. I didn't open it before due to the warranty void if open.

- Still have some stuter with mouse in bios and when browsing but at least i can game a little.

I got more fps in creator mode than game mode with Sniper Elite 3. Normal ? GM = 62 to 78 fps and CM = 72 to 89 fps !

I think the XFR cause the stutering, Ryzen master keep trying to boost 2 core from 3.7ghz to 4.1ghz each 2 seconds.

How i can fix the chrome issue ?

0 Likes
Matt_AMD
Community Manager

I doubt XFR is related to the stuttering, but if you set cores to 3.7Ghz with Ryzen Master Tool XFR and all power saving features of the CPU will be disabled until you restart the system.

I suspect your Chrome issue and mouse lag (outside of the bios) is related to your GPU/Drivers which i can't help with.

0 Likes
drajitsh
Adept I

Did you consider that your waterblock is compatible with threadripper but not actually designed for it. Please go through

Analyzing Threadripper Thermals: Big Base Cooling Wins 

0 Likes
samet
Adept I

I had those stuttering, lag issue. What I did was disabling hpet from within windows in command line while leaving it enabled in bios because I could not reboot if it was disabled in bios. Then I disabled fast boot in control panel, and in power settings, I selected Amd ryzen balanced mode and customised it settings. In the bios I also disabled all cpu features like cool and quiet, cstate control, opcache, mode0, spread spectrum etc..., I just leaved SVM Enabled because I need it for vmware. I also set my cpu speed to 3200 by setting multiplier to 32, instead of using auto. XMP is enabled on profile 2 ( I have a MSI x470 carbon pro ). There is no lags anymore it is super fast. I noticed that in ryzen master, before all those fixes, edc was at 100% in red, now it is at 85%. Everything works normaly.

 

There is also a bug related to windows 10 not feeing up standby memory, so it causes lags, download a program named EmptyStandbyList. search tutorials on web on how to make it works it is easy, and that way memory will always be free, and the will be no lags.

 

I also found out that after reenabling fast boot in power settings, or waking up from hibernation makes lags and stutterings come back. And also, waking up from sleep does not work : /

0 Likes
inf3rno
Journeyman III

There is a good chance your SSD is causing it. Run CrystalDiskMark random Q8T8 test on it. For me it freezes the computer, but sometimes it just stutters.

0 Likes