Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Stuttering 3600 Ryzen

Hello. I have been having stuttering issues since this computer was bought. I have tried every single fix on the internet. You name it, ive done it. Ive tried everything posted in related posts on this website as well. The Ryzen power plan helped smooth the stuttering a bit, but its still there and driving me nuts.

Nvidia 2070
Windows 10 64 bit
Latest drivers as of 12/2/2020
LG 27gl850 DP to DP, 2560x1440, 144hz
Ryzen 3600
Asus x470
16GB 3200mhz (i think)

The pattern is consistent. 100+ FPS nonstop, then the CPU power drops to 25% or so (according to MSI afterburner and HWinfo). I can hear some fan slowing down as this happens too. It seems my clock rates stay the same, and I know its not the GPU fan cause im monitoring it.
There is NO HEAT THROTTLING. Everything runs  at <50C

I figure this is the CPU trying to do some power saving thing, and the changes are causing that stuttering. I do not have the option to turn off cool n quiet in my bios, I tried. Power plan set to Ryzen performance or whatever and it helped for sure. 650 watt power supply so its not that either.

Ive spent the past 20 years being an AMD fanboy, and I am starting to lose hope. Help me!

PS I have found a tool named "Ryzen Controller" and I dont mind setting my parameters higher and using extra energy, id rather not deal with this stuttering. I do not know what settings to use, so I HAVE NOT attempted to use it. If you think this will help, id love you to explain what to change.

2 Replies

Sorry you are struggling so long with this.

If you have been fighting this a while, I would highly suggest you talk to Asus support. 

This problem is obviously not normal or widespread so something is likely going on for sure.

They can help you diagnose if it is a Bios configuration issues or hardware problem or even if they think it is CPU related.

If you end up having to RMA the cpu, you can start that process here:


Check your BIOS version. If this the Asus X470-PRO and your BIOS was "updated" to 5806, you need 5603 and unfortunately Asus claims it's a non-reversible update. That BIOS is Beta and AGESA V2 PI causes issues like yours and worse. See if  Asus can help you out, probably with an RMA to fix that BIOS chip. The July version for the X470 is: AGESA ComboV1 It applies to all X470,B450,B350,A320 chipsets, no matter what board maker. 

I have the 3600X and tried that update but have an AsRock X570 board with "flashback" so it was a quick fix minus needing to reinstall my OS and games. Mine would stutter and do all these things too, plus random reboots. Flashed back to Agesa V2 PI and no issue. 

"It worked before you broke it!"