Showing results for 
Search instead for 
Did you mean: 


Journeyman III

[SOLVED] New Ryzen 5 3600 CPU high temperature with safety shut downs


If anyone would stumble onto this: The problem was that the new heatsink was firmly screwed in but still there was a gap (<1mm) between the CPU and itself.

The first one was probably faulty because the stock heatsink was mounted correctly (that one does not come with slightly too long pegs to stand on).

Conclusion: Always try to fit a piece of paper under the heatsink to see if it is mounted properly.

New data: 77 °C max when gaming. On idle (or not under serious stress) it sometimes jumps to 60 °C but then cools off just as fast otherwise it runs under 40 °C. I guess that's pretty normal with these 7nm technology CPUs.


------------------------------------------------------------------------original message-----------------------------------------------------------------


I have a Gigabyte x570 UD motherboard with a Ryzen 5 3600 CPU.

Ever since putting my PC together the CPU temperature was above 90°C.

I read multiple threads and i did the following:

  • Updated BIOS with the latest one from Gigabyte (MOBO is Revision 1.0 and the BIOS i got is for that). For this I used the Aorus Q flash thing (maybe i should take out the CPU and repeat?)
  • Reseated the heatsink several times and even the CPU once (while always cleaning off then reapplying thermal paste)
  • I traded the first CPU I bought for a new one under warranty with the store and the issue still persists
  • Bought a new beefier heatsink which did mitigate problem just enough to be able to use the PC for a few minutes before safety shut-down
  • I also reinstalled my system drive several times to no avail

Now, my true question is that could the MOBO somehow overdrive my CPU?

I reset the CMOS a few times and tried to check the BIOS settings but the problem is hugely amplified in BIOS with the temperature getting above 100°C in seconds. It seems that the chipset drivers in windows help but since they are absent in BIOS I can't even see what options I have there. So I checked the manual but on my PC the "Core Performance Boost" option is missing, so I guess that's not it. I do not dare to change frequency and voltage settings so I don't know what else should I try here.

I also checked voltage levels with CPU-Z and the results seemed OK (just under 1V) with the core voltages spiking high (cca. 1,3 V) from time-to-time. But the frequency was around 3,5GHz on all cores constantly with little fluctuation.

Ryzen Master showed temps just under 90°C with spikes of 94-95°C.

At this point I don't know what else I could do so any ideas would be very welcome.

2 Replies

Absolutely it could be a faulty thermal sensor reading, and I would suspect it is since you changed both the CPU and the heatsink, and it's not displaying some insane voltage in BIOS.


I am not sure because the back plate feels rather hot (though touchable).

I'll try BIOS downgrade and one more system reinstall today and tomorrow I'll take my gear to have it diagnosed.

I'm going to keep your suggestion in mind, thank you.