Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Slow performance of 1920x system in old 3d app and strange behavior of SMT

I`ve had my 3990K with similair spec but it has been burnt. Something is wrong with my new comp becouse it is much slower than my 3990K (i7 x64 6cores / 16threads 3.2/3.8 GHz) it is even slower than my current old Leonovo Laptop W520 (i7-2820QM 2,30 GHz/3,4 GHz 4cores/8threads)  on 3d app.

That old W520 is my current base point (it may be funny but not for me ).

I`ve did all tips from that article:

I use David 3d scanner which handle CPU for mesh alignment. DAVID_Setup_4.5.3.1374.exe (Date: 2016-08-31) from this site: It`s possible to run that soft without saving (some kind of trial).

Open David as administrator. Open my attached file made for testing. Go to Shape Fusion tab and hit "G" key. Next point green mesh as "A" and violet one as "B". Look on time.

1920x with Creator Mode (SMT turned on) with default BIOS and disabled HPET - it`s about 21seconds (measured with stoper on cell phone)

Old Lenovo W520 same alignment did on 15 seconds (Mobile quad core is about 6 second faster than my 1920x. Something wrong here.)

On heavier meshes difference is much more noticable (21sec vs 30 SMT-1:30 noSMT)

Other thing is when I turn on SMT in Ryzen Master then on Windows 10 I can see only 12cores/12 threads. When I turn off SMT then I can see 12cores/24 threads in Windows 10.

On CPU multithread benchmark it`s about half of 1950x (SMT enabled).

My teories:

- faulty RAM (tested and it`s ok)

- dual RAM on four slots instead of quad on eight slots (I should buy more ram)

- faulty CPU

- faulty motherboard

- Motherboard is not supporting SMT and should but better one

- everything is ok and I have to live with it that my old laptop is faster than my new comp which may be used for heavy duty work

- something with bad latencies (I don`t know that topic at all)

Can you help me with my issue?

My system:

Motherboard: x399 sli plus (AMI BIOS Version 7B09vA6 A.6.0 2018/08/09, AMD Chipset Driver Version 17.40.2815.1010)

Video: GTX 1080Ti

SSD Samsung 860 PRO EVO

CPU: 1920x (Ryzen Master

CPU cooler: NH-U14S TR4-SP3 (temperature up to 50 celcius)

RAM: Kingston Fury 64GB (4 x 16GB) DDR4 2400CL15

Windows 10 Pro version 1803

PSU: Corsair HX1000 CP-9020139-EU 1000W 80+ Platinum

14 Replies
Journeyman III

I have one more strange behavior.

When I disable SMT in BIOS and I have disabled SMT in Ryzen Master (Creator Mode) then I can still see 12 cores and 24 threads (same way as I had SMT enabled in BIOS).

When I disable SMT in BIOS and I have enabled SMT in Ryzen Master (Creator Mode) then I can still see 12 cores and 12 threads (same way as I had SMT enabled in BIOS).

So it looks like SMT feature is not supported on my MoBo (but there is present option in BIOS - SMT auto and disable). Maybe BIOS is same for all models and higher version will support it properly or my unit is faulty.

So in Windows and Ryzen Master settings all looks same with no connection is that SMT option is disabled in BIOS or not. Performance is also same (maybe even 3% faster if disable SMT in BIOS for both cases in Ryzen Master).

Maybe If I buy top class MoBo then SMT feature will show 24 threads.

Please help me to identify reason of this issue.

Please tell me also one thing:

is SMT feature should show all threads or only real cores and same amount of threads?

Maybe my unit is faulty or my MoBo doesn`t support SMT.

Big Boss

bartosh, those are really old chip set drivers.  Please DL the latest from AMD driver site.  Install them and activate the Ryzen Balanced power plan.  Please post a screenshot of Ryzen Master (RM).  RM is the AMD reference for measuring CPU temperature.  What does "- dual RAM on four slots instead of quad on eight slots (I should buy more ram)" mean?  CPU-Z says you are running quad channel.  Enjoy, John.


I have RAM:Kingston Fury 64GB (4 x 16GB) DDR4 2400CL15 HX424C15FBK464

so it`s not possible that I`m on quad channel becouse I use 4 slots instead of 8 (4x16GB RAM). 4 slots are free, so I think it`s dual channel.

I`ve updated chipset drivers to newest ones. Reset bios to default settings (inside bios). Is in same way as before. With SMT enabled I can see only 12cores and 12 threads instead of 24 threads.

I have activated balanced plan.

Thanks for trying help me.





Thanks, bartosh, your drivers look good.  Where did your OS installation come  from?  If it is not a fresh install of W10 x64, then that is the problem.  If so, please do a fresh install of W10 and let us hear the results.  In particular, if you are using the W10 from your Intel install, that is a major problem.  As far as I know there is no correction other a fresh install.  I too only have 4 sticks of memory (4x8GB) in my 1950X and it is quad channel.  What slots are your sticks in?  Enjoy, John.


My license (box not oem) is upgrade from 8 Pro so always I have to install 8.1 and then upgrade it up to 10 (with using media creation tool).

I`ve done fresh install of 8.1 on new drive. Next I`ve used Media Creation Tool to install Win 10 upgrade. I`ve thought that is a fresh copy of Windows 10.

Is it needed to be Windows 10 as direct instalation without 8.1 underneath?

"In particular, if you are using the W10 from your Intel install, that is a major problem."

So what version should I use?

When I disable SMT in BIOS and I have disabled SMT in Ryzen Master (Creator Mode) then I can still see 12 cores and 24 threads (same way as I had SMT enabled in BIOS).

When I disable SMT in BIOS and I have enabled SMT in Ryzen Master (Creator Mode) then I can still see 12 cores and 12 threads (same way as I had SMT enabled in BIOS).

Is it becouse of 8.1>Windows 10 fresh instalation instead of direct Windows 10?

Thanks for helping me undertstand that issue.


Thanks, bartosh, your install process should work OK.  I think you need to get to pure factory defaults and see what you see.  First do a Clear CMOS or Load UEFI Defaults.  You should be able to create the latest version of W10 (1803.17134.285) using MS Media Creation Tool, boot the USB, let Setup format your C: disk and do a fresh install.  Does MS complain about this?  When Setup asked for a key, click the option below that you do not have one.  You can run RM, if you like, but stay on the Current tab and do not set anything.  Use CPU-Z to show us the memory channels and cores/threads.  Who makes your MB and where are your four memory sticks plugged?  Thanks and enjoy, John.


Fresh Windows 10 PRO 10.0.17134 (screens below).

It`s faster a bit but It`s still slow on my David software.

Should I see 12 or 24 threads after enable SMT in Ryzen Master?

Ram is present on A2, B2, C2, D2.






Looks fine to me, bartosh.  You should not have to set SMT Enabled, should be default.  I think you need to post on the MSI AMD MB forum.  I have a logon there and perhaps we both can learn something.  Please post a screenshot here running David software.  Please let me know if you find SMT turned off.  Thanks and enjoy, John.

EDIT: Can you run David HP 3D Scan 5?  It is a full 2 years newer than what you are running when Ryzen did not even exist.

Journeyman III

During my work I have few hundreds scans. I`m licensed on 4 version but 5 version (HP) is same speed with alignment as previous one (I`ve checked it today once again).

Bigger scans (which I can`t provide NDA) are aligning on my newest setup with SMT disabled about 90 seconds. When I enable SMT in Ryzen Master then I can do it in 45 second. When I disable 4 cores and leave SMT enabled then I can do it in 30 seconds (best setup).

My old lenovo quad laptop W520 do it in 28 second. My old 3930K did it in few seconds (permamently burnt and I can`t  do test on it but I`ve worked on it few years so I have experience).

Why SMT should be disable? Why temperatures without SMT are smaller (37C) than with SMT disabled (47C).

I feel during work that SMT is needed for me becouse I feel like threads are not communicating each other and do that job chaotic. Alignmet is few stage process and it`s freezed on first stage longer while before it starting doing something.

On laptop I feel that stages are made simultaneously thats why I tried to enable SMT. My better timings on SMT enabled are proving that I`m right. Why when I turn on SMT then I can see only 12 cores and 12 threads? Is it normal behavior?

Thanks for trying help me.

I will post message on forum which you provided.

Best regards,






Thanks, bartosh.  I cannot make sense of this.  Were you able to try 5 (HP)?  I have wondered in the past that many applications have run on Intel processors always and been optimized on them and do not run well on AMD architecture.  I suggest you open a ticket with AMD and David.  If David has a user forum, please ask their opinions.  Sorry I could not help.  Good luck and enjoy, John.


I`ve taken David 5 from this link above. I`ve installed it on my 1920x Win10 Pro (newest setup). I don`t have license for 5. I`ve used it as trial to check speed only.

Should I create new ticket here: ?

I`ve created thread on David HP forum (HP is owner of that technology now):

Thanks John for your efforts.

Best regards,



Thanks, bartosh.  Yes that is the correct link to open an AMD e-mail ticket.  I guess 5.5.1 was just as slow?  Enjoy, John.


After watching this:

and after installing Process Lasso and disabling 4 first threads (and changing power plan to ultra) performance improved in David. I hope Redstone 5 update (and maybe AMD chipset update) will fix those problems. I think it`s not only David problem. It`s bad utilising some threads in some apps.


I know that linux is better in that. Unfortunately David in only Windows app.


Wow, thanks, bartosh!  Great video.  Do you think MS is onboard?  Enjoy, John.

EDIT: There was a scheduler problem in Windows for AMD Bulldozer architecture.  MS quickly released a Hot Fix, correcting it.  I just searched for a Hot Fix for Threadripper and found none but did find some people waiting on one.