cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

tomtom_x1234
Journeyman III

S3 Sleep mode disabled with SMT disabled

Jump to solution

When disabling SMT in BIOS, S3 (Energy Save) is also not available anymore on Windows 10. If checking with powercfg/a S3 is not available.

For some application disabling SMT is necessary because of performance benefits (that's also the case for Intel's HT)

S3 disable with SMT disable is not only the case on my motherboard, but also on some others I've seen so far; also some internet research shows that behavior.

Why this happens I don't see a relation, please fix if possible.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
amdmatt
Community Manager
Community Manager

Re: S3 Sleep mode disabled with SMT disabled

Jump to solution

If you are using a Ryzen or Threadripper CPU this is expected behaviour. If you wish to use Sleep mode, you cannot disable cores/threads.

View solution in original post

0 Kudos
3 Replies
amdmatt
Community Manager
Community Manager

Re: S3 Sleep mode disabled with SMT disabled

Jump to solution

If you are using a Ryzen or Threadripper CPU this is expected behaviour. If you wish to use Sleep mode, you cannot disable cores/threads.

View solution in original post

0 Kudos

Re: S3 Sleep mode disabled with SMT disabled

Jump to solution

Why?

0 Kudos
amd_amd
Journeyman III

Re: S3 Sleep mode disabled with SMT disabled

Jump to solution

Just came across this due to noticing this on a 3990x system.  Indeed, why does disabling SMT disable sleep?

Any plans to fix this, can it be fixed with a BIOS/AGESA change?

0 Kudos